cant get localhost to work with IIS5.1 on Windows xp pro

I just got a laptop with Microsoft XP Professional and have installed IIS 5.1. (Came with OS). I am trying to set it up at home where I am always connected to the internet on broadband. I cannot get localhost to work. Please help. I have installed and uninstalled and reinstalled IIS. I have tried starting and stopping the services. I have to have this for an application to work for my job. What else do I need to try? I have Internet Explorer 6, service pack 2. I have even tried reinstallin OS.
Thanks,
Kathy
garvismAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
Dave_DietzConnect With a Mentor Commented:
Is the checkbox next to IPv6 checked or unchecked on the adapters?

You should be able to uncheck it to de-bind it from that adapter.

Dave Dietz
0
 
humeniukCommented:
What happens when you try to access it via http://localhost?  Do you get an error message?

Also, can you access it by IP address?
0
 
garvismAuthor Commented:
I can't access it whatever I do. I have tried http://localhost and http://127.0.0.1 and by my ipaddress and by computer name nothing works. Does this have anything to do with me having a wireless router. I don't know. I am so frustrated
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
garvismAuthor Commented:
sorry..yes, I get page cannot be displayed...with everything I try.
0
 
garvismAuthor Commented:
Also at the bottom of the page cant be displayed error it says cannot find server or dns error internet explorer. I tried doing all of the stuff that the error page suggested.
0
 
humeniukConnect With a Mentor Commented:
Do you have some kind of firewalll running on the server, ie. Windows XP firewall or ZoneAlarm?  If so, try shutting it off to test if you can get through.  If you can, you will need to restart the firewall, then configure it to allow port 80 traffic to reach the server.
0
 
garvismAuthor Commented:
Yes I do have a windows firewall and I just turned it off. Do I have to restart the computer before trying to see if my localhost will work? (with firewall off)
0
 
garvismAuthor Commented:
I turned off the firewall and did not restart the computer...but tried http://localhost/... and it still does not work. Any other suggestions?
0
 
GUEENCommented:
Go to tools  > internet options > advanced  uncheck show friendly http and urls

Next  go to Start > Run   and type   services.msc
Is IIS admin started?
next to IE:
http://localhost
copy/paste error to here.

Last go to: C:\WINDOWS\system32\inetsrv and open iis.msc
Under + web sites what do you have going on there?


0
 
garvismAuthor Commented:
also just wanted to add that when i ping localhost I get the following
reply from ::1: time<1ms
reply from ::1: time<1ms
reply from ::1: time<1ms
reply from ::1: time<1ms

there is no 127.0.0.1 in the reply
0
 
garvismAuthor Commented:
I unchecked show friendly http and urls and now I am not getting an error at all..its just a blank page. what is up with that?
In IIS.msc Under WebSites I have Default website...but I cant even browse the IIS help on local host.
0
 
GUEENCommented:
Do you have the service turned on?
0
 
garvismAuthor Commented:
The page cannot be displayed
The page you are looking for is currently unavailable. The Web site might be experiencing technical difficulties, or you may need to adjust your browser settings.

--------------------------------------------------------------------------------

Please try the following:

Click the  Refresh button, or try again later.

If you typed the page address in the Address bar, make sure that it is spelled correctly.

To check your connection settings, click the Tools menu, and then click Internet Options. On the Connections tab, click Settings. The settings should match those provided by your local area network (LAN) administrator or Internet service provider (ISP).
See if your Internet connection settings are being detected. You can set Microsoft Windows to examine your network and automatically discover network connection settings (if your network administrator has enabled this setting).
Click the Tools menu, and then click Internet Options.
On the Connections tab, click LAN Settings.
Select Automatically detect settings, and then click OK.
Some sites require 128-bit connection security. Click the Help menu and then click About Internet Explorer to determine what strength security you have installed.
If you are trying to reach a secure site, make sure your Security settings can support it. Click the Tools menu, and then click Internet Options. On the Advanced tab, scroll to the Security section and check settings for SSL 2.0, SSL 3.0, TLS 1.0, PCT 1.0.
Click the  Back button to try another link.



Cannot find server or DNS Error
Internet Explorer  


This was my error once the page opened.
0
 
meverestCommented:
in IIS manager, is there more than the default web site?

Right click on one of them->properties->web site->Ip Address->Advanced->Add

in the address box, put "127.0.0.1" in the port put "80" and in the jost header put "localhost"

OK to everything - make any difference now?

Cheers.
0
 
garvismAuthor Commented:
It looks like there are many default websites. I did not have >website under the properties of each individual website, but I did under default website...so I tried it there and it still did not work. There was already an entry in there for Default on port 80....I guess that doesnt matter. Anyway, I tried what you said and it just is not working. Any other ideas??? I definitely need this computer to run the IIS:)
0
 
humeniukCommented:
Since this is running on WinXP/IIS5.1, there can't be more than one website.
0
 
garvismAuthor Commented:
ok, so what do I do? remove all others? What about the iis help stuff?
0
 
humeniukCommented:
Those aren't websites, those are files within the website.  Don't delete those.  'Default Website' is the only website.  Do you have a default document set for the website?
0
 
garvismAuthor Commented:
I am not sure...where would I look?
0
 
garvismAuthor Commented:
Oh yes...under documents there are like 4 default docs if that is what you mean
0
 
garvismAuthor Commented:
Why is it that when I ping localhost I get a strange response that looks like the above :reply from ::1: time<1ms

why does it not say reply from 127.0.0.1? I have been reading other questions on this site, and most of them reply with : reply from 127.0.0.1 time<1ms etc.??
0
 
Dave_DietzCommented:
Check to see if you have IPv6 enabled on your network adapter.  If you do try removing it and see if you get different results from both Ping and trying to access IIS on your machine.

Dave Dietz
0
 
garvismAuthor Commented:
Dave: where would I find Ipv6? I look under Control panel>system>Network adapters>device manager in the Hardware devices area and I have the following:
1394 Net Adapter
Broadcom449x10/100 Integrated Controller
Intel R Pro Wireless 2200BG network Connection.
I use wireless at home and a network connection when I go to work.

When I look in the properties, is that where I would find IPv6...I am not sure that I saw it, but if I am looking in the right place, I will check again.
Please keep helping!!!!
0
 
garvismAuthor Commented:
I just found on the Intel R. Pro Wireless 2200bg network connection that Tcpip version 6 is installed, and so is tcpip. Do I need to uninstall tcpip version 6 from the wireless network?
0
 
garvismAuthor Commented:
I also have the TCPIP version 6 installed on the Broadcom449x10/100 Integrated Controller. Do I need to uninstall them on both of these? I dont see an option to disable, just uninstall.
0
 
garvismAuthor Commented:
It doesnt seem to be working when I unbind both the wireless one and the network one. I tried localhost and nothing is happening.
0
 
garvismAuthor Commented:
Is anyone out there? I am really stuck???? Is there something I am doing wrong with assigning points? I have never done this before. I really need someone to help. I have looked at other questions..I have tried to telnet localhost and it looks like it connects and I get a blank screen. I did unbind ipv6 from both my wireless connection and my nic card. I don't know what else to do. I have disabled all firewalls and still cannot connect to localhost. I have uninstalled and reintalled. Any other ideas.
0
 
humeniukCommented:
What happens if you ping 127.0.0.1 or ping the IP of the laptop?
0
 
GUEENCommented:
0
 
GUEENConnect With a Mentor Commented:
Hold on what firewall did you turn off?  ICMP may still be blocked (won't be able to ping loopback) If it is Symantec you can almost count on that being the culprit.
0
 
garvismAuthor Commented:
I think you are right. I had 2 firewalls...windows firewall...I turned it off...and then there was macafee...that I disabled...but it still didnt work. I saw on another page that someone uninstalled macafee and it worked...and guess what it did. Is that what you meant by ICMP it still being blocked? Well anyway, I am so grateful for all of your help. I guess now I have to figure out how the point thing works. Thanks again
0
 
humeniukCommented:
That's good news.  Good to hear that it's working.

If you have any questions about how the 'points thing' works, let us know.  That should be a bit easier.  Also, you can find official info on your options for closing the question here: www.experts-exchange.com/help.jsp#hs5.
0
 
GUEENCommented:
Yes ICMP being blocked by the firewall is what I meant. You can always go into the properties of the firewall to *allow a range of addresses* and you could include 127.0.0.1
0
All Courses

From novice to tech pro — start learning today.