• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 489
  • Last Modified:

/tmp/socket (2) error on freebsd

I facing with this problem ERROR 2002: Can't connect to local MySQL server through socket '/tmp/mysql.socket' (2).

I am using FreeBSD5.3, apache1.3, php4 and mysql 4.0.3
i go through with all the forum and documentation but failed to solve...

please help
0
operation1611
Asked:
operation1611
1 Solution
 
snoyes_jwCommented:
Is the mysqld service running?
0
 
jnielsendotnetCommented:
How did you install MySQL?  Is it running?  What command are you issuing that gives you that error?

If you installed MySQL from the ports/packages system, you should be able to startt mysqld by giving the 'start' parameter to its startup script:

/usr/local/etc/rc.d/mysql-server.sh start

If it's a recent revision of the port, then you will need to have
mysql_enable=yes
in your /etc/rc.conf for the script to do  anything.

Also, note that the default socket is "/tmp/mysql.sock" (and not mysql.socket, as you wrote).

Finally, I would recommend updating to MySQL 4.1.10 from ports or packages.  You should plan on dumping/restoring your data if you want to preserve it across the upgrade.

JN
0
 
operation1611Author Commented:
thank you...after i upgrade, everything works fine
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now