Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 6350
  • Last Modified:

Workstation Service takes very long time to load

Hello,
I am running Windows XP Pro.  My computer used to start everything very quickly, but recently I noticed that it took a long time for Windows to completely start up. The desktop would appear, and I could run some programs, but most networking tasks did not work.

Upon further investigation, I noticed that my Workstation service gets stuck in the 'Starting' state for more than a minute before it enters the 'Started' state. Once it is in the started state, the system runs fine.

If I change the Workstation service to DISABLED, the computer starts up nice and quick, but obviously lacks the networking capabilites that require the Workstation service.

Starting the Workstation service by typing    NET START WORKSTATION   makes this output:

C:\Documents and Settings\Chris>net start workstation
The Workstation service is starting...............................
The Workstation service was started successfully.


Just for comparison, here is NET START SERVER
The Server service is starting.
The Server service was started successfully.

Notice how many extra dots the workstation has after starting?

The only possible cause I can think of is the other day I downloaded, tried, then uninstalled a few Antivirus programs.   I think the ones I used were:  Kaspersky and Vexira.   I may have tried others, but I can't remember any other names. I know I did not ever install Norton, so I shouldn't be having the 'Norton Leaves Hooks' problems some other people have had.   Are there any known problems uninstalling the two I just listed? I used Windows  Add/Remove programs to uninstall them.



If you need any more information, I will gladly provide it.

Thank you!
0
123abc
Asked:
123abc
  • 7
  • 5
1 Solution
 
mdiglioCommented:
Hello,

See if you can peform a system restore to before these programs were installed
0
 
123abcAuthor Commented:
Unfortunately, System Restore is not enabled. In retrospect,  I might of been able to spare those few gigs for the restore points.

I'm not positive it is those programs that have caused this to start happening, it is just the only thing I can think of that I did differently.

I have tried uninstalling/reinstalling  'Client for Microsoft Networks' in an attempt to reinstall the Workstation service, but it didn't help.
I am going to try creating a new user account and see if it has trouble starting this service also, to narrow it down to just my account issue, or a global issue.
0
 
123abcAuthor Commented:
Creating a new account was no help.

I remembered another anti-virus I tried: AVG.   So that makes it  : Kaspersky, AVG and Vexira.
I also installed/uninstalled GAIM, including the GTK+ kit.  

I don't know if any of this is useful information, but I'm just trying to give you as much as I can.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
mdiglioCommented:
Hello,
Well this is kind of a shotgun approach...

check event viewer for any errors that might relate to or be causing this issue.

Frmo the command line type sfc \scannow ( you'll need your XP CD handy )
When this finishes check windows update and see if you need to reinstall any critical updates

reinstall the latest service pack

0
 
123abcAuthor Commented:
Well, I've gone and made it worse.

There are no interesting messages in event viewer.  I can't locate my XP CD right now to try the SFC /SCANNOW, but I'll find it in the morning and try that.

I tried setting every single service  to AUTOMATIC to make sure I hadn't turned off a service that was needed, but upon reboot it still acted the same, so I set the services back to how they were before.
Now, apparently this changed the order that things load. Now instead of showing me my desktop THEN taking forever to load up Workstation, it takes forever to just show the desktop, but as soon as it shows my desktop everything runs fine. I'm assuming that it is still Workstation service that's slowing it down, but now it loads before the desktop is displayed. I'll search Google a bit more before I go to bed, then in the morning I'll try that SFC thing. Thanks for all of your suggestions, hopefully something will work.
0
 
123abcAuthor Commented:
SFC /scannow   has no effect.  Currently re-downloading SP2.

Checking Event Viewer again, I get these errors/warnings:

WARNING:
Windows saved user SAGER\Chris registry while an application or service was still using the registry during log off. The memory used by the user's registry has not been freed. The registry will be unloaded when it is no longer in use.

 This is often caused by services running as a user account, try configuring the services to run in either the LocalService or NetworkService account.


ERROR:
The Computer Browser service terminated with the following error:
This operation returned because the timeout period expired.


Also, I have 6 instances of SVCHOST running... I know it's ok to have multiple instances, but is 6 too much?

Here is the output of a TASKLIST /SVC

C:\Documents and Settings\Chris>tasklist /svc

Image Name                   PID Services
========================= ====== =============================================
System Idle Process            0 N/A
System                         4 N/A
smss.exe                     720 N/A
csrss.exe                    772 N/A
winlogon.exe                 800 N/A
services.exe                 844 Eventlog, PlugPlay
lsass.exe                    856 ProtectedStorage, SamSs
svchost.exe                 1016 DcomLaunch, TermService
svchost.exe                 1120 RpcSs
acs.exe                     1292 ACS
svchost.exe                 1328 AudioSrv, CryptSvc, Dhcp, dmserver,
                                 EventSystem, FastUserSwitchingCompatibility,
                                 HidServ, Irmon, LanmanServer,
                                 LanmanWorkstation, Netman, seclogon, SENS,                     <----There is the workstation service that takes so long to start up
                                 ShellHWDetection, TrkWks, W32Time, winmgmt,
                                 wuauserv
svchost.exe                 1340 Dnscache
spoolsv.exe                 1524 Spooler
explorer.exe                1788 N/A
ACU.exe                     1916 N/A
aim.exe                     1936 N/A
CrystalCPUID.exe             192 N/A
speedfan.exe                 200 N/A
winamp.exe                   220 N/A
slserv.exe                  2032 SLService
svchost.exe                  128 stisvc
svchost.exe                  924 SSDPSRV
wmiprvse.exe                1636 N/A
firefox.exe                 2000 N/A
mmc.exe                     1684 N/A
taskmgr.exe                 1108 N/A
cmd.exe                      652 N/A
tasklist.exe                1896 N/A
wmiprvse.exe                 536 N/A


Note that Speedfan is used to monitor temperatures, and CrystalCPUID is used to control voltage and cpu speed.  The problem persists even disabling these. Is there anything else that you see that could be a problem?
0
 
123abcAuthor Commented:
Reinstalled SP2, didn't help.

If it helps any, these are all the services that start before Workstation gets started:
http://home.kc.rr.com/chis101/before.jpg

And these are all the services that are started AFTER Workstation gets up:
http://home.kc.rr.com/chis101/after.jpg
0
 
mdiglioCommented:
Concerning the Computer Browser service error...

I don't know how much this applies to the Computer Browser service error you are recieving
because this service is dependent upon the workstation service which is having a hard time starting

The Computer Browser service does not start and event ID 7024 is logged when you restart your Windows XP Service Pack 2-based computer
http://support.microsoft.com/?kbid=875362

Before following these steps you can also try to just shutoff the firewall and see if that corrects any problems.
honestly, I should have recommended that earlier :)
0
 
123abcAuthor Commented:
I already had the firewall disabled, as I am behind a NAT with no ports forwarded.  Just for fun, I tried disabling File/Print sharing, as that article mentioned it. No help.

I'm gonna have to format this thing, aren't I? :-/
0
 
mdiglioCommented:
No, I hope you do not have to redo this machine.

I am running out of suggestions...

- Is the file and printer sharing for ms networks' installed on the properties of your network connection?

- Your task list looks very clean but it won't hurt to check for spyware.
It seems like you keep up with all that stuff but just incase:
MS Anti-Spyware
http://www.microsoft.com/athome/security/spyware/software/default.mspx

- Have you reinstalled SP2 yet ?

- And finally before formatting you can always try to reinstall the OS
I usually use Paul Thurrotts site for slipstreaming sp2 instruction... it is down right now
but a google search for slipstream windows sp2 will give Pauls site as its top match

If it comes down to it on Monday post a 'pointer' to this question this will give
other people here a chance to look at this question

For a pointer question you will title it 'link to 500 point question'
and give that link question a low point value. you'll delete it afterwards
0
 
123abcAuthor Commented:
To some degree I figured it out... Disabling my wireless adapter made everything start up fine. (If I would have even considered it being the problem, I would have mentioned that I am on a laptop w/ a wireless adapter.)  I have stopped using the software that came with my adapter, and am using Windows Wireless Zero Configuration.  This doesn't explain WHY this problem suddenly started happening after months of working fine, but it works now, so I'm happy.

Thanks for all of your help!
0
 
mdiglioCommented:
Well Good..I'm glad you are on the right track
Thanks for the points
0
 
screamerzCommented:
Checkout TweakUI's "Autologon" section!
Sometimes, for example if you have installed Microsoft's Tweak UI, maybe someone set an Username that is not listed in User Management (maybe just mistyped), from the next logon on, windows XP logins with that nonexistent username but Workstation will fail to load. [It's a bug, you can even reload the service to start browsing with that faked username.] To fix it you'll have to go back in that section and retype the correct username and password or simply disable it, than restart the computer. Same thing can happen with wrong registry configuration for Autologon.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 7
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now