Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 462
  • Last Modified:

RPC over HTTP problems SBS 2003

I have a SBS trial machine set up to test RPC over HTTP with Outlook 2003/XP SP2 clients.  Running into a few problems even after searching the useful advice on here.

I set it up first with just the external ip address, but realised it needs dns.  Contacted the ISP and got them to set that up.

The certificate seems to work fine, once its installed I go straight into https://www.<website>/remote

If I go to the rpc page (?) I get the required error message (access forbidden).

Its a single server so I've double checked the registry entries and they all seem ok.

I ended up having problems connecting with outlook even on the network.  I got the error message could not open mail folders and something about OST and terminal services???

When you enter the URL in outlook to connect to, should that be https://www.external.name.com
Should the proxy be msstd:www.external.name.com

Thanks
0
Mad_Lenny
Asked:
Mad_Lenny
2 Solutions
 
Fatal_ExceptionCommented:
Have yet to actually configure this type of connection, but read an article about it a few weeks ago...

http://www.msexchange.org/tutorials/outlookrpchttp.html
0
 
vico1CIOCommented:
What you have described is not Exchange RPC over HTTP That is OWA Outlook Web Access.

I may be wrong but I just want to make sure we are talking about the same thing.

A.- If it is OWA you need to do the following:

Under Server Management
Go to To do List

Run the second option Connect to the internet wizard.

When you reach firewall Chose optin to enable firewall and click next

Make sure that you specified that your users can access outlook from the internet and what ever else that you want them to access

That should solve your problem.


B.- If you are talking about Exchange RPC over HTTP:

The setting must be done at the user level from outlook 2003

this is how you do it:

1.-Install the server certificate at the client side.

to know if the server certificate is installed, Access your server from the web https://yourserver.com (where your server is DNS name or www name)

If the certificate is installed you will not see any warning about Certificate.

if you see a certificate warning:

Click on view certificate and install it.

2.- Now  Go to the client outlook 2003 settings.
Do so by clicking on tools e-mail accounts then select view or Change existing e-mail accounts

there you will need to add the microsoft exchange server.

In fact make sure in the following link that your settings on the server side are ok.
 If you are running SBS 2003, your settings should already be perfect. go to the link and perform Step 5 to connect your client.
http://www.microsoft.com/technet/prodtechnol/exchange/guides/E2k3RPCHTTPDep/1583ab17-f7d1-41c1-ba52-37ec276e3644.mspx

Good luck!

if you have more info or need more info post them.
Vico1
0
 
Mad_LennyAuthor Commented:
Ok thanks for the info so far.  I am talking about RPC over HTTP and not OWA.  OWA is working fine.  I don't get any certificate warning so I don't think that's the problem.  Mine is 'homegrown' though but it should still work.  The next thing is to try freessl and double check my settings i guess.

May try the resource kit and set it up remotely, as I can't get to the server next week.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
SembeeCommented:
I have a lot of information about how to configure the service at both the server and the client side on my web site. http://www.amset.info/exchange

I would definitely recommend using a purchased certificate. It will not only secure your RPC installation, but also your OWA installation and will ensure that you don't get any certificate warnings no matter which you are using.

The msstd: entry should match exactly what is on the certificate. So if your certificate is mail.domain.com then that is what you need to enter.

Make heavy use of outlook.exe /rpcdiag to see what Outlook is doing. Any errors or incorrect configurations and Outlook will fall back to tcp/ip

Finally - get it work internally before you even think about going outside the network. If it isn't working internally then you will have no end of problems.

Simon.
0
 
Mad_LennyAuthor Commented:
Thanks Sembee, i've read your replies to everyone else on this subject!  I installed a certificate from freeSSL which went ok (remotely).  Think I'll have to wait till after easter to connect internally using HTTP, unless I can get my boss to have a go!
0
 
Mad_LennyAuthor Commented:
Oh, and I get the log in box right now with the username but when I put the password in it just goes back to the login screen again.
0
 
vico1CIOCommented:
Then you are successful like I said you have to use the right format for your login

the format is the following: domain\username
0
 
Mad_LennyAuthor Commented:
Haha result it works!  Thanks a lot for the help.  It was a combination of using a real certificate (though possibly it would have worked with a home grown one) and actually using the correct domain name on the login (doh).

I've split the points between vico1 and sembee.
0
 
vico1CIOCommented:
Thanks :)
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now