Windows 2003 PDC unable to open netlogon or Domain Controller Security Policy

I manage a server that has started giving the following problems.

First we noticed that the netlogon share was not able to be accessed. After that we also noticed that Domain Controller Serurity Policy was not availiable.

This all seems to be tied back to the fact that fact that the sysvol share has a different name than the system is looking for. I am unsure how this could be, but the following errors in event view is what lead me to this conclusion.

Event ID: 1058
Windows cannot access the file gpt.ini for GPO CN={31B2F340-016D-11D2-945F-00C04FB984F9},CN=Policies,CN=System,DC=intranet,DC=local. The file must be present at the location <\\intranet.local\sysvol\intranet.local\Policies\{31B2F340-016D-11D2-945F-00C04FB984F9}\gpt.ini>. (The system cannot find the path specified. ). Group Policy processing aborted.

Event ID: 1030
Windows cannot query for the list of Group Policy objects. Check the event log for possible messages previously logged by the policy engine that describes the reason for this.

When I open the "c:\WINNT\SYSVOL\sysvol\intranet.local\Policies" directory the only folder is "{5CC22055-4D2D-4714-B449-0A174D4A6751}".

Does anyone know how I can fix this problem? I have tried Micrsoft KB article 830676 and 842804. These did not seem to help.

Thanks in advance.
mcmincAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

oBdACommented:
If you have more than one DC, check the sysvol folders on all of them. If it's present on one of the others, you have a replication problem.
If you have only one DC, check if you have a valid backup of the sysvol folder, and restore the missing folder.
If you don't have a backup, you can try to recreate the folder manually. Here's a similar issue; this might work for you as well:

Group Policy Error Message When Appropriate Sysvol Contents Are Missing
http://support.microsoft.com/?kbid=253268
0
mcmincAuthor Commented:
I appricate the post, but they did not help me.

I have check the only other DC on the domain and it has the same directory structure.

I do not have a backup as I believe this has been a problem for over a month and our backup scheme does not go back that many days.

If anyone else has a suggestion please let me know.
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

mcmincAuthor Commented:
One other note.

When I restart the netlogon service I get the folloowing error.

Event Type:      Error
Event Source:      NETLOGON
Event Category:      None
Event ID:      5706
Date:            3/20/2005
Time:            12:07:11 AM
User:            N/A
Computer:      TERMSER
Description:
The Netlogon service could not create server share C:\WINNT\SYSVOL\sysvol\intranet.local\SCRIPTS.  The following error occurred:
The system cannot find the file specified.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 02 00 00 00               ....    

Does anyone know how to fix this? If so maybe that will create the share.
0
mcmincAuthor Commented:
BTW: I was going to say that I had already looked at http://support.microsoft.com/default.aspx?scid=kb;en-us;318936 and the Registry entries look good.
0
ajsaastaCommented:
does the netlogon service start and stay up on boot? if not, see http://support.microsoft.com/?kbid=269375.

I had the similar problem on sysvol location, just fix the path to sysvol location and it should work. See articles

http://www.jsifaq.com/SUBI/tip4400/rh4460.htm

and

http://www.jsifaq.com/SUBD/tip1700/rh1794.htm

how to modify registry.
0
oBdACommented:
Have you tried to create the ...\Policies\{31B2F340-016D-11D2-945F-00C04FB984F9} folder manually?
As for the scripts folder--does it exist at all?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mcmincAuthor Commented:
oBdA,

Manually recreating the folders seems to have taken care of the problem. I had to also create the SCRIPTS folder and set the permissions, but it worked. Now all I have to do is recreate all the login scripts.

Thanks.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.