Apostrophes result in Error 553: mailbox name not allowed or chunk too large

I have the same problem as several others who have reported this problem.  An outside sender cannot send to us, and this sender has an apostrophe in their email address .. I'm running Exchange 2000 under W2K with a Watchguard FB1000.  All of our email goes to an outside service that supplies spam filtering; anything not filtered out is passed through to our firewall.  The firewall is set to use SMTP proxy for incoming, and I've set that to allow apostrophes.  The spam service reports the 553 message to the outside sender, and reports that it came from our server.  In other words, the spam service is not trapping these emails. It looks like Exchange is rejecting them, not the firewall.  An earlier response to someone who had this problem with Exchange 5.5 suggested upgrading to Exchange 2000, but I have the same problem.  Is there a setting in Exchange that I've missed?
RBECKMNAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SembeeCommented:
I think you need to look at your Watchguard. While I was researching another issue I found a number of people reporting that this is caused by an SMTP filter on the Watchguard. If that feature is enabled, turn it off (can't tell you exactly what it is called as I don't have a Watchguard to refer to).

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
RBECKMNAuthor Commented:
I thought I had adjusted the SMPT filter on the firewall, but I forgot to write the configuration change back to the firewall, so it was still set at the default, which does excludes apostrophes, quotes, and several other characters.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.