• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3817
  • Last Modified:

jsp compilation

Hi all,

i've installed the weblogic 7.0 + SP5. I've deployed a simple application with some jsps. My servers runs in debugging mode with the exploded structure. My jsp's are compiled during startup (set to true in weblogic.xml). My  application is working fine. Now when i update a jsp i want the jsp to be compiled automatically so i just have to refresh to page. But thats not happening... I receive  errors saying :

C:\bea\user_projects\mydomain\jspwd\myappwa\jsp_servlet\__index.java:132: isResourceStale(java.lang.String,long,java.lang.String) in weblogic.servlet.jsp.StaleChecker cannot be applied to (java.lang.String,long,java.lang.String,java.lang.String)
        if (sci.isResourceStale("/index.jsp", 1111477352468L, "7.0.5.0", "Europe/Paris")) return true;

How can I resolve the issue so that automatic compilation can be achieved ?

below is my weblogic.xml
-----------------------------
<weblogic-web-app>
  <jsp-descriptor>
    <jsp-param>
      <param-name>workingDir</param-name>
      <param-value>C:/bea/user_projects/mydomain/jspwd/myappwa</param-value>
    </jsp-param>
    <jsp-param>
      <param-name>precompile</param-name>
      <param-value>true</param-value>
    </jsp-param>
    <jsp-param>
      <param-name>keepgenerated</param-name>
      <param-value>true</param-value>
    </jsp-param>
    <jsp-param>
      <param-name>noTryBlocks</param-name>
      <param-value>true</param-value>
    </jsp-param>
  </jsp-descriptor>
</weblogic-web-app>

in my config.xml i have:
---------------------------
    <Application Deployed="true" Name="_appsdir_myapp_ear"
        Path=".\applications\myapp.ear" StagedTargets="" TwoPhase="false">

Thanks and regards,
Dries
0
drieske
Asked:
drieske
3 Solutions
 
sompol_kiatkamolchaiCommented:
I think it's java programming problem. It's not the problem caused by WebLogic server.

As I see in the error you dump, I found that in the index.jsp file have some missing argument passing in method isResourceStale(String, long, String, String)

Please check the argument of the method isResourceStale in the class of sci instance. I think your team member update the class and not notify you.

In the code, you call this.
sci.isResourceStale("/index.jsp", 1111477352468L, "7.0.5.0", "Europe/Paris")
But in the class of sci instance does not have this method signature.

Best Luck,

SOMPOL
0
 
drieskeAuthor Commented:
Hi sompol,

hmmm first if all thanks for your answere..

but what does it mean isResourceStale ? and how come it works fine i mean how come that during startup of WL  all jsp's gets compiled fine without this error ?

Thx,
Dries
0
 
koppchaCommented:
I am using WL8.1 in this i create a domain in userprojects and run the application ...when ever i do any modifcations to the JSP page i just have to refresh the page.Let me know if this is the same in WL7.0 otherwise i will try it in 7.0 and let you now
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
rama_krishna580Commented:
Hi,

The Best and ODD suggestion will be, always remove the compiled jsp files from the directory "..\jsp_classes\jsp_servlet". Look for this path and remove when ever you got any changes in the JSP page and you want to load the new page changes. This will be one solution which you can try it...!

R.K
0
 
drieskeAuthor Commented:
hi Nuti Rama Krishna,
tried your solution (deleting the compiled jsp files) but same problem... below is the console output:

<Mar 23, 2005 11:16:12 AM CET> <Error> <HTTP> <101017> <[ServletContext(id=7097929,name=myapp.war,context-path=/myapp)] Root cause of ServletException
weblogic.servlet.jsp.CompilationException: Compilation of C:\bea\user_projects\myappdomain\jspwd\myappwa\jsp_servlet\__index.java failed.
        at weblogic.servlet.jsp.JspStub.compilePage(JspStub.java:445)
        at weblogic.servlet.jsp.JspStub.prepareServlet(JspStub.java:215)
        at weblogic.servlet.jsp.JspStub.checkForReload(JspStub.java:150)
        at weblogic.servlet.internal.ServletStubImpl.getServlet(ServletStubImpl.java:557)
        at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:377)
        at weblogic.servlet.internal.TailFilter.doFilter(TailFilter.java:20)
        at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:27)
        at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:27)
        at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:5632)
        at weblogic.security.service.SecurityServiceManager.runAs(SecurityServiceManager.java:685)
        at weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppServletContext.java:3213)
        at weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java:2555)
        at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:251)
        at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:219)
>

thx,
dries
0
 
drieskeAuthor Commented:
all,

Finally i found the issue; I use a lib folder wich contains all .jar files and my classpath was still pointing to the weblogic.jar of 7.0 and not the one of 7.0SP5 which is different.

will split the point between the persons who helped the most ..
Thx
0

Featured Post

[Webinar] Database Backup and Recovery

Does your company store data on premises, off site, in the cloud, or a combination of these? If you answered “yes”, you need a data backup recovery plan that fits each and every platform. Watch now as as Percona teaches us how to build agile data backup recovery plan.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now