• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1042
  • Last Modified:

Kernel Asynchronous I/O

I have ASE 12.5.3 running on Red Hat Enterprise Linux 3.0 and I would like to start using Kernel Asynchronous I/O. But log of may ASE still shows:
"Enabling (RT) Posix asynchronous disk I/O strategy.".

And it really seems, that ASE is using Posix Asynchronous I/O, because when I try to set extended cache (I have created /dev/shm acording to "ASE Large Memory Support for Linux 32.pdf" and then tried sp_configure "extended cache size", 1024) it fails and in log I see:

Large Memory feature requires Linux Kernel asynchronous disk I/O strategy.
Please fix the server to use Kernel aio or disable 'extended cache size'.


So, does anybody know, how to "fix the server" to use Kernel aio ?
0
Jan Franek
Asked:
Jan Franek
  • 3
  • 2
1 Solution
 
Joe WoodhousePrincipal ConsultantCommented:
Jan, apologies if this is an annoying thing to say but let's eliminate the simple things first...

Is the sp_configure parameter "allow sql server async i/o" enabled?

Is traceflag 1630 enabled (probably at boot time, check the RUN_SERVER file?)

In earlier versions (12.5.0.3, 12.5.1), Sybase recommended disabling KAIO and using Posix threads by using one or both of these methods, but they're not needed in ASE 12.5.3...

ASE 12.5.3 on RHEL 3.0 is supposed to use KAOI out of the box, so I'm guessing you might have upgraded from an earlier ASE version?
0
 
Jan FranekAuthor Commented:
> Is the sp_configure parameter "allow sql server async i/o" enabled?
 
Yes, it's set to 1. The server actually uses asynchronous I/O - but the Posix one.

> Is traceflag 1630 enabled (probably at boot time, check the RUN_SERVER file?)

No, it isn't.

And yes, it's upgraded system - 12.5.0.3 -> 12.5.2 -> 12.5.3

May be I forgot to mention, that we use filesystem devices, but AFAIK it should work on both filesystem and raw devices.
0
 
Joe WoodhousePrincipal ConsultantCommented:
I figured you'd've covered the obvious questions but it's always worth checking.

About all I can suggest now is to try creating a brand new test server on the same host with the same ASE binaries and see if it gets KAIO out of the box?

And yes, I agree, ASE 12.5.3 on RHEL 3.0 (or indeed 2.1) is supposed to use KAIO by default unless either of the two parameters/traceflags above are used. And yes, as of 12.5.3 it shouldn't matter if it's file or raw...

Maybe raise this with Sybase Tech Support? If I think of anything else I'll let you know...

Good luck!
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Jan FranekAuthor Commented:
I have called Sybase TP and I've got quite strange answer - they want me to try to raise max memory configuration parameter to see, if it will help ASE to create extended cache. Now I use 2.7 GB (max memory=1380000) and I want to add 1 GB extended cache and they want me to set max memory to 3.7 GB. I'm not sure if I want to try it - it seems like very strange idea. And it seems to me, that this can't help ASE to use KAIO.
0
 
Jan FranekAuthor Commented:
Well, we have sorted it out - it seems that our instalation of RHEL didn't contain libaio library. After instalation of this library, ASE started to use Kernel Asynchronous I/O and now I can create extended cache.
0
 
moduloCommented:
Closed, 500 points refunded.

modulo
Community Support Moderator
Experts Exchange
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now