?
Solved

I can not go to # prompt

Posted on 2005-03-22
15
Medium Priority
?
702 Views
Last Modified: 2013-12-16
I have a problem with my server; I have a unix box with SCO OpenServer 5.0.5 and everything was OK but today I was making some tests and I tried to stop the gated daemon typing "gated SIGKILL" as I saw it in the command help, but after the system didn't respond anymore; I restarted but now while botting I have a message saying "fsstat: root file system needs cheking" then there is a cheking process and I finally I see a resume like this:

** Root file system
NO PARTIAL TRANSACTIONS PENDING
FILE SYSTEM STATE SET TO OKAY
53176 files 1623721 blocks 298762 free

*** ROOT FILE SYSTEM WAS MODIFIED ***

*** ROOT REMOUNTED MODIFIED ***

... and that's all, the system does not respond.

I need help!!!
0
Comment
Question by:drodalejo
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 4
  • 3
  • +1
15 Comments
 
LVL 21

Expert Comment

by:tfewster
ID: 13606120
Please see http://wdb1.sco.com/kb/showta?taid=105411 for fixing root filesystem problems
0
 
LVL 38

Assisted Solution

by:yuzh
yuzh earned 1000 total points
ID: 13607593
To boot up to single user mode, power on the PC as soon as you see "boot", type in <enter>.

You might have problem with the filesystem, do a "fsck" to all your filesystem and try again.
(it is better to use  emerency FDs to boot up to single user mode to fix the problem).

Have a look at:
http://wdb1.sco.com/kb/showta?taid=105411
http://www.acersupport.com/ess/techart/multi_sco_filesystem.html

to learn more details.

also see http:Q_21350803.html
0
 

Author Comment

by:drodalejo
ID: 13615273
The problem here is that when I power on the PC, and after typing <enter> when "boot:" appears, just before I can see the (Type CRTL+D or password ....) to enter in single user mode I receive the following:

fsstat: root file system needs checking.
OK to check the root file system (/dev/root)? (y/n)

if I answer "yes" I get the message posted in my first post and if I answer "no" I get nothing, so independently of my answer I cannot enter, the system does not respond anymore.

I have used the emergency disks to boot up to single user mode and I tried /etc/fsck -ofull <Enter> but I receive an error saying that /etc/checklist could not be found so I tried fsck -s -ofull -D  /dev/hd0root and this found some problems so I chose to repair them and the final message I receive is that the filesystem was modified. At this point everything seems to be ok but when I reboot I have the same problem as nothing had been done.

Thanks
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 38

Expert Comment

by:yuzh
ID: 13617996
After you get into single user mode, did you following the procudure in:
     http://wdb1.sco.com/kb/showta?taid=105411

If you still have problem, used the emergency disks to boot up to single user mode , then
run "divvy" to find out all the filesystem device (Warming, do NOT make any change to
the partion table, just write down the partion name, otherwise you will LOST data!)

then do a fsck to all the filesystem, this will involved a lot off human intervention, if you are
 not sure what to do you need to get someone know SCO (NOT other Unix favour!) to do it
for you.

       
0
 
LVL 7

Expert Comment

by:sppalser
ID: 13630738
Have you tried booting the system without any operator intervention? The file "ioctl.syscon" may be corrupted.  You may want to boot from your boot/root floppies and go thru your filesystem checks first.  After doing that do a reboot on the machine and let it boot on its own.  when the boot: prompt comes up "DO NOT" press enter--let it time out, which should be about 60-seconds.  By doing the fsck's from floppy above the system should not stop and ask about doing a filesystem check.  If the decision sceen about pressing <CTL>-D or entering the system password to go to maintenance mode comes up "DO NOT" do anything here either--let it time out--should be about 30-seconds.  When the date and time query comes up "DO NOT" enter anything here either--let it time out.  If the system comes up to a login you should login as root then go to the etc directory and do the following:

     # ls -l ioctl.syscon

you should get something like:

     lrwxrwxrwx  1 root     sys   44 Aug 12 2004 ioctl.syscon > /var/opt/K/SCO....

If you see the "l" at the beginning of the permissions then cd to the path shown after the greater than symbol then "remove" the ioctl.syscon file at that location.

if the permissions above start with a dash (-rw...) then remove the ioctl.syscon file from the etc directory.

After removing the ioctl.syscon file do a shutdown and reboot.  You should be able to boot as you normally would.  The file /etc/ioctl.syscon will be recreated during the boot process.  

This is a known "gothca" on openserver 5.  The system only checks for the presence of the file at boot time it does not check it for corruption.  If the file is not found a new one is created.  But if it is there the system will just go on--however if the file is corrupt what you have described above can happen.

Good Luck
0
 

Author Comment

by:drodalejo
ID: 13653048
yuzh,

I followed the procedure step by step and after reboot I was able to enter normally, without any warning or error message. I thought all my problems had gone but when I reboot the computer for a second time I had exactly the same problem.

sppalser,

I want to probe your solution but at this time the only way to enter the system is using the emergency floppies, I cannot boot the machine on its own because it hangs up after listing the devices during the boot process.

So, do you guys think this problem can be solved?? I have used all the utilities to verify system integrity and in theory there have been fixed all the problems by these utilities but after a reboot the problem is present again. What else can I do??

Thanks!
0
 
LVL 7

Accepted Solution

by:
sppalser earned 1000 total points
ID: 13653427
You may need to go further with the investigation.  If you go to the following link to SCO's knowledge center:

     http://wdb1.sco.com/kb/showta?taid=103157&qid=701755389&sid=208738208&pgnum=1

You will find the TA #103157 which outlines the fix for what you have described above.  In 90+ percent of the cases just doing the ioctl.syscon will take care of it.  But in your case you may need to follow the rest of the fixes outlined in the TA.  

Maybe a silly question here at this point, but you are doing a proper shutdown when rebooting?

Have you tried booting an alternate kernel?  At the "boot:" prompt you can type "unix.old" or "unix.install" or on some systems there is a "unix.safe" or if you had saved any kernels to a different name you should try one of those.

Once you are able to get the system to come up so that you can tell it to go to single user mode it will hurt anything to go through TA 105411 "Completely".  The link is:

     http://wdb1.sco.com/kb/showta?taid=105411&qid=610583246&sid=208738208&pgnum=1

If you still have trouble you may need to knock the system down to minimal hardware and see if it will come up.  If it does then start adding hardware back in one at a time to see if the problem comes back.  Sometimes if it is the hardware a good cleaning and reseating of the cards and cables fixes a lot of stuff.

Good Luck
 
0
 
LVL 7

Expert Comment

by:sppalser
ID: 13653464
Should have mentioned as well, when booted on the boot/root set, did you check your filesystems for free space?  Full root filesystems can cause a lot of grief.

Good Luck
0
 

Author Comment

by:drodalejo
ID: 13656497
Well, I finally was able to get the system come up using the "unix.safe" as you pointed and I followed all steps in the SCO's knowledge center's article but once again all this was unuseful. Tomorrow I'm going to open the machine to make a good cleaning as you suggest.

I have checked the filesystem for free space and this is not the problem. And in relation to your question about my method to reboot, I have been doing this using "init 6" or "reboot" but also due to my problem I have been doing a lot of cold boots when the machine hangs up.

Tomorrow I'll let you know the situation after cleaning the machine.
0
 
LVL 38

Expert Comment

by:yuzh
ID: 13657949
also check /var/adm/messages file to see if any errors.
0
 

Author Comment

by:drodalejo
ID: 13664839
I cleaned the machine, all cards and cables but still no luck. I checked /var/adm/messages and there aren't errors. At this time the only way to get the system come up is using the "unix.safe" alternate kernel, any other ideas???
0
 

Author Comment

by:drodalejo
ID: 13664920
Is it something about the kernel??
0
 

Author Comment

by:drodalejo
ID: 13666114
Well I think it is a issue with the kernel cause continuing with different tests I have discovered that if the kernel is rebuilded, for example, if I change the nic configuration and let the system to rebuild the kernel and set it as default to boot, when I reboot I can enter the system normally, without any error message. I can reboot as many times as I want and everything is ok, but sadly I also discovered that if I turn off the machine, when I power on it again I'm in the beginning, I have the same problem.

Any comment would be appreciated!!
0
 
LVL 38

Expert Comment

by:yuzh
ID: 13667583
Boot up your box again, use scoadmin to reconfig you the kernel (get rid of all the devices
which is no longer in your box), relink the kernel, and reboot.

if the kernel is clean up and you still have trouble, the next thing to look at your hardware,
eg mainborad etc.
0
 

Author Comment

by:drodalejo
ID: 13681308
Well I think I'm going to close this question, I can't figure out what the problem is but I have had the machine working for the last two days without problems and as I said in a previous post I can reboot normally but when I shutdown I have the problem again. However I have now the recipe to come up the system again; I have to enter using "unix.safe" then I relink the kernel and finally I reboot the system.

I know this is not the best solution but I really don't know why I have this problem everytime I shutdown the system and assuming that I'm not going to be shuting down the system frequently I can live with this.

Thank you guys, I'm going to split the points because I have learned a lot from both of you.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

My previous tech tip, Installing the Solaris OS From the Flash Archive On a Tape (http://www.experts-exchange.com/articles/OS/Unix/Solaris/Installing-the-Solaris-OS-From-the-Flash-Archive-on-a-Tape.html), discussed installing the Solaris Operating S…
Using libpcap/Jpcap to capture and send packets on Solaris version (10/11) Library used: 1.      Libpcap (http://www.tcpdump.org) Version 1.2 2.      Jpcap(http://netresearch.ics.uci.edu/kfujii/Jpcap/doc/index.html) Version 0.6 Prerequisite: 1.      GCC …
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
In a previous video, we went over how to export a DynamoDB table into Amazon S3.  In this video, we show how to load the export from S3 into a DynamoDB table.
Suggested Courses

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question