?
Solved

Cisco PIX 501 firewall, cannot access web from pcs

Posted on 2005-03-22
11
Medium Priority
?
773 Views
Last Modified: 2013-11-16
I have received my new Cisco PIX 501 after reading very good reviews.

I have plugged everything in, run through the wizard and all seems good. *NOT*

I have a cisco 2600 router with a couple of bonded T1 lines which works great without a firewall connected

I have connected the crossover lead from the router to the firewall and then a standard cat5 cable from the pix to a pc

I can connect ok from pc to pix
I can ping from pix to the 2600 router and isp dns ip addresses

All lights on the cisco router look ok and both interfaces seem to be up ok

I do not want DHCP turned on, I want to set up internal ips manually and map them to external/public ips which I have been provided by my ISP

I have no experience with cisco equipment as you can see. i have set up many cheap firewalls without any probs but this is not as simple

Hope somebody can help

Thanks
0
Comment
Question by:drawles
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 3
  • +1
11 Comments
 
LVL 13

Expert Comment

by:gpriceee
ID: 13605270
Can you get into the firewall and see the config?
Did you change your gateway on the workstation to match the IP address of the inside interface of the pix?
If you can find your config, don't post it with actual ip addresses or the actual hash for the passwords.
0
 
LVL 32

Expert Comment

by:harbor235
ID: 13605378
Is the PIX in front of or behind the router? Please post both configs

harbor235

0
 
LVL 79

Expert Comment

by:lrmoore
ID: 13605456
>I can connect ok from pc to pix
>I can ping from pix to the 2600 router and isp dns ip addresses
You can ping and http to the PIX from the PC?
What are you using for DNS server IP address? You can't use the PIX IP for that.
You'll need to post the config of the PIX.. From the GUI, File | Show running config in new window - cut/paste and edit the real public IP's and any password..
0
Get real performance insights from real users

Key features:
- Total Pages Views and Load times
- Top Pages Viewed and Load Times
- Real Time Site Page Build Performance
- Users’ Browser and Platform Performance
- Geographic User Breakdown
- And more

 

Author Comment

by:drawles
ID: 13605721
Yes I did change the the ip to match the ip address of the inside interface
The PIX is behind the router
the config is here

Building configuration...
: Saved
:
PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password
passwd
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside ***.***.***.194 255.255.255.192
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
route outside 0.0.0.0 0.0.0.0 ***.***.***.*** 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.129 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:420f5a3e6052795f7aef1af6dc624e5f
: end
[OK]

I have set up my pc with both dns ip as 192.168.1.1 (pix ip) and with the dns ips given from my ISP and neither way works or allows access to the net
0
 

Author Comment

by:drawles
ID: 13605744
>You can ping and http to the PIX from the PC?

Yes I can do that fine

>What are you using for DNS server IP address? You can't use the PIX IP for that.

I thought so but I tried with the DNS ips supplied by the ISP and they dont work either
0
 

Author Comment

by:drawles
ID: 13605820
I have access to the web now!  but I still cant ping the dns servers from the dos prompt, how odd

is that something to do with icmp packets not being allowed back?

0
 
LVL 79

Accepted Solution

by:
lrmoore earned 75 total points
ID: 13605848
> but I still cant ping the dns servers from the dos prompt, how odd
Not odd at all. The PIX will not allow icmp responses back from an inside host unless you expressly permit it with an access-list.

Try adding this:
  access-list icmp permit icmp any any echo-reply
  access-group icmp in interface outside

0
 
LVL 13

Assisted Solution

by:gpriceee
gpriceee earned 75 total points
ID: 13605854
Change ethernet0 to a specific speed:
interface ethernet0 100full
For 100full, replace it with the appropriate speed: 10baset, 10full, 100basetx, 100full, 1000basesx, or 1000sxfull

I assume your route outside address is the ethernet interface on the 2600.

If you don't want DHCP, then you need to enter the following commands:
no dhcpd address 192.168.1.2-192.168.1.129 inside
no dhcpd lease 3600
no dhcpd ping_timeout 750
no dhcpd auto_config outside



0
 

Author Comment

by:drawles
ID: 13606041
Thanks for your help guys, no doubt I will be back with more questions!

I will add the settings you have provided

I guess splitting the points is the right thing to do?


0
 
LVL 79

Expert Comment

by:lrmoore
ID: 13606080
Glad to help! Point split is just fine with me.
0
 
LVL 13

Expert Comment

by:gpriceee
ID: 13606109
Welcome to the pix.  The split is fine with me too.
0

Featured Post

Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

For many of us, the  holiday season kindles the natural urge to give back to our friends, family members and communities. While it's easy for friends to notice the impact of such deeds, understanding the contributions of businesses and enterprises i…
This month, Experts Exchange’s free Course of the Month is focused on CompTIA IT Fundamentals.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…
Suggested Courses
Course of the Month12 days, 13 hours left to enroll

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question