?
Solved

remote GUI access to Fedora

Posted on 2005-03-24
7
Medium Priority
?
6,620 Views
Last Modified: 2007-11-27
Here is a situation.

I have a linux machine (fedora) that I can access from outside the network. The fedora has got only a command line access to it or in other words , x windows may not be running. I donot have physical access to that box.

What I want to do is , from outside the network , I should be able to open a browser in that box or in other words run some kind of x windows or x server and then use cygwin or VNC (preferable) from my windows machine so that I can open the browser.  

Any ideas ?

SR
0
Comment
Question by:sunray_2003
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
7 Comments
 
LVL 8

Assisted Solution

by:marxy
marxy earned 800 total points
ID: 13622656
Yes. You can load vnc server on the linux box and, then, access it from ouside as a GUI.
There is very goo article how to install it step by step.
http://linuxreviews.org/howtos/xvnc/

0
 
LVL 38

Accepted Solution

by:
wesly_chen earned 1200 total points
ID: 13625066
Hi,

   From your previous question
http://www.experts-exchange.com/Networking/Linux_Networking/Q_21307171.html

   You have already setup vnc or ssh pass through your firewall.

   The next thing will be get gnome running in vnc.

   Edit ~/.vnc/xstartup
---------
#!/bin/sh

# Uncomment the following two lines for normal desktop:
# unset SESSION_MANAGER      # <==== Uncomment these 2 lines
# exec /etc/X11/xinit/xinitrc        # <====

[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
gnome-seesion &  (or "startkde &")   #  <=== Change from "twm &" 
--------

   Then restart the vncserver.

   Then from the vncviewer, you will get the Gnome desktop as if you are in front of the machine (monitor).

   However, the vnc use bitmap graphic transfer, so the performance (refresh rate) is kind of bad on the slow link.
So Xwindow might be better on slow connection.

   For Xwindow to run on M$ Windows, you need to have Xserver softwares such as Hummingbird Exceed or cygwin/X
(http://x.cygwin.com/) running on your PC. (or check Xwindow in cygwin setup )

   So open a Xterm with startxwin.exe in cygwinX, then use "ssh -X <IP or FC3> -p <port number>" in Xwindow.
It will forward the display to your PC. Then start "mozilla" or "firefox" in Xwindow, the browser will come to
your Windows PC. However, this part is kind of trick since your firewall on PC (or on remote site) might block the traffic.

Regards,

Wesly
0
 
LVL 49

Author Comment

by:sunray_2003
ID: 13625125
Wesly,

When I run vncserver  on the linux , it gives this

New 'localhost.localdomain:2 (root)' desktop is localhost.localdomain:2
Starting applications specified in /root/.vnc/xstartup
Log file is /root/.vnc/localhost.localdomain:2.log

and then from windows machine , i use vncclient to connect to it and when I give

<ip address>:5092 , it doesnot connect.  Actually, windows and Linux are on the same network.


0
Congratulations! You’re Certified – Now What?

Starting a new career can be overwhelming. Becoming certified in your field of expertise is a great start, but where do you go from here?  Here are some tips to help you on your career journey.

 
LVL 38

Expert Comment

by:wesly_chen
ID: 13625160
> windows and Linux are on the same network
Then it should be
<ip address>:2
:5902 is for the machine outside your firewall or webbrowser.
0
 
LVL 49

Author Comment

by:sunray_2003
ID: 13625221
something is screwy here.. it says unable to connect to host if i try <ip address>:2.. It used to work before but not sure why it is not , now.

When i run vncserver, i remember it asking for password but then  after restarting the machine, when i started vncserver again by giving the command "vncserver", it never asked for any password..
0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 13625315
It asks for passwd only once.
Then the passwd is encrypted and stored in ~/.vnc/passwd.
You can remove it and regenerate the password if you want.

Make sure your firewall on FC3 not block the VNC.
service iptables stop  
0
 
LVL 49

Author Comment

by:sunray_2003
ID: 13625352
>> service iptables stop
that helped..

SR
0

Featured Post

Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
In this video, Percona Solution Engineer Dimitri Vanoverbeke discusses why you want to use at least three nodes in a database cluster. To discuss how Percona Consulting can help with your design and architecture needs for your database and infras…
Suggested Courses

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question