?
Solved

Cannot see package body in TOAD

Posted on 2005-03-24
4
Medium Priority
?
5,746 Views
Last Modified: 2013-12-12
The package body should be able to be seen when you click on the "+" next to the package on procs tab of TOAD. But I can not see the package body for any packages with my ID on my PC, only specs. The DBA logged in with my ID on her TOAD. She was able to see the package bodies. Has anybody met the same problem? Is there any configuration I missed in TOAD? I also tried the Load Database Object tool in procudure editor. When I chose the object type as Package Body, I didn't get anything.

Thanks!

0
Comment
Question by:HoaiTrangPhan
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
4 Comments
 
LVL 11

Expert Comment

by:sujit_kumar
ID: 13650304
See if you have the GRANT to see the package body. There is no such settings in TOAD to see the package body.

For testing create a test package in your own userand try to view it in the Object Browser.
0
 
LVL 7

Expert Comment

by:Mehul Shah
ID: 13651347
Have you tried reinstalling toad
0
 
LVL 11

Accepted Solution

by:
pennnn earned 2000 total points
ID: 13654839
Not sure if this makes sense, but I remember having the same problem a while ago with a different tool, I think (not TOAD). Surprisingly enough, the solution was to grant "create any procedure" to the user having the problem.
I just tested that in TOAD and I was able to reproduce the problem and the solution I just described solves it. Of course, you should be careful granting "create any procedure" (as with any other "create ANY" privilege).
Hope that helps!
0
 

Author Comment

by:HoaiTrangPhan
ID: 13657023
Pennnn,

Granting "create any procedure" to me solved the problem! I am surprised. Thank you so much for help me out...
Thank you all who answered this question!
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Why doesn't the Oracle optimizer use my index? Querying too much data Most Oracle developers know that an index is useful when you can use it to restrict your result set to a small number of the total rows in a table. So, the obvious side…
Have you ever had to make fundamental changes to a table in Oracle, but haven't been able to get any downtime?  I'm talking things like: * Dropping columns * Shrinking allocated space * Removing chained blocks and restoring the PCTFREE * Re-or…
This video explains at a high level with the mandatory Oracle Memory processes are as well as touching on some of the more common optional ones.
Video by: Steve
Using examples as well as descriptions, step through each of the common simple join types, explaining differences in syntax, differences in expected outputs and showing how the queries run along with the actual outputs based upon a simple set of dem…
Suggested Courses

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question