?
Solved

Can not get split-tunneling to work on PIX 515 (Cisco VPN client)

Posted on 2005-03-24
12
Medium Priority
?
403 Views
Last Modified: 2013-11-16
I can not get split-tunneling to work on a PIX 515.  With the config below, when connected via the Cisco VPN client I can browse out, but I can not see any of the hosts behind the firewall.  When I try to ping hosts behind the firewall the VPN client statistics show the packets as being digarded.

<config>
PIX Version 6.3(4)
interface ethernet0 100full
interface ethernet1 100full
interface ethernet2 auto shutdown
interface ethernet3 auto shutdown
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 intf2 security4
nameif ethernet3 intf3 security6
enable password /xxx encrypted
passwd xxx encrypted
hostname fortress
domain-name xxxxx.com
clock timezone CST -6
clock summer-time CDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.50.0 Ergodyne_Inside
name 192.168.1.0 Crown_Net
access-list 2004032501 permit tcp anyx255.255.255.224 eq www
access-list 2004032501 permit tcp any x92 255.255.255.224 eq citrix-ica
access-list 2004032501 permit tcp any x255.255.255.224 eq 3389
access-list 2004032501 permit tcp any host xx eq smtp
access-list 2004032501 permit tcp any host xx eq pop3
access-list 2004032501 permit tcp any host xx eq imap4
access-list 2004032501 permit tcp any host xx eq 135
access-list 2004032501 permit tcp any host xx eq 445
access-list 2004032501 permit tcp any host xx gt 1000
access-list 2004032501 permit udp any host xx eq ntp
access-list 2004032501 permit udp any host xx eq 135
access-list 2004032501 permit udp any host xx.213 gt 1024
access-list 2004032501 permit tcp any host xx eq 135
access-list 2004032501 permit tcp any host xx eq 445
access-list 2004032501 permit icmp any host xx
access-list 2004032501 permit tcp any host xx gt 1024
access-list 2004032501 permit tcp any host xx eq smtp
access-list 2004032501 permit tcp any host xx eq pop3
access-list 2004032501 permit tcp any host xx eq imap4
access-list 2004032501 permit tcp any host xx eq 135
access-list 2004032501 permit tcp any host xx eq 445
access-list 2004032501 permit tcp any host xxgt 1000
access-list 2004032501 permit udp any host x eq ntp
access-list 2004032501 permit ip host x any
access-list 2004032501 permit tcp host xxany
access-list 2004032501 permit udp host xx any
access-list 2004032501 permit ip xx255.255.255.0 any
access-list 2004032501 permit tcp any host xx eq 11000
access-list 2004032501 permit tcp any host xx eq 11001
access-list 2004032501 permit tcp any host xx eq 11002
access-list 2004032501 permit tcp any host xx eq 11020
access-list 2004032501 permit ip xx 255.255.255.0 any
access-list 2004032501 permit ip xx255.255.255.0 any
access-list 2004032501 permit tcp any host xxeq smtp
access-list 2004032501 permit tcp any host xxeq pop3
access-list 2004032501 permit tcp any host 209.117.210.216 eq imap4
access-list 2004032501 permit tcp any host 209.117.210.216 eq 135
access-list 2004032501 permit tcp any host 209.117.210.216 eq 445
access-list 2004032501 permit tcp any host 209.117.210.216 gt 1000
access-list 2004032501 permit udp any host 209.117.210.216 eq ntp
access-list 2004032501 permit icmp any host 209.117.210.210
access-list 2004032501 permit icmp any any
access-list outside_cryptomap_60 permit ip 10.12.14.0 255.255.255.0 Crown_Net 255.255.255.0
access-list inside_outbound_nat0_acl permit ip 10.12.14.0 255.255.255.0 Ergodyne_Inside 255.255.255.0
access-list inside_outbound_nat0_acl permit ip 10.12.14.0 255.255.255.0 MN_Air 255.255.255.0
access-list inside_outbound_nat0_acl permit ip 10.12.14.0 255.255.255.0 Crown_Net 255.255.255.0
access-list inside_outbound_nat0_acl permit ip 10.12.14.0 255.255.255.0 192.168.17.0 255.255.255.0
access-list outside_cryptomap_20 permit ip 10.12.14.0 255.255.255.0 Ergodyne_Inside 255.255.255.0
access-list outside_cryptomap_40 permit ip 10.12.14.0 255.255.255.0 MN_Air 255.255.255.0
access-list SecureVPN_splitTunnelAcl permit ip 10.12.14.0 255.255.255.0 192.168.17.0 255.255.255.0
access-list SecureVPN_splitTunnelAcl permit ip 192.168.17.0 255.255.255.0 10.12.14.0 255.255.255.0
access-list outside_cryptomap_dyn_20 permit ip any 192.168.17.0 255.255.255.0
no pager
logging on
logging timestamp
logging monitor debugging
logging buffered debugging
logging queue 0
no logging message 710005
no logging message 302015
no logging message 302014
no logging message 304001
no logging message 302016
icmp permit any outside
icmp permit any echo-reply outside
icmp permit any echo outside
icmp permit any inside
icmp permit any echo inside
icmp permit any echo-reply inside
mtu outside 1500
mtu inside 1500
mtu intf2 1500
mtu intf3 1500
ip address outside xx 255.255.255.224
ip address inside 10.12.14.196 255.255.255.0
no ip address intf2
no ip address intf3
ip audit info action alarm
ip audit attack action alarm
ip local pool VPNPool 192.168.17.1-192.168.17.254
failover
failover timeout 0:00:00
failover poll 15
failover ip address outside xx
failover ip address inside 10.12.14.197
no failover ip address intf2
no failover ip address intf3
pdm location 10.12.14.201 255.255.255.255 inside
pdm location 10.12.14.202 255.255.255.255 inside
pdm location 10.12.14.203 255.255.255.255 inside
pdm location 10.12.14.204 255.255.255.255 inside
pdm location 10.12.14.205 255.255.255.255 inside
pdm location 10.12.14.206 255.255.255.255 inside
pdm location 10.12.14.210 255.255.255.255 inside
pdm location 10.12.14.211 255.255.255.255 inside
pdm location 10.12.14.212 255.255.255.255 inside
pdm location 10.12.14.213 255.255.255.255 inside
pdm location 10.12.14.214 255.255.255.255 inside
pdm location 10.12.14.215 255.255.255.255 inside
pdm location 10.12.14.222 255.255.255.255 inside
pdm location 10.12.14.192 255.255.255.224 inside
pdm location xx 255.255.255.255 outside
pdm location xx255.255.255.255 outside
pdm location 172.16.1.0 255.255.255.0 outside
pdm location 10.12.14.207 255.255.255.255 inside
pdm location 10.12.14.208 255.255.255.255 inside
pdm location 10.12.14.209 255.255.255.255 inside
pdm location 10.12.14.216 255.255.255.255 inside
pdm location 10.12.14.217 255.255.255.255 inside
pdm location 10.12.14.218 255.255.255.255 inside
pdm location 10.12.14.219 255.255.255.255 inside
pdm location 10.12.14.220 255.255.255.255 inside
pdm location 10.12.14.221 255.255.255.255 inside
pdm locationxx 255.255.255.0 outside
pdm location xx255.255.255.255 outside
pdm location xx 255.255.255.0 outside
pdm location xx 255.255.255.0 outside
pdm location Ergodyne_Inside 255.255.255.0 outside
pdm location 10.12.14.223 255.255.255.255 inside
pdm location 10.12.14.224 255.255.255.255 inside
pdm location 10.12.14.198 255.255.255.255 inside
pdm location 10.12.14.199 255.255.255.255 inside
pdm location 10.12.14.200 255.255.255.255 inside
pdm location MN_Air 255.255.255.0 outside
pdm location Crown_Net 255.255.255.0 outside
pdm location 10.12.14.64 255.255.255.224 outside
pdm location 192.168.17.0 255.255.255.0 outside
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) xx 10.12.14.201 netmask 255.255.255.255 0 0
static (inside,outside) xx10.12.14.217 netmask 255.255.255.255 0 0
< removed by Ozzmod>
access-group 2004032501 in interface outside
route outside 0.0.0.0 0.0.0.0 209.117.210.193 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server RADIUS (inside) host 10.12.14.213 w1nd3x0r1g1n@l timeout 10
aaa-server LOCAL protocol local
ntp server 192.5.41.41 source outside
ntp server 192.5.41.40 source outside prefer
http server enable
http 0.0.0.0 0.0.0.0 outside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-DES-MD5
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer 216.183.115.150
crypto map outside_map 20 set transform-set ESP-DES-SHA
crypto map outside_map 40 ipsec-isakmp
crypto map outside_map 40 match address outside_cryptomap_40
crypto map outside_map 40 set pfs group2
crypto map outside_map 40 set peer x
crypto map outside_map 40 set peer x
crypto map outside_map 40 set transform-set ESP-DES-MD5
crypto map outside_map 60 ipsec-isakmp
crypto map outside_map 60 match address outside_cryptomap_60
crypto map outside_map 60 set peer x
crypto map outside_map 60 set transform-set ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map client authentication RADIUS
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address x netmask 255.255.255.255 no-xauth no-config-mode
isakmp key ******** address xnetmask 255.255.255.255 no-xauth no-config-mode
isakmp key ******** address x50 netmask 255.255.255.255 no-xauth no-config-mode
isakmp key ******** address x netmask 255.255.255.255 no-xauth no-config-mode
isakmp identity address
isakmp keepalive 60 60
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash sha
isakmp policy 20 group 1
isakmp policy 20 lifetime 28800
isakmp policy 40 authentication pre-share
isakmp policy 40 encryption des
isakmp policy 40 hash md5
isakmp policy 40 group 2
isakmp policy 40 lifetime 28800
vpngroup SecureVPN address-pool VPNPool
vpngroup SecureVPN dns-server x10.12.14.214
vpngroup SecureVPN wins-server 10.12.14.213 10.12.14.214
vpngroup SecureVPN default-domain xxxxxxxxxxx.com
vpngroup SecureVPN split-tunnel SecureVPN_splitTunnelAcl
vpngroup SecureVPN idle-time 1800
vpngroup SecureVPN password ********
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
terminal width 80
</config>
0
Comment
Question by:makman111
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 6
12 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 13626587
>access-list SecureVPN_splitTunnelAcl permit ip 192.168.17.0 255.255.255.0 10.12.14.0 255.255.255.0
You need to remove that line. Source should always be your internal network..

These lines are the primary consideration
>access-list inside_outbound_nat0_acl permit ip 10.12.14.0 255.255.255.0 192.168.17.0 255.255.255.0
>access-list SecureVPN_splitTunnelAcl permit ip 10.12.14.0 255.255.255.0 192.168.17.0 255.255.255.0
>vpngroup SecureVPN split-tunnel SecureVPN_splitTunnelAcl


0
 

Author Comment

by:makman111
ID: 13626614
I removed that line but when I try to ping an internal IP, it times out.  I can ping external IPs.

When I ping external IPs the VPN client stats increments that "packets bypassed" field.
When I ping internal IPs the VPN client stats increments that "packets discarded" field - not the packets "encrypted field"
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 13626628
Add this line..

isakmp nat-traversal 20

0
WatchGuard's M Series Appliances - Miecom Approved

WatchGuard's newest M series appliances were put to the test by Miercom.  We had great results and outperformed all of our competitors in both stateless and stateful traffic throghput scenarios! Ready to see how your UTM appliance stacked up? Download the Miercom Report!

 

Author Comment

by:makman111
ID: 13626664
why 20?
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 13626686
That's the default ... make it 30 if you want...
0
 

Author Comment

by:makman111
ID: 13626699
No change.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 13626733
Do you have your client set to Enable Transparent Tunneling / IPSec over UDP (NAT/PAT)
Can I assume that whatever you are trying to ping has its default gateway pointing to the pix, and you are not trying to ping the PIX inside interface ip?

What version client? Windows XP w/SP2?
Has it ever worked?
0
 

Author Comment

by:makman111
ID: 13626783
I do have " Enable Transparent Tunneling / IPSec over UDP (NAT/PAT)" on.
That is correct I am trying to ping a host with a default GTWY of the pix.  I am not pinging the pix.
0
 

Author Comment

by:makman111
ID: 13626807
it has not worked (yet) - windows XP sp2
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 13626815
What version client?
0
 

Author Comment

by:makman111
ID: 13626959
3.6.3a
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 2000 total points
ID: 13626985
Version 4.05 and 4.6 were specifically released to be compatible with XP/SP2
You might just have to upgrade the client. Do you have CCo account to download?
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Wikipedia defines 'Script Kiddies' in this informal way: "In hacker culture, a script kiddie, occasionally script bunny, skiddie, script kitty, script-running juvenile (SRJ), or similar, is a derogatory term used to describe those who use scripts or…
To setup a SonicWALL for policy based routing to be used with the Websense Content Gateway there are several steps that need to be completed. Below is a rough guide for accomplishing this. One thing of note is this guide is intended to assist in the…
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…
In this video, Percona Director of Solution Engineering Jon Tobin discusses the function and features of Percona Server for MongoDB. How Percona can help Percona can help you determine if Percona Server for MongoDB is the right solution for …
Suggested Courses

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question