?
Solved

Configuring Cisco 1721 T1 Router  LAN Interface

Posted on 2005-03-24
5
Medium Priority
?
631 Views
Last Modified: 2008-02-01
I am new to programming routers. I need to configure a Cisco 1721 router with a T1 WIC. Can someone post the configuration code. Here is the ip information:

Primary WAN:
IP: 66.83.158.182
Gateway/Default Route: 66.83.158.181
Subnet Mask: 255.255.255.252
 
Secondary WAN:
IP: 65.23.7.193
Subnet Mask: 255.255.255.224
 
Primary DNS Server: 64.89.70.2
Secondary DNS Server: 64.89.74.2
 
LAN IP: 216.215.174.254
Subnet Mask: 255.255.255.240

Frame Relay IETF encapsulation
I dont think NAT is needed.

I know how to login to the router and that's about all. Also what are the commands to ping a site after done configuring? Let me know if more information is needed.
0
Comment
Question by:sonnye2000
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 4

Expert Comment

by:piersonm
ID: 13627906
Here something to start with....let me know if you run into problems.

service tcp-keepalives-in
service tcp-keepalives-out
service timestamps log datetime msec local show-timezone
service timestamps debug datetime msec local show-timezone
service password-encryption
no service dhcp

hostname <add your router name here>

enable secret <encrypted-password>
username <user1> privilege 15 secret <encrypted password>
username <user2> privilege 15 secret <encrypted password>

aaa new-model
aaa authentication login default local
aaa authorization exec default local

no ip domain-lookup
ip tcp synwait-time 5
no ip  source-route
clock timezone EST -5

interface loopback 10.1.1.1 255.255.255.255

ip domain-name <enter your domain name here>
ip name-server 64.89.70.2
ip name-server 64.89.74.2
ip subnet zero

interface FastEthernet0
  ip address 216.215.174.254 255.255.255.240
  speed 100
  duplex full
  no ip directed-broadcast
  no shutdown
interface s0
  bandwidth xxx
  no ip address
  encapsulation frame-relay
  no shutdown
interface s0.1
  ip address 66.83.158.182 255.255.255.252
  frame-relay interface-dlci <remote side DLCI>
  no arp frame-relay
interface s0.2
  ip address 65.23.7.193 255.255.255.224
  frame-relay interface-dlci <remote side DLCI>
  no arp frame-relay

router eigrp 1
  network 0.0.0.0
  no auto-summary
  eigrp log-neighbor-changes

ip route 0.0.0.0 0.0.0.0 66.83.158.181

logging on
no logging console
logging monitor debugging
logging buffer 4096 debugging
logging trap warnings

line con 0
  privilege level 15
  logging synchronous
  login authentication default
line aux 0
  no login authentication
line vty 0 4
  logging synchronous
  password <your password>
  login authentication default
0
 
LVL 11

Accepted Solution

by:
-Leo- earned 2000 total points
ID: 13627958
login to the router
enter to the enable mode with "enable" command
type:

configure terminal

int fa0/0
ip address 216.215.174.254 255.255.255.240
no shutdown

int Serial0/0                               (I beleive you have this interface, other wise do "sh interfaces" first to see its name/number)
enacpsulation frame-relay ietf
bandwidth   xxx                         (your bandwidth)
no ip address
no shutdown
!
interface Serial0/0.1 point-to-point
bandwidth xxx                           (your bandwidth)
ip address 66.83.158.182 255.255.255.252
ip address  65.23.7.193 255.255.255.224 secondary
frame-relay interface-dlci xxx     (check with ISP about DLCI number)

ip name-server 64.89.70.2
ip name-server 64.89.74.2

ip route 0.0.0.0 0.0.0.0 66.83.158.181

end
-------------------------------------------------------------------------------------
Basicly this should work, but you have to try and see
0
 

Author Comment

by:sonnye2000
ID: 13627967
Can you give an explanation of "remote side DLCI"? Thanks.
0
 

Author Comment

by:sonnye2000
ID: 13627969
never mind the DLCI comment
0
 
LVL 11

Expert Comment

by:-Leo-
ID: 13627974
Frame Relay using DLCI's (Data Link Connection Identifiers) and to set-up Frame Relay properly, you have to define these DLCI's

You can read about FR here: http://www.cisco.com/univercd/cc/td/doc/cisintwk/ito_doc/frame.htm
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Problem Description:   Couple of months ago we upgraded the ADSL line at our branch office from Home to Business line. The purpose of transforming the service to have static public IP’s. We were in need for public IP’s to publish our web resour…
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question