Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Cisco 2600 T1 w/BGP crawls at 345k.

Posted on 2005-03-24
2
Medium Priority
?
1,507 Views
Last Modified: 2013-12-12
Hi,

I have a new failover T1 configuration that is currently running on the failover side due to a router being down. I am running BGP with partial routes. Since the install I can not get speeds of any greater than 345k down and 900k up. Pinging the wan interface of my router shows alot of packet loss but my interfaces are clean and I have tried a different cable run. I can ping my upstream with <10ms replies and have tested out in front of the router and am getting full speed. I did a router reload this evening and now have only gotten one prefix. Was getting them earlier. My hardware is not taxed at all and I am baffled. Here is my show run:

Building configuration...

Current configuration : 2036 bytes
!
version 12.2
service nagle
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname n4m-2600
!
logging buffered 4096 debugging
no logging console
no logging monitor
enable secret 5
enable password 7
!
clock timezone EST -5
clock summer-time EDT recurring
ip subnet-zero
no ip source-route
ip flow-cache timeout active 1
!        
!
no ip domain-lookup
ip name-server x.x.x.x
ip name-server x.x.x.x
!
no ip bootp server
ip audit notify log
ip audit po max-events 100
ip ssh time-out 120
ip ssh authentication-retries 3
!
call rsvp-sync
cns event-service server
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address x.x.x.x 255.255.255.252
 duplex auto
 speed auto
 no cdp enable
 no mop enabled
!
interface FastEthernet0/1
 ip address x.x.x.x 255.255.255.128
 duplex auto
 speed auto
 no cdp enable
 standby 1 ip x.x.x.x
 standby 1 preempt
!
router bgp 0000
 no synchronization
 bgp log-neighbor-changes
 network x.x.x.x
 network x.x.x.x
 neighbor x.x.x.x remote-as 0000
 neighbor x.x.x.x next-hop-self
 neighbor x.x.x.x soft-reconfiguration inbound
 neighbor x.x.x.x remote-as 0000
 neighbor x.x.x.x soft-reconfiguration inbound
 neighbor x.x.x.x route-map AS-MYNET-OUTGOING-UPDATES out
 no auto-summary
!
no ip classless
ip route x.x.x.x 255.255.255.0 Null0 245
ip route x.x.x.x 255.255.255.128 x.x.x.x
ip route x.x.x.x 255.255.255.0 x.x.x.x
ip route x.x.x.x 255.255.255.0 Null0 245
no ip http server
ip pim bidir-enable
!
access-list 2 permit x.x.x.x
access-list 2 permit x.x.x.x
no cdp run
route-map AS-MYNET-OUTGOING-UPDATES permit 10
 match ip address 2
 set as-path prepend 0000 0000 0000 0000
!
!
!
dial-peer cor custom
!
!        
!
!
!
line con 0
 login
line aux 0
line vty 0 4
 access-class 1 in
 exec-timeout 60 0
 password 7 11030E5C33190F2925
 login
 transport input telnet
!
no scheduler allocate
end


0
Comment
Question by:pakitloss
2 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 2000 total points
ID: 13633535
Try adding a default route and enabling ip classless

ip classless
ip route 0.0.0.0 0.0.0.0 x.x.x.x  <== "upstream" ip of your ISP

0
 

Expert Comment

by:hairymonster
ID: 14335494
By omitting all the IP address info you may have hidden a possible BGP issue (flapping). Can you check if your BGP neighbors are statically reachable (either directly connected or you have to add a static route; otherwise a BGP can experiencing an internal loop if a nex-hop is also learned via BGP and the neighborships start flapping).
The other common cause of problems is the autonegotiated speed and duplex on the ethernet ports. I suggest you change that to whatever is really supported by the other end (e.g. "duplex full" and "speed 100").
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Cable Modem Provisioning from DPoE compliant server  This Article is to support CMTS administrators to provide an overview of DOCSIS compliance configuration file, and to provision a cable modem located at customer place from a Back office serve…
Last month, the FCC voted to repeal Title II, the framework supporting net neutrality across all broadband ISPs. We sat down with Doug Walton, database administrator at Experts Exchange to gauge his opinion of what will happen next.
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an anti-spam), the admin…
Despite its rising prevalence in the business world, "the cloud" is still misunderstood. Some companies still believe common misconceptions about lack of security in cloud solutions and many misuses of cloud storage options still occur every day. …
Suggested Courses
Course of the Month11 days, 19 hours left to enroll

564 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question