• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 271
  • Last Modified:

Linux system wont boot. Not sure what to do :(

Hey fello EE'ers, I just got a compaq presario on my bench thats running linux on it ( I think the exact distro is "gentoo"). The estimate only said "check machine for problems" so you can imagine my slight shock and suprise when I saw the system going through a linux load process when i powered it on.  I've tried to boot the system three times and it keeps freezing at the exact same spot in the process. Here are the last two lines that the boot process generates before it pauses:

EXT2-fs: ide0(3,3): Couldn't mount because of unsupported optional features (4).
Kernel panic: VFS: Unable to mount root fs on 03:03

Now, despite being an IBM techie for the most part, I have had enough experience with linux operating systems to have a pretty good ideal of what the system is trying to tell me. I'm just dont have much of a clue at to what my next (or first) move should be.
If anyone could help out, i'd really appreciate it. Late ^_^

-Zerous
0
Zerous
Asked:
Zerous
1 Solution
 
wesly_chenCommented:
> Kernel panic: VFS: Unable to mount root fs on 03:03
Make sure your kernel has a "root=" parameter passed to it in your bootloader and that the parameter points to your root file system. Such as
kernel (hd0,0)/boot/bzImage-2.6.1-rc2-gentoo-1 root=/dev/hda2
For Grub boot loader, "e" on the boot menu, and press 'e" to edit boot menu as the line above.
Make sure your root (/) is right (/dev/hda2 in this example).

For more details, you can check:
http://forums.gentoo.org/viewtopic.php?t=122524

Wesly
0
 
mburdickCommented:
You might want to get a copy of a "live" CD like System Rescue CD (http://www.sysresccd.org) or Knoppix (http://www.knoppix.org). Boot from them and you should at least be able to "fdisk /dev/hda" and then "p"rint the partition table out.

Knoppix will boot you straight into a GUI and [hopefully] show you the partitions it sees on the hard disk. You can then drill into the directories and look at configuration options.

I know it isn't anywhere near a "solution", but it should get you started in the right direction.
0
 
theruckCommented:
start the gentoo livecd and try to mount your partition where the linux besides. then edit the /etc/fstab according to your needs - you should have a line like this:
/dev/hda3            /            ext3            noatime                  0 0

i think that you will have something else instead of the ext3 put there.
0
 
wesly_chenCommented:
> VFS: Unable to mount root fs
For this kind of error message, it comes right after boot loader, earlier than mount the filesystem in /etc/fstab.
So it could be
1. Filesystem corrupted, use LiveCD or boot CD to boot and run "fsck" to fix the filesystem.
2. Wrong boot "root" device, which is specified in boot loader. My first post address this issue.
3. Corrupted boot table, especially, this disk is "Ghost" clone. Need to rebuild the boot loader to fix.
    Boot from previously made boot floppy or boot from CD into rescue modd and run
    grub /dev/hda  (or  grub-install /dev/hda)
    to rebuild the boot loader.
4. Filesystem type mismatch or unrecoverable error on the filesystem. Then reinstall OS...

Regards,

Wesly
0
 
ZerousAuthor Commented:
Sorry about taking so long to get back....but I got the problem fixed. Turned out to be a corrupted file system like u said. Thanks :)
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now