?
Solved

X doesn't start, screen constantly turns on and off, small cursor visible during on cycle in Fedora Core 3.

Posted on 2005-03-27
5
Medium Priority
?
250 Views
Last Modified: 2013-12-15
I upgraded from FC2 to FC3, on a system which worked well.

Now, every time I start up, it gets to the point where it tries starting xorg-x11, and the screen changes mode as normal, i see a mouse cursor, and less than a second later, the screen changes mode.  I tried a different monitor, and it has the same effect.

I tried pressing ctrl-alt-backspace to kill the server and enter command line - but it didn't work.  Perhaps I should note that the keyboard does not seem to respond once X tries to start (num lock etc are not functional)

How can I resolve this?  Or failing that, how can I access the command line?

p.s. this machine has no cd-drive and I have no startup disk
0
Comment
Question by:vincevincevince
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 8

Expert Comment

by:marxy
ID: 13642294
Look at X server log files /var/log/X*log.
There is an error printed, i think.
0
 
LVL 1

Author Comment

by:vincevincevince
ID: 13642463
Marxy, many thanks for your reply

Do you know how I can access the log file?  As soon as the machine starts up it starts cycling loading and crashing X.  Even if I try to log in at the prompt that comes before X - by the time I can type in username and password the screen has been taken over by X and the keyboard no longer works.

I can't find a way to kill this X server cycling :S
0
 
LVL 8

Assisted Solution

by:marxy
marxy earned 500 total points
ID: 13642480
Try entering single mode
After grub displays login screen
press 'e'
then, add to boot string
init=/bin/sh rw

and press 'b' to boot

This will load single mode.
0
 
LVL 14

Accepted Solution

by:
theruck earned 500 total points
ID: 13645042
your keyboard driver for the xorg is not properly set
if you wait a minute the X respawning should stop with error: X respawning too fast. Disabled for * minutes. and you will be able to log on normally and to edit your xorg.conf and set your keyboard.
0
 
LVL 1

Author Comment

by:vincevincevince
ID: 13652973
theruck - I think it is not respawning slowly enough.  I finally gave up I'm afraid, and used the advice from marxy to burn a CD of my data from the command line, reformatted and installed FC3 clean.

Many thanks for your help.
0

Featured Post

WordPress Tutorial 2: Terminology

An important part of learning any new piece of software is understanding the terminology it uses. Thankfully WordPress uses fairly simple names for everything that make it easy to start using the software.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

rdate is a Linux command and the network time protocol for immediate date and time setup from another machine. The clocks are synchronized by entering rdate with the -s switch (command without switch just checks the time but does not set anything). …
In part one, we reviewed the prerequisites required for installing SQL Server vNext. In this part we will explore how to install Microsoft's SQL Server on Ubuntu 16.04.
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Suggested Courses
Course of the Month7 days, 23 hours left to enroll

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question