?
Solved

Linux setup -- dual boot with Dos, Debian Linux, and Win2k Pro Svpk IV

Posted on 2005-03-27
14
Medium Priority
?
482 Views
Last Modified: 2013-12-06
 I have been running Win2k and Dos for awhile and attempted to install Debian Linux.  After the install, i get a lot of problems.  The Linux boot menus give me three options: 1) Linux, 2) other drive, and 3) Windows.

  The Windows option in the Linux boot menu won't work.  The other Drive option will work, but it takes forever to boot to Win2k.  After booting into Win2k, My Computer won't show anything and the file saving routine appears to be dysfunctional in Win2k.  I have been able to get around the dysfunctional file saving routine, but it is very slow and tedious.

  On this website I found another person with a very similar problem as me, except that he was trying to dual boot with Red Hat.  One of the comments posted was that a person would copy the master boot record from Linux into Windows, but I wasn't able to get in contact with the person who posted this message.

  I was just advised by someone that Linux should always be installed first before attempting to install Win2k because Win2k will overwrite the MBR.  My question is there a way to still install Linux if Win2k and dos are already installed?  What do I need to do to clean this thing up.  I have changed the primary boot drive a couple of times from Dos to Linux and back to Dos.  Do I need to fdisk /mbr?  Or can I copy the MBR somewhere?  Dos and Win2k were installed on my computer before Debian Linux was installed.

  I am getting a daisy chained Linux boot menu and Win2k boot menu when I select the second option "other drives" in the Debian Linux boot menu.  Can dos, linux, and win2k all be run on the same computer?  Or do I need to sacrifice dos?    Win2k does require that dos is the primary boot drive if Win2k is installed and run as a dual boot.

ZCorker


0
Comment
Question by:ZCorker
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
  • 2
  • +1
14 Comments
 
LVL 14

Expert Comment

by:theruck
ID: 13644693
what bootloader do you use?
0
 
LVL 14

Expert Comment

by:theruck
ID: 13644734
>> I was just advised by someone that Linux should always be installed first before attempting to install Win2k
incorrect exactly the oposite way is better
>> Can dos, linux, and win2k all be run on the same computer?
yes of course
>>win2k does require that dos is the primary boot drive if Win2k is installed and run as a dual boot
then you will have jkust 2 options in your boot menu 1st linux and 2nd DOS and the DOS will show you a new boot menu for booting DOS or WIndows
0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 13648968
Hi,

   Could you post your bootloader configuration files
/etc/grub.conf
or
/etc/lilo.conf
and the output of
fdisk -l
in Linux?

Wesly
0
Secure Your WordPress Site: 5 Essential Approaches

WordPress is the web's most popular CMS, but its dominance also makes it a target for attackers. Our eBook will show you how to:

Prevent costly exploits of core and plugin vulnerabilities
Repel automated attacks
Lock down your dashboard, secure your code, and protect your users

 
LVL 6

Expert Comment

by:admin0
ID: 13655757
Hi,

Contrary to the suggestion to install linux first, and then win2k, I would not recommend that. Once linux is setup, and you install win2k/xp, it will overwrte the MBR and you will have a hassale to boot into linux again.

My recommendation is:

1. install win2k/XP first, and ensure that it is running all OK.
2. install linux (I recommend a derivate of debian - UBUNTU http://ubuntulinux.org), and it will automatically recognize and add your win2k as a boot option, giving you a choice to boot win2k by default or linux by default.

-- install and that's it. its not that complicated.

Another easier way is to install XOSL-- xtended operating system loader ... installs via windows platform, nice and easier way for booting multiple systems, with password protection.


Cheers,


0
 

Author Comment

by:ZCorker
ID: 13658050
 Dos and Win2k were installed on my system prior to Linux Debian.  I would like to save the current installation of Debian if at all possible.  I have been reading some posts with people encountering similar problems with Red Hat and Win2k dual boot.  Apparently there is a registry fix for this malaise.  However, my problem is more severe since my disk manager won't appear.

  I am running Lilo as my boot loader.  I get a daisy chain between the Lilo boot menu and the win2k boot menu when I select the 2nd option -- other operating systems.

  I suspect that Win2k is having trouble recognizing the ext2(3) Linux file system.  During the bootup and after selecting Windows in the windows boot menu, I get prompted on every single bootup to have Win2k run chkdsk on the F: drive (Linux).  When it runs this, it shows the drive as Fat 32.  Should it be something else?  In addition, the chkdsk routine for this drive is extremely slow.

  It takes forever to finally boot into Win2k.  I am communicating with you via Win2k, but would like to get Linux hooked up to the net.  I am going to take a class in Linux as soon as I get Linux workiing.  How do i get Win2k to recognize the ext2(3) file system?  Once recognized, will chkdsk still run on the F: drive?

  I would like to keep my current installation and just add a few fixes.

ZCorker
0
 

Author Comment

by:ZCorker
ID: 13664238
 How do I copy the output of fdisk -I?  What is fdisk -I?  I am a newbie so please be patient.  

ZCorker
0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 13664555
It is
fdisk -l    (not -I)
To "List" your disk device table (or partition table).

> chkdsk on the F: drive (Linux).  When it runs this, it shows the drive as Fat 32
It seems either your partition corrupted or you installed the Dibian on a FAT 32 partition.
Do "df -k" in Debian will tell you the filesystem type.

> How do I copy the output of fdisk -l?
fdisk -l > /tmp/sysinfo
echo "" >> /tmp/sysinfo
df -k >> /tmp/sysinfo
Then copy the file /tmp/sysinfo to Windows partition or floppy.
0
 

Author Comment

by:ZCorker
ID: 13678509
Thanks for the clarification and extra help on accessing the partition table in Linux.  Currently I bootup straight to the login prompt and password.  Do I need to enter a name and password in order to get to a screen that I could type the commands for /etc/lilo.conf and fdisk l?

  I am having trouble loggin on in an unconnected state?  Looks like I forgot my name and password combination or something else is going on.  How do I retrieve this?

ZCorker
0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 13678599
If you use LILO as boot loader, type "Ctrl + X" and boot menu and type
linux single
to boot into single user mode, which you don't need to type username and password.
It will go into root shell prompt.
0
 

Author Comment

by:ZCorker
ID: 13689268


  I did type Linux single and then got prompted to give the root password for maintenance or type
Control -D for startup.  What is the root password?

ZCorker
0
 
LVL 38

Accepted Solution

by:
wesly_chen earned 375 total points
ID: 13689566
Well, Debian need rot password to get into single user mode.
Please boot from boot disk (or knoppix LiveCD), then mount your root filesystem on /mnt, and blank out the
password field for root in /mnt/etc/passwd, as so:
root::0:0:root:/:/bin/sh

Now root has no password; when you reboot from the hard drive you should
be able to login as root and reset the password using passwd.
0
 

Author Comment

by:ZCorker
ID: 13695367
 I booted from boot disk and was prompted with a menu that had several options:
   
     1) Repartition disk
     2) Initialize
     3) Mount

  I am not sure what you mean by mount file system on /mnt?  Is /mnt a directory that I create?  Or is this something that should show up on my screen after selecting one of the above options?  If so, which option should I select to get this?

  Your help is really appreciated.

ZCorker


0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 13695422
>  which option should I select to get this?
3) mount

/mnt is a direcotory. Just type in
mount /dev/hda1 /mnt  #<=== Check your "/" partition with command "df -k" in normal boot,
         change /dev/hda1 to your root partition
0
 

Author Comment

by:ZCorker
ID: 13704287
  I booted from the debian ISO that I downloaded from the net and I selected the "mount" option from the menu of choices.  At this point the computer gives me the option of selecting /hda1, /hda5, and /hda6, but it doesn't give me the option of typing      
"mount /dev/hda1 /mnt".  Also, I am unable to check the "/" partion with command "df -k" in normal boot because I am still getting the request for name and password in normal mode.

   One of the several options in the Linux Menu is "Edit Kernel Boot Parameters".  Do I need to do anything with this?

  When selecting the "partition option" in Linux I get the following:

      /dev/hda1                           Dos
      /dev/hda5:                         Win 95   Fat 32   (LBA)
     /dev/hda6:          Boot          Linux native

  However, when the Linux Boot Menu shows up it shows:

               1)  Linux
               2) Other ops
               3) Windows

  Win2k is accessed through "other ops".  

  One possible solution, but not necessarily the best would be to remove the Linux partition and reformat it to Win95 and reinstall Debian Linux with someone online.  I do have another computer along side of me and it might be helpful if someone was on ICQ walking me through the Linux installation sequence.  Debian appears to install very rapidly and I don't think it would take more than 3-5 minutes at the most.  However, I still have some doubts as to how we would fix the things you suggested.  You indicated in your last message that I need to make sure that /dev/hda1 to root partition is accomplished, but I am not certain that this isn't already happening.

 After reading the postings under dual boot problems with Red Hat and Win2k on this website, I would conclude that Win2k may not be recognizing the File (2) ext system.  The postings offered a registry fix in Win2k that cured the problem and the reports in later postings appeared to indicate that the problem was fixed and that Win2k started booting rapidly again.  Although Red Hat is different than Debian, the differences are small and I have a hunch that the registry fix might help
in my case.  Even then there are still other problems.

ZCorker
0

Featured Post

Get MongoDB database support online, now!

At Percona’s web store you can order your MongoDB database support needs in minutes. No hassles, no fuss, just pick and click. Pay online with a credit card. Handle your MongoDB database support now!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you use Debian 6 Squeeze and you are tired of looking at the childish graphical GDM login screen that is used by default, here's an easy way to change it. If you've already tried to change it you've probably discovered that none of the old met…
It’s 2016. Password authentication should be dead — or at least close to dying. But, unfortunately, it has not traversed Quagga stage yet. Using password authentication is like laundering hotel guest linens with a washboard — it’s Passé.
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
Suggested Courses
Course of the Month10 days, 4 hours left to enroll

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question