Data pump conversion errors

I've exported from a Solaris box running 10.1.3  and now trying to import to Win2003 server running 10.1.3.  I'm getting errors on all rows.


ORA-02374: conversion error loading table "STUDENT"."COURSE_TERM_TB2"
ORA-01401: inserted value too large for column

ORA-02372: data for row:             TERM : 0X'200820202020202020200320202008202
0202020

I created only a tablespace on the Windows box expecting the export to define and create the tables.  Looking at that original table, the TERM is defined as CHAR 3.
What kind of conversion happened and how do I fix it?

xoxomosAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
schwertnerConnect With a Mentor Commented:
It is possible to export from one OS and to import in another
but only if in upwards or equal versions of Export/Import/dataPump Utility.

Yes, export should define the tables. But you should use BINARY mode when moving the
dumps between platform. If you do not do this the dump will get corrupted.

Data Pump works strange so far and produces many errors.
I will recommend to use Export/Import.
0
 
helpneedCommented:
hi

A row could not be loaded into the table because there was a conversion error for one or more columns in a row.  

See the message that follows for more information about the row that could not be loaded. To avoid this error, make sure the        definition of the table being imported matches the definition of  the table being exported.  

it is not possible to export from one os and to import into other...

regards
0
 
xoxomosAuthor Commented:
The faq at Oracle's otn says you can.
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
xoxomosAuthor Commented:
Can I move a dump file set across platforms, such as from Sun to HP?

Yes, Data Pump handles all the necessary compatibility issues between hardware platforms and operating systems.

0
 
helpneedConnect With a Mentor Commented:
hi

u can use pump itself

If you use Data Pump and experience a failure, you may be able to easily correct the problem and then use the Data Pump restart capability without any loss of data, and without having to completely redo the operation

regards
0
 
xoxomosAuthor Commented:
I've switched to export.  Looks like all the tables, procedures, packages etc were defined when i tried the data pump import.  Just the data is missing from the tables.  Original export gives errors stating these objects were already created, but it doesn't put the data in either.
0
 
schwertnerCommented:
Yesterday I tried again to use Data Pump.
I run into bugs. Oracle promised to fix them in the Release 10.1.0.4.
This release IS AVAILABLE on Metalink for Windows, Linux, etc., since March 28, 2005.
Enjoy!
0
 
xoxomosAuthor Commented:
These machines are x86-64 linux and 64 bit Solaris.
0
All Courses

From novice to tech pro — start learning today.