?
Solved

Default browser for opening http links in thunderbird

Posted on 2005-03-29
7
Medium Priority
?
351 Views
Last Modified: 2010-04-20
Under SuSE 9.2 have set default browser to be firefox (set under componen setting ...control panel). Whenever I click on a http link in an email it always lauches mozilla browser, not firefox. I did have this working (found how to do this via a web page, but can't find it anymore), but recently upgraded to the latest version of thunderbird, and it lost the setting. I think you have to manually edit an entry in one of the java files. Has anyone had the same issue, and if so where is the line to edit??

Prof
0
Comment
Question by:prof666
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
7 Comments
 
LVL 8

Expert Comment

by:marxy
ID: 13651711
Go
Applications-->Preferencies-->More preferencies-->Preffered Applications
Choose Web Browser Tab.
Select the aplication you wish to be default browser.
0
 
LVL 6

Author Comment

by:prof666
ID: 13652690
That would'nt work because this is a manual install of thunderbird, Plus thinderbird doesn't use KDE or GNOME api it uses java, which remains un-affected by the default browser you choose in the windows manager. You have to manually edit one of the files to point to the browser binary file.
0
 
LVL 8

Expert Comment

by:marxy
ID: 13652801
What window manager do you use then?
0
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

 
LVL 6

Author Comment

by:prof666
ID: 13652864
KDE ,but I have already set firefox as my default browser, but any links in thunderbird emails get opened in mozilla in-spite of this.
0
 
LVL 6

Author Comment

by:prof666
ID: 13653153
Found the link::

http://www.mozilla.org/projects/thunderbird/linuxurls.html

need to add the following to the prefs.js file under /home/username/.thunderbird/mailboxname/prefs.js

user_pref("network.protocol-handler.app.http", "/path/to/firefox-binary");


Works like a charm..

Prof
0
 

Accepted Solution

by:
OzzMod earned 0 total points
ID: 13686745
Closed, 250 points refunded.
OzzMod
Community Support Moderator (Graveyard shift)
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

rdate is a Linux command and the network time protocol for immediate date and time setup from another machine. The clocks are synchronized by entering rdate with the -s switch (command without switch just checks the time but does not set anything). …
Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses
Course of the Month10 days, 18 hours left to enroll

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question