can ping other PCs but not access them

I just installed a linksys router. One PC is direct connect to the router, the other uses a USB wireless adapter.

I can ping between the two PCS but am unable to access one from the other. I did setup file and print sharing.  OS is XP Pro on both.

If I do a start\run and put in \\xx.xxxx.xx.xx it gives invalid network name. So even if use ip address can not access the other PC.

If on PC A with IP 192.168.1.100 I even try to may a drive back to itself as \\192.168.1.100\shareddocs I get an error of network path could not be found. However, if I use \\jeff-portable\shareddocs it maps. However, nothing I do will map to PC B.

I am surprised that on PC A I can't map back to myself via IP address.
jbeckstromAsked:
Who is Participating?
 
Fatal_ExceptionConnect With a Mentor Commented:
Yea, there is something wrong with your TCP/IP stack.  Try running WinsockFix on this machine.  You can get it from my site, and read what it does:

http://65.24.134.81/KipSolutions/WinsockFix/WinsockFix.htm

FE
0
 
Fatal_ExceptionCommented:
Also, feel free to read about P2P troubleshooting:

http://65.24.134.81/KipSolutions/P2PNetworks/TroubleshootingP2P.htm
0
 
gpriceeeCommented:
Is this what you have?

         PCA ----------> PCB
                                     ------------Wireless--------->Linksys

If so, you really should connect both PCs to the router and let it do the routing.

If that is not an option, then enter the following in both PCs and post it defining which is PCA and which is PCB

ipconfig /all
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
jbeckstromAuthor Commented:
PC A - direct
      \
       router
      /
PC B - wireless
0
 
Fatal_ExceptionCommented:
You might try physically connecting your wifi enabled system to the router, and take wifi out of the mix...  but you still need to address that IP issue..

FE
0
 
gpriceeeCommented:
Do you have firewalls enabled?  The SP2 firewall or some other firewall?
Have you eneterd at the cmd prompt
nbtstat -RR
0
 
jbeckstromAuthor Commented:
I have SP 1 - no firewall
0
 
jbeckstromAuthor Commented:
Searching the net I found some discussion of a GUEST account.  Do I need it enabled?
0
 
gpriceeeCommented:
No!
If you can ping PCB by name, have you tried to map the drive to PCB this way?
Open Windows Explorer
Tools --> Map Network Drive
Choose drive letter
enter UNC:  \\PCBname\share
Click on different user name
Enter the username as follows:  PCB\user     replace PCB with the machine name and replace the user with the user on PCB who has the rights to the share.

Are both machines on the same workgroup?
0
 
JohnnyCanuckCommented:
Enable  the guest account and verify that both computers have the same workgroup name.
0
 
gpriceeeCommented:
The OS is XP Pro--the guest account simply creates a vulnerability.  Never enable it.
0
 
jbeckstromAuthor Commented:
Caan not ping PC B from A by name.  I can only do it via ip address.
0
 
gpriceeeCommented:
Can you enter into each machine the following at the cmd prompt:
ipconfig /all

Please post the results specifying which machine is A and which is B.
0
 
Fatal_ExceptionCommented:
Easist to use the notepad command to post your IP Config..

ipconfig /all > ip.txt  (enter)
notepad ip.txt  (enter)

Have you followed the steps outlined in my posts above?

FE
0
 
james_in_hardwareCommented:
Do you have blank passwords on either of these machines?
0
 
jbeckstromAuthor Commented:
I will get the ipconfig tonight.

No I do not have blank passwords.
0
 
Fatal_ExceptionCommented:
Once you connect to another computer, the connecting computer will cache those credentials...  That is why you are able to re-connect without a logon window..
0
 
jbeckstromAuthor Commented:
One of our network people suggested turning on netbios under tcp/ip  What do you thinK?
0
 
Fatal_ExceptionCommented:
Yea, in fact it should be enabled by default via DHCP (if configured that way).  If not, certainly enable it!  (and it is Netbios OVER TCP/IP)  You can find it in the Advanced area of TCP/IP properties..  in the WINS tab..  (The default is use config from DHCP, but you can force it also)
0
 
gpriceeeCommented:
NetBIOS won't help you reach PCB: you tried an ip address.  NetBIOS simply will allow the machine name to replace the ip address.
0
 
jbeckstromAuthor Commented:
I turned on netbios and no change - still couldn't even ping by name.

Added entry in hosts file and now could ping by name but still could not add printer.  Error message is "windows cannot connect to the printer.  Either the printer name was typed incorrectly or the server has lost connection to the printer.


Ipconfig /all on laptop shows the below.  Only difference for my desktop pc is ip of 101 instead of 100.
C:\WINDOWS\SYSTEM32>ipconfig /all
 
Windows IP Configuration
 
        Host Name . . . . . . . . . . . . : jeff-xxxxx
        Primary Dns Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Mixed
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No
 
Ethernet adapter Local Area Connection:
 
        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Accton EN2242 Series MiniPCI Fast Et
hernet Adapter
        Physical Address. . . . . . . . . : 00-D0-59-24-D9-F1
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 192.168.1.100
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.1.1
        DHCP Server . . . . . . . . . . . : 192.168.1.1
        DNS Servers . . . . . . . . . . . : 166.102.165.13
                                            166.102.165.11
        Lease Obtained. . . . . . . . . . : Tuesday, March 29, 2005 6:09:00 PM
        Lease Expires . . . . . . . . . . : Wednesday, March 30, 2005 6:09:00 PM
 

0
 
gpriceeeCommented:
Are you using this router to get to the web?
If so, can both machines get to the web?
If you're not, is the cable to the wired machine plugged into the WAN port?
0
 
jbeckstromAuthor Commented:
Currently, do NOT have dsl - it is on order so router won't connect to internet.

One is hard wired to the router other is wireless.
0
 
gpriceeeCommented:
The cable wired to the router, where is it plugged in?
0
 
jbeckstromAuthor Commented:
One of the direct ports.  Both PCs are able to get to the routers config page and have correct IP addresses so they do see the router.
0
 
gpriceeeCommented:
Are both machines in the same workgroup?
0
 
gpriceeeCommented:
What is the router model number?
0
 
gpriceeeCommented:
Your DNS entry should be empty if you're not connecting to the internet.
0
 
jbeckstromAuthor Commented:
I had put in the DNS entries since they will be needed once DSL is setup.  Should I remove them and try again.

Router is linksys wrt54g.
0
 
gpriceeeCommented:
Do you have dynamic or static routing enabled?

And, have you tried just resetting the router to defaults, checking you connections, and then applying changes afterward?
0
 
gpriceeeCommented:
Clear the DNS.
0
 
jbeckstromAuthor Commented:
dhcp

From both PCs, I can use internet explorer to get to the router's config page so appears router is working.
0
 
gpriceeeCommented:
From both PCs you should be able to get to the router because it doesn't have to route that traffic; however, if it needs to route your machines to eachother, which should work just fine if dynamic routing is enabled.  If static routing is enabled, the route has to be checked.

You might just save yourself a lot of time by resetting the router and starting again.
0
 
jbeckstromAuthor Commented:
but then I shouldn't be able to ping the other pc if the router was not working.
0
 
JohnnyCanuckCommented:
Can you see the computers in My Network Places?  Remove any network settings from the connections regarding DNS, Gateway etc. and only have DHCP enabled.  Clear the DNS entries from the router as well (if you are not connected to the internet you don't need them and when you do connect, your router will likely be able to obtain them automatically).  Turn off any firewalls, create accounts on each machine with the username and password of the other machine.  Turn off simple filesharing (double click My Computer, click Tools->Folder Options->View, scroll down to the bottom of the list and uncheck Use simple filesharing (recommended)).  Create a folder on each machine to share files (but not in the root of C:, XP doesn't like that - instead make a folder and put the shared folder inside of it).  Right click the folder and select Sharing and Security.  Select Share this Folder, click Permissions, select the permissions you want people to have (read, change, full control), click Apply, click Apply.  Wait a few minutes and try My Network Places again.
0
 
jbeckstromAuthor Commented:
Brought my router to work.  Hooked up two computers and they worked so not the router.  Then hooked my laptop in place of one of the computers that worked and then did not.  Therefore, there is something on the laptop that is blocking the connection.
0
 
jbeckstromAuthor Commented:
Problem is resolved!!!!!

Happened to notice that when looking at properties for the network connection that MS client and File and print sharing options WERE checked, however, the box was gray.

Deinstalled MS client and reinstalled it and then check box looked normal.  

0
 
gpriceeeCommented:
How frustrating!
Good thing it's done.
0
 
Fatal_ExceptionCommented:
:)
0
 
Fatal_ExceptionCommented:
Thanks!
0
All Courses

From novice to tech pro — start learning today.