?
Solved

Con'td general VoIP question

Posted on 2005-03-29
7
Medium Priority
?
372 Views
Last Modified: 2010-04-12
Ok, I'm into the network today.....here's what I have:
from a 3600, I have a T1 going into a Frame cloud, and then out of the Frame cloud, two 256Kbps links to some remote location routers (these are both 1760's).....with about 7 Cisco IP phones (1740's maybe) at each of the two sites....I'm VERY new to QoS, as well as this website :)
I will use map-classes and traffic-shaping, set up at those 3 points? (the 3600, and the two 1760's)

any hints will be much appreciated :)
0
Comment
Question by:dlitty7
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
7 Comments
 

Author Comment

by:dlitty7
ID: 13656439
I have a Cisco 4510 Core switch that has CallManager connected..........this 4510 is connected to a Cisco 3640 router with a T1 (2 sub interfaces)....192.168.100.1, and 192.168.100.9....going to a Frame Relay cloud, then from that cloud, there are two 256Kbps links to two 1760's......192.168.100.2, and 192.168.100.10.......each of these two sites will have about 7 cisco 1740 phones attached......
I need to QoS these two 1760's and the 3650......
 
voice class h323 1
 h225 timeout tcp establish 3
 
class-map match-all INTERNET
  match access-group 100
class-map match-all VOIP-SIGNALING
  match access-group 110
class-map match-all VOIP-TRAFFIC
  match access-group 120
 
policy-map QOS-Policy-256k                    <---------------------------------------------------------------------------------
  class VOIP-TRAFFIC
   priority  [what here?  I've only got 256K to play with]
  class VOIP-SIGNALING
   bandwidth [what here?  I've only got 256K to play with]
  class INTERNET
   shape peak [what here?  I've only got 256K to play with]
  class class-default
   fair-queue
 
interface Serial0/0                                          I'm not too sure about these S0/0 int lines                      
 description T1 to Appia Indy
 ip address 192.168.100.2 255.255.255.0
 ip nat outside
 service-policy output QOS-Policy-256k   <-----------------------------------------------------
 load-interval 30
 h323-gateway voip bind srcaddr 192.168.100.2
 
route-map Set-IP-QOS permit 10
 match ip address 130                  
 set ip precedence flash            ????????? is flash a known variable?
 
route-map Set-IP-QOS permit 20
 match ip address 140
 
route-map Set-IP-QOS permit 30
 match ip address 150
 set ip precedence routine
 
access-list 100 permit ip any any
access-list 120 permit ip any any precedence critical        ??????????? is critical a known variable?
access-list 120 permit ip any any dscp ef
access-list 110 permit ip any any precedence flash        
access-list 110 permit ip any any dscp af31
access-list 130 permit tcp any any range 2000 2002
access-list 130 permit tcp any any eq 1720
access-list 130 permit tcp any any range 11000 11999
access-list 130 permit tcp any any eq 2427
access-list 140 permit udp any any range 16384 32767
access-list 150 permit ip any any
dialer-list 1 protocol ip permit                     ?????????not familiar with this
 

0
 
LVL 7

Expert Comment

by:minmei
ID: 13671296
Post the whole config (with the public network numbers changed to protect the innocent). Too many holes in the above config to make much sense, especially the dialer-list 1 protocol ip permit

critical and flash are variables - goes like this - routine priority immediate flash flash-override critical internet network

Highest is most right at 7, lowest is routine at 0.

The service-policy lines apply the policy to the interface - those are correct.

The route-maps look to be used to set precedence based on the ports the traffic is coming to, but these need to be applied to the ethernet interfaces.

We also have another customer who uses Appia Indy POP that works.  
0
 

Author Comment

by:dlitty7
ID: 13672328
I've spent the last two days trying to figure this all out, this is ONE of two offsite 1760's that go into a FR cloud, then to a 3865, the config on the 3825 is after this one:

1760#sho config
Using 1259 out of 29688 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Morrison-RTR1760
!
boot-start-marker
boot system flash:c1700-ipvoice-mz.123-13.bin
boot-end-marker
!
enable secret 5 $1$kG1k$hpCOb4Z9K0gM6EXAfC2d50
enable password medassoc
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
voice-card 2
!
no aaa new-model
ip subnet-zero
ip cef
!
ip dhcp pool phone
   network 10.23.4.0 255.255.252.0
   default-router 10.23.4.1
   dns-server 10.23.0.10 10.23.0.11
   option 150 ip 10.23.0.10
!
no ftp-server write-enable

class-map match-all VOIP-SIGNALING
  match ip dscp af31                            
 
class-map match-any VOIP-TRAFFIC
   match ip dscp ef
   match ip precedence 5
   match access-group 140

policy-map QOS-Policy-256k
class VOIP-TRAFFIC
    priority  170
class VOIP-SIGNALING
    bandwidth 10
class class-default
    fair-queue

map-class frame-relay FRQoS                                                                    
 frame-relay cir 256000
 frame-relay mincir 256000
 frame-relay bc 2560
 service-policy output QOS-Policy-256k


!
interface FastEthernet0/0
 no ip address
 speed 100
 full-duplex
!
interface FastEthernet0/0.1
 encapsulation dot1Q 1 native
 ip address x.x.x.x x.x.x.x
 no snmp trap link-status
!
interface FastEthernet0/0.2
 encapsulation dot1Q 2
 ip address x.x.x.x x.x.x.x
 no snmp trap link-status

interface serial 0/0                    
ip address x.x.x.x x.x.x.x
service-policy output QOS-Policy-256k
frame-relay traffic-shaping
frame-relay class FRQoS
frame-relay dlci 101 CISCO                        
!
router eigrp 1
 network x.x.x.x x.x.x.x
 network x.x.x.x
 auto-summary
!        
ip classless
ip route 0.0.0.0 0.0.0.0 x.x.x.x
no ip http server

access-list 140 permit udp any any range 16384 32767

!
!
voice-port 2/0
!
voice-port 2/1
!
voice-port 2/2
!
voice-port 2/3
!
line con 0
line aux 0
line vty 0 5
 password medassoc
 login
!
End



here's the 3825:




This router is the backup and has PRI

clinton3825-1#sho config
Using 3324 out of 491512 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname clinton3825-1
!
boot-start-marker
boot system flash:c3825-ipvoice-mz.123-11.T3.bin
boot-end-marker
!
logging buffered 51200 warnings
!
username cisco privilege 15 secret 5 $1$M7vv$yz4fBNIB3F6FURgv6PCiS/
username khansen privilege 15 secret 5 $1$IFQh$U1xuCbLyuTzYVMBpMxcvn/
network-clock-participate wic 0
no aaa new-model
ip subnet-zero
ip cef
!
ip dhcp excluded-address 10.23.0.0 10.23.0.255
ip dhcp excluded-address 10.23.3.0 10.23.3.255
!
ip dhcp pool Phone
   network 10.23.0.0 255.255.252.0
   default-router 10.23.0.1
   dns-server 10.23.0.10 10.23.0.11
   option 150 ip 10.23.0.10
!
no ip domain lookup
ip domain name yourdomain.com
no ftp-server write-enable
isdn switch-type primary-ni
voice-card 0
 no dspfarm

class-map match-all VOIP-SIGNALING
  match ip dscp af31                                                  

class-map match-any VOIP-TRAFFIC
   match ip dscp ef
   match ip precedence 5
   match access-group 140

policy-map QOS-Policy-256k
class VOIP-TRAFFIC
    priority  170
class VOIP-SIGNALING
    bandwidth 10
class class-default
    fair-queue

map-class frame-relay FRQoS                                                                  
 frame-relay cir 256000                      
 frame-relay mincir 256000                
 frame-relay bc 2560                          
 service-policy output QOS-Policy-256k
!
controller T1 0/0/0
 framing esf
 linecode b8zs
 cablelength short 133
 pri-group timeslots 1-24
 description PRI to Phone Switch
!
controller T1 0/0/1
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24 speed 64
 description T1 to Appia
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/0.1
 description Data VLAN 1
 encapsulation dot1Q 1 native
 ip address x.x.x.x 255.255.0.0
!
interface GigabitEthernet0/0.3
 description Data VLAN 3
 encapsulation dot1Q 3
 ip address x.x.x.x 255.255.0.0
!
interface GigabitEthernet0/1
 description Phone VLAN2
 ip address 10.23.0.1 255.255.252.0
 duplex auto
 speed auto
 media-type rj45
!
interface Serial0/0/0:23
 no ip address
 isdn switch-type primary-ni
 isdn incoming-voice voice
 no cdp enable
!
!
!
!
!
!
!
!
!
interface Serial0/0/1:0
 description T1 to Appia
 no ip address
 encapsulation frame-relay
 frame-relay traffic-shaping

interface Serial0/0/1:0.1 point-to-point
 description T1 to xxxxxxx 1760
 ip address x.x.x.x 255.255.255.252
 frame-relay class FRQoS
 frame-relay dlci 101 CISCO

interface Serial0/0/1:0.2 point-to-point
 description T1 to xxxxxx 1760
 ip address  x.x.x.x 255.255.255.252
 frame-relay class FRQoS
 frame-relay dlci 102 CISCO
!
router eigrp 1
 network 10.23.0.0 0.0.3.255
 network 172.20.0.0
 network 172.29.0.0
 network 172.31.0.0
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 x.x.x.x
ip route x.x.x.x x.x.x.x x.x.x.x
!
access-list 140 permit udp any any range 16384 32767

ip http server
ip http authentication local
!
snmp-server engineID local xxxxxxxxxxxxxxxxxxxxxxxxxxxxx
snmp-server community public RO
!
control-plane
!
voice-port 0/0/0:23
!
line con 0
 login local
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 privilege level 15
 login local
 transport input telnet
line vty 5 15
 privilege level 15
 login local
 transport input telnet
!
scheduler allocate 20000 1000
!
end




the innocent should be protected :)
thx for any help given

0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
LVL 7

Expert Comment

by:minmei
ID: 13673345
>class-map match-all VOIP-SIGNALING
> match ip dscp af31                            
 
>class-map match-any VOIP-TRAFFIC
>   match ip dscp ef
>   match ip precedence 5
>   match access-group 140

These are the qualifying commands that tell the router which traffic is in which class.

VOIP signaling is useful to prioritize but not that important.

VOIP Traffic is the media path - this we want.

This is a blanket catch all - access-list 140 is catching all udp traffic to ports higher than 16384. This should be the media path.
The other two lines will catch if the IP TOS or DCSP bits are set from the phone and carried thru the switch.

These look good.

>class VOIP-TRAFFIC
    priority  170
class VOIP-SIGNALING
    bandwidth 10
class class-default
    fair-queue

This is ok as well - you can't prioritize over 75% of the available bandwith (Cisco rule) so 170 is fine. the 10 is small enough to be almost meaningless, but it's a good one to keep in for example.

What are you looking for an answer to?



0
 

Author Comment

by:dlitty7
ID: 13677947
well, since I'm new at this, I guess I'm looking to make sure that they are on QoS is on the correct interfaces, and that the CLI is correct on those interfaces.......this Frame Relay part is kind of confusing me......

thanks again for the help.....

and one more question.......what's up with this point system,  I mean, what if I gave 500 pts for a question like, "what is a PC?"
0
 
LVL 7

Accepted Solution

by:
minmei earned 1400 total points
ID: 13678174
You seem to understand it pretty well from the QOS perspective...

We've seen vendors put in this stuff with bad, incomplete, and just flat out wrong QOS before...

As for points, it's up to you. There are moderators, and I imagine you couldn't get away with too many "What is a PC" questions.

500 usually is enough to get more than one person going for an answer. Sometimes 50 does it, if it's an easy one.
0
 

Author Comment

by:dlitty7
ID: 13678235
thx for your help......I will be using this site quite a bit!
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Although VoiceOver IP has been around for a while, internet connections have only recently become fast enough to provide good call quality. Now, VoIP has become a real option for businesses looking at ways to improve their business model. In this ar…
Hey there Heard about jingle, the add on for XMPP that enables point to point audio between two XMPP clients. No server config necessary. Actually quite a cool feature. However, how good is it if you can not use those voice capabilities to do a P…
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…
This tutorial will teach you the special effect of super speed similar to the fictional character Wally West aka "The Flash" After Shake : http://www.videocopilot.net/presets/after_shake/ All lightning effects with instructions : http://www.mediaf…

801 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question