Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 196
  • Last Modified:

Deploying software in Active Directory

Ok guys i am using WinInstallLE 2003 to create msi files and it has been working very well. However i am having a problem using them in Active Directory. Ill explain.
Ok i make the msi... Put it in a Network Share that everyone has rights to...
My AD structure is set up like this: For every Department we have, i have them set up with a main Organization Unit...Example Pharmacy is the OU and under that OU i have an OU for Users and another OU for Computers. Accounting is another OU and under it i have another OU for Users and then another OU for computers.
So basically every single dept is an OU with an OU for the Users and an OU for the Computers underneath it.
What i have been doing is going to the OU's group policy for the department(ex. Accounting) then going to the group policy and under the computer settings assigning the msi package to be deployed. I am setting it to assign and not publish. I do a gpupdate and it goes through successful and then when i reboot i see it saying applying security setting>>>installing managed software>>>Installing MSI(filename) Software and then i see the startup scripts load. The startup scripts i am running through the default domain group policy. However when i log in and try to access the software it shows up as not being installed.
Now if i go to start>>>run>>>\\servername\share\filename.msi and try to load it manually it loads fine and works perfect.(Just to point out, this is the same share that the active directory is pointed to)
Let me add something else to this. When i do load it manually as stated above it still asks me to accept the license agreement when i access the software for the first time. In the instructions of the software i made an MSI package says to make it self registering on your installer(Dont know if this helps but hoping maybe it does)
This is the software i am using...  http://www.crowcanyon.com/Help_Desk/OutlookHelpDesk.html   ...Basically it is a help desk ticketing solution that integrates with Exchange and Outlook. So basically what happens is i get a nag in outlook when i try to use this software when i do not have the patch loaded on the machine. The patch is what i made into an MSI file which is called redemption patch for outlook. So anyway what happens when i load it manually is i open outlook and immediately upon opening outlook i get the prompt for me to accept the software agreement. So i am not sure if the problem lies within my AD group policy or if it is because of the fact it needs to be a self registering software in the msi.
However to me it seems like it is something in my group policy because when i am manually mapping to the folder to load the msi manually it is the same exact folder i have the AD pointed to and it works just fine. I have to get this thing rolling soon so help !!! lol
Thanks again
Jim

Also i am more than willing to work with someone on a messanger if it is easier !
0
jjeffords
Asked:
jjeffords
1 Solution
 
Chris DentPowerShell DeveloperCommented:

Hi Jim,

If you check using the Resultant Set of Policy Tool, RSOP.msc (Start, Run, rsop.msc) it will allow you to view any policy processing errors that are occurring when the software attempts to install.

It may be a simple problem that it's getting stuck on.

Let me know how you get on.

Chris
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now