?
Solved

Open Up With Problem

Posted on 2005-03-29
25
Medium Priority
?
3,449 Views
Last Modified: 2007-12-19
Background:

I used to have this option both when I right click on a selected file as well as under the "File"Menu if I held the
"Shift Key" down.

I installed the eariler version of Open Expert 1.30. for thosethat are not familiar with it, the newest version is 1.40 which is here with its explanation:

OpenExpert 1.40

Open With submenu for explorer's menu

Simply install our freeware OpenExpert and you will be able to configure every single existing filetype with its own "open with..." submenu extension. Now you can quickly and simply choose which application you want to open that particular file. Right click the mouse and select the program to open the file. That's all there is to it!

OpenExpert is free for use at home! For business use please purchase a licence

http://www.baxbex.com/products.html

For reasons which are not material to the discussion here, I removed, i.e. uninstalled Open Expert and it was
some time much later that I discovered that the
Open Up With Option was missing both from my
"Right Click Menu as well as from the Menue under
"File whether I held the shift key down or not.  I even
went to Doug Knox's web site and downloaded what was suppose to be a Registry Entry to correct this, but
that did not work either.  At this time, I could select a file and choose properties and get the option that
shows the program that opens up that file with the option to change it.

Anyway, astaec posted a similiar problem here:

http://www.experts-exchange.com/Operating_Systems/WinXP/Q_21322881.html

and sramesh2k  provided the answer to which I
added an additional inquiry about importing  which
I never really understood.

In the meantime, I shoulld also add, I reinstalled
"OPen Expert" the new Version  1.40 which I am still using.

Subsequently, a second question was posted by
mgh_mgharish here:

http://www.experts-exchange.com/Operating_Systems/WinXP/Q_21360722.html

I followed mgh mgharish instructions on how to
import the suggested registry change as originally
posted by  sramesh2k  in the first Q & A.  I have
backed up the Registry and I imported this change:
Now I have two 'OPen With Selections both on my
Right Click Menu and under the File Menu, but
the problem exists with the one "OPen With"
associated with this Registry Change:

The Question, when i select a file and Choose
the Open With associated with the windwo program
rather than the one associated with Open Expert
I get a window as follows:

Red Button
With White X+

            This file does not have a program associated with it for performing this action. Create an association in the Folder Options control panel.


                             (  OK   )


Currently I am trying to have it both ways, that I
can elect to utilized either the "Open Up Expert Program and/or the Windows Open With Program at my election.





0
Comment
Question by:LRI41
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 14
  • 11
25 Comments
 
LVL 34

Expert Comment

by:sramesh2k
ID: 13658955
Hi LRI41,

If I understand correctly, you want to Undo the procedure I described here ?:

http://oldlook.experts-exchange.com:8080/Operating_Systems/WinXP/Q_21322881.html

0
 
LVL 10

Author Comment

by:LRI41
ID: 13663559
That's not my first preference,

1.  My first preference is a solution to get the Windows Open With
option to work so that I have both OPen With Programs available to me.
Right Now, all I have it the Widnows Open With Option avaiable (which is was not before) but it doesn't work)

I Kinda of assume, but may be wrong is when I removed, uninstalled
Open Expert the first time, I somehow screwed up the Window Open Up with Program.  and now since I have re-installed OPen Expert 1.40,
Windows will not allow me to uttilize both programs simutaneously
so I must choose between one or the other?

I would like to know how I can undo the removse the registry change
you cited, but that is a secondary.   If my premise above is correct,
if I uninstall OPen Expert, it will lose the new registry change, and then
could re-install it and have only the Windows Open with Program.
0
 
LVL 10

Author Comment

by:LRI41
ID: 13665772
1. What is the solution for Not getting the error message and actually
getting the option to Open with?

2.  How do i undo this registry change, it I cannot get it to work?

Is that simpler?
0
How Blockchain Is Impacting Every Industry

Blockchain expert Alex Tapscott talks to Acronis VP Frank Jablonski about this revolutionary technology and how it's making inroads into other industries and facets of everyday life.

 
LVL 34

Expert Comment

by:sramesh2k
ID: 13668854
For No.1, try this:

Start Regedit.exe and navigate to:

[HKEY_CLASSES_ROOT\*\Shell\Open with\command]

Note down the value for (default) in the right-pane. It should read the following:

"rundll32.exe C:\\Windows\\system32\\shell32.dll,OpenAs_RunDLL %1"

-------------------------------------------------------------------------------------------------
Important: Change the drive-letter if Windows is installed in a different drive than C:\
-------------------------------------------------------------------------------------------------

For No.2, try this:

Backup the above key to a REG file. (Use File > Export option).

Select the "Open with" sub-key and delete it.
0
 
LVL 34

Accepted Solution

by:
sramesh2k earned 1200 total points
ID: 13669466
Correction (For 1) above:

It should read the following:

"rundll32.exe C:\Windows\system32\shell32.dll,OpenAs_RunDLL %1"
0
 
LVL 10

Author Comment

by:LRI41
ID: 13676555
sramesh2k

I went here:

[HKEY_CLASSES_ROOT\*\Shell

1.  I have no "Open With" Folder all i have is the following:

I have no "OPen With" Folder under Shell I only have the following:

HKEY_CLASSES_ROOT\Shell

HKEY_CLASSES_ROOT\Shell\shell

HKEY_CLASSES_ROOT\Shell\shell\explore

HKEY_CLASSES_ROOT\Shell\shell\explore\command

HKEY_CLASSES_ROOT\Shell\shell\explore\ddeexec

HKEY_CLASSES_ROOT\Shell\shell\explore\ddeexec\application

HKEY_CLASSES_ROOT\Shell\shell\explore\ddeexec\ifexec

HKEY_CLASSES_ROOT\Shell\shell\explore\ddeexec\topic

HKEY_CLASSES_ROOT\Shell\shell\open

HKEY_CLASSES_ROOT\Shell\shell\explore

HKEY_CLASSES_ROOT\Shell\shell\explore\command

HKEY_CLASSES_ROOT\Shell\shell\explore\ddeexec

HKEY_CLASSES_ROOT\Shell\shell\explore\ddeexec\application

HKEY_CLASSES_ROOT\Shell\shell\explore\ddeexec\ifexec

HKEY_CLASSES_ROOT\Shell\shell\explore\ddeexec\topic

HKEY_CLASSES_ROOT\Shell\shell\open

HKEY_CLASSES_ROOT\Shell\shell\open\command

HKEY_CLASSES_ROOT\Shell\shell\open\ddeexec

HKEY_CLASSES_ROOT\Shell\shell\open\ddeexec\application

HKEY_CLASSES_ROOT\Shell\shell\open\ddeexec\ifexec

HKEY_CLASSES_ROOT\Shell\shell\open\ddeexec\topic

2.  I suspect ddeexec refers to the Open Expert Program and
the following is the reason I get the error message on
the Windows OPen With

Sub Folder ddeexec
HKEY_CLASSES_ROOT\Shell\shell\explore\ddeexec
Left Panel  Name          Type         Data
Icon ab                    (Default)   (ExploreFolder("%l", %I, %S)

Iconab  No Activate Handler     Reg S Z (THIS ONE)


These are identical in both ddeexec Folder under both "explore " and
"Open"

Here is a copy of the Open Expert Install Log:

/ fkWare Setup Wizard uninstall data file.
// Please do not modify or delete this file!

[Application]
 Copyright = "Copyright © 1999-2002 by BAxBEx Software. All Rights Reserved."
 Name = "OpenExpert"
 NeedReboot = "1"
 UninstallDLL = "C:\\WINDOWS\\system32\\OpenExpert.dll"
 Version = "1.40"

[WebUpdate]
 WebUpdateCmd = "C:\\Program Files\\OpenExpert\\OpenExpert.exe UPDATE"

[Folder]
 Remove = "C:\\Documents and Settings\\LesNJan\\Start Menu\\Programs\\OpenExpert"
 Remove = "C:\\Program Files\\OpenExpert"

[Files]
 Remove = "C:\\Documents and Settings\\LesNJan\\Start Menu\\Programs\\OpenExpert\\BAxBEx Web Site.url"
 Remove = "C:\\Program Files\\OpenExpert\\OpenExpert.exe"
 Remove = "C:\\Program Files\\OpenExpert\\OpenExpert.cnt"
 Remove = "C:\\Program Files\\OpenExpert\\OpenExpert.hlp"
 Remove = "C:\\Program Files\\OpenExpert\\readme.txt"
 Remove = "C:\\Documents and Settings\\LesNJan\\Start Menu\\Programs\\OpenExpert\\OpenExpert.lnk"
 Remove = "C:\\Documents and Settings\\LesNJan\\Start Menu\\Programs\\OpenExpert\\OpenExpert Help.lnk"
 Remove = "C:\\Documents and Settings\\LesNJan\\Start Menu\\Programs\\OpenExpert\\Uninstall OpenExpert.lnk"
 Remove = "C:\\Program Files\\OpenExpert\\Install.log"

[Registry]
 Remove = "HKEY_CURRENT_USER\\Software\\Microsoft\\Windows\\CurrentVersion\\Run|OpenExpert"
 Remove = "HKEY_CURRENT_USER\\Software\\BAxBEx\\OeffnenMitEx"
 Remove = "HKEY_LOCAL_MACHINE\\Software\\BAxBEx\\OeffnenMitEx"
 Remove = "HKEY_LOCAL_MACHINE\\Software\\Microsoft\\Windows\\CurrentVersion\\Uninstall\\OpenExpert"
 Remove = "HKEY_LOCAL_MACHINE\\SOFTWARE\\Microsoft\\Windows\\CurrentVersion\\App Paths\\OpenExpert.exe"
 RemoveEmpty = "HKEY_CURRENT_USER\\Software\\BAxBEx"
 RemoveEmpty = "HKEY_LOCAL_MACHINE\\Software\\BAxBEx"
 RootKey = "Software\\BAxBEx\\OeffnenMitEx"

[RegisterServer]
 UnRegister = "C:\\WINDOWS\\system32\\OpenExpert.dll"
0
 
LVL 34

Expert Comment

by:sramesh2k
ID: 13681570
LRI41,

The tweak which I suggested adds a sub-key here:

HKEY_CLASSES_ROOT\*\Shell

Try my earlier suggestion, and that re-creates the Open With entry to the context-menu. We can deal with the duplicate "open with" issue later.
0
 
LVL 10

Author Comment

by:LRI41
ID: 13681617
I  will import it a second time I guess as I already did import it once already, but I don't know where it went.
0
 
LVL 10

Author Comment

by:LRI41
ID: 13681941
Comment from sramesh2k
Date: 03/29/2005 08:48PM PST
 Comment  


Hi LRI41,

If I understand correctly, you want to Undo the procedure I described here ?:

http://oldlook.experts-exchange.com:8080/Operating_Systems/WinXP/Q_21322881.html


 
Comment from LRI41
Date: 03/30/2005 08:50AM PST
 Your Comment  


That's not my first preference,

1.  My first preference is a solution to get the Windows Open With
option to work so that I have both OPen With Programs available to me.
Right Now, all I have it the Widnows Open With Option avaiable (which is was not before) but it doesn't work)

I Kinda of assume, but may be wrong is when I removed, uninstalled
Open Expert the first time, I somehow screwed up the Window Open Up with Program.  and now since I have re-installed OPen Expert 1.40,
Windows will not allow me to uttilize both programs simutaneously
so I must choose between one or the other?

I would like to know how I can undo the removse the registry change
you cited, but that is a secondary.   If my premise above is correct,
if I uninstall OPen Expert, it will lose the new registry change, and then
could re-install it and have only the Windows Open with Program.
 
Comment from LRI41
Date: 03/30/2005 12:44PM PST
 Your Comment  


1. What is the solution for Not getting the error message and actually
getting the option to Open with?

2.  How do i undo this registry change, it I cannot get it to work?

Is that simpler?
 
Comment from sramesh2k
Date: 03/30/2005 09:24PM PST
 Comment  


For No.1, try this:

Start Regedit.exe and navigate to:

[HKEY_CLASSES_ROOT\*\Shell\Open with\command]

Note down the value for (default) in the right-pane. It should read the following:

"rundll32.exe C:\\Windows\\system32\\shell32.dll,OpenAs_RunDLL %1"

-------------------------------------------------------------------------------------------------
Important: Change the drive-letter if Windows is installed in a different drive than C:\
-------------------------------------------------------------------------------------------------

For No.2, try this:

Backup the above key to a REG file. (Use File > Export option).

Select the "Open with" sub-key and delete it.
 
Comment from sramesh2k
Date: 03/30/2005 11:50PM PST
 Comment  


Correction (For 1) above:

It should read the following:

"rundll32.exe C:\Windows\system32\shell32.dll,OpenAs_RunDLL %1"

 
Comment from LRI41
Date: 03/31/2005 02:47PM PST
 Your Comment  


sramesh2k

I went here:

[HKEY_CLASSES_ROOT\*\Shell

1.  I have no "Open With" Folder all i have is the following:

I have no "OPen With" Folder under Shell I only have the following:

HKEY_CLASSES_ROOT\Shell

HKEY_CLASSES_ROOT\Shell\shell

HKEY_CLASSES_ROOT\Shell\shell\explore

HKEY_CLASSES_ROOT\Shell\shell\explore\command

HKEY_CLASSES_ROOT\Shell\shell\explore\ddeexec

HKEY_CLASSES_ROOT\Shell\shell\explore\ddeexec\application

HKEY_CLASSES_ROOT\Shell\shell\explore\ddeexec\ifexec

HKEY_CLASSES_ROOT\Shell\shell\explore\ddeexec\topic

HKEY_CLASSES_ROOT\Shell\shell\open

HKEY_CLASSES_ROOT\Shell\shell\explore

HKEY_CLASSES_ROOT\Shell\shell\explore\command

HKEY_CLASSES_ROOT\Shell\shell\explore\ddeexec

HKEY_CLASSES_ROOT\Shell\shell\explore\ddeexec\application

HKEY_CLASSES_ROOT\Shell\shell\explore\ddeexec\ifexec

HKEY_CLASSES_ROOT\Shell\shell\explore\ddeexec\topic

HKEY_CLASSES_ROOT\Shell\shell\open

HKEY_CLASSES_ROOT\Shell\shell\open\command

HKEY_CLASSES_ROOT\Shell\shell\open\ddeexec

HKEY_CLASSES_ROOT\Shell\shell\open\ddeexec\application

HKEY_CLASSES_ROOT\Shell\shell\open\ddeexec\ifexec

HKEY_CLASSES_ROOT\Shell\shell\open\ddeexec\topic

2.  I suspect ddeexec refers to the Open Expert Program and
the following is the reason I get the error message on
the Windows OPen With

Sub Folder ddeexec
HKEY_CLASSES_ROOT\Shell\shell\explore\ddeexec
Left Panel  Name          Type         Data
Icon ab                    (Default)   (ExploreFolder("%l", %I, %S)

Iconab  No Activate Handler     Reg S Z (THIS ONE)


These are identical in both ddeexec Folder under both "explore " and
"Open"

Here is a copy of the Open Expert Install Log:

/ fkWare Setup Wizard uninstall data file.
// Please do not modify or delete this file!

[Application]
 Copyright = "Copyright © 1999-2002 by BAxBEx Software. All Rights Reserved."
 Name = "OpenExpert"
 NeedReboot = "1"
 UninstallDLL = "C:\\WINDOWS\\system32\\OpenExpert.dll"
 Version = "1.40"

[WebUpdate]
 WebUpdateCmd = "C:\\Program Files\\OpenExpert\\OpenExpert.exe UPDATE"

[Folder]
 Remove = "C:\\Documents and Settings\\LesNJan\\Start Menu\\Programs\\OpenExpert"
 Remove = "C:\\Program Files\\OpenExpert"

[Files]
 Remove = "C:\\Documents and Settings\\LesNJan\\Start Menu\\Programs\\OpenExpert\\BAxBEx Web Site.url"
 Remove = "C:\\Program Files\\OpenExpert\\OpenExpert.exe"
 Remove = "C:\\Program Files\\OpenExpert\\OpenExpert.cnt"
 Remove = "C:\\Program Files\\OpenExpert\\OpenExpert.hlp"
 Remove = "C:\\Program Files\\OpenExpert\\readme.txt"
 Remove = "C:\\Documents and Settings\\LesNJan\\Start Menu\\Programs\\OpenExpert\\OpenExpert.lnk"
 Remove = "C:\\Documents and Settings\\LesNJan\\Start Menu\\Programs\\OpenExpert\\OpenExpert Help.lnk"
 Remove = "C:\\Documents and Settings\\LesNJan\\Start Menu\\Programs\\OpenExpert\\Uninstall OpenExpert.lnk"
 Remove = "C:\\Program Files\\OpenExpert\\Install.log"

[Registry]
 Remove = "HKEY_CURRENT_USER\\Software\\Microsoft\\Windows\\CurrentVersion\\Run|OpenExpert"
 Remove = "HKEY_CURRENT_USER\\Software\\BAxBEx\\OeffnenMitEx"
 Remove = "HKEY_LOCAL_MACHINE\\Software\\BAxBEx\\OeffnenMitEx"
 Remove = "HKEY_LOCAL_MACHINE\\Software\\Microsoft\\Windows\\CurrentVersion\\Uninstall\\OpenExpert"
 Remove = "HKEY_LOCAL_MACHINE\\SOFTWARE\\Microsoft\\Windows\\CurrentVersion\\App Paths\\OpenExpert.exe"
 RemoveEmpty = "HKEY_CURRENT_USER\\Software\\BAxBEx"
 RemoveEmpty = "HKEY_LOCAL_MACHINE\\Software\\BAxBEx"
 RootKey = "Software\\BAxBEx\\OeffnenMitEx"

[RegisterServer]
 UnRegister = "C:\\WINDOWS\\system32\\OpenExpert.dll"

 
Comment from sramesh2k
Date: 04/01/2005 07:26AM PST
 Comment  


LRI41,

The tweak which I suggested adds a sub-key here:

HKEY_CLASSES_ROOT\*\Shell

 
 Comment from LRI41
Date: 04/01/2005 07:31AM PST
 Your Comment  


I  will import it a second time I guess as I already did import it once already, but I don't know where it went.


Well I went back and "used the "Merge" option on the first one that I had made, it
said it went into the registry, rebooted, When I went to look at the registry entrrie
no change from what I report above, , i.e. No :Open With Folder."

I then went back to you original comment and recopied the instructions including
the quotataiion marks that you had , I am not sure I included those in the first
one, so I made the second one, and imported that one, which said went into the
registry, rebooted, went to the registry and still no change in what I reported above,same
Folders and Sub Folders with no "Open With Folder,

I still have the two Open With Options both in my right click menu as well as under
File" which is exactly what I want, but the top Option, which I assume is supposed
to be associated with the Windows Program still gives the same message,
at least when I used the Reg Change it did in fact put this into the menus,
but its doesn't work it still says:

Red Button
With White X+

            This file does not have a program associated with it for performing this
            action. Create an association in the Folder Options control panel.


                             (  OK   )


My guess is  still the same by installing "Open Expert" that does something to the Windows
Program so it doesn't work and in fact if subsequently you uninstall OPen Expert, thats
when you lose it from the menus.  Ill just bet dollars to donuts that if I uninstalled OPen
Expert and was able to clean out all references to it in the Registry and then used you
solution, then I would get it back and it would work. I sent an web site message to the
author of Open Expert a couple of night ago, but haven't heard anything yet.  I may not.
0
 
LVL 34

Expert Comment

by:sramesh2k
ID: 13690367
Hi LRI41,

You stated:

>> When I went to look at the registry entrrie no change from what I report above, , i.e. No :Open With Folder."

Actually, my REG fix adds "Open with" entry for files and not the "Open with folder" entry. You may try the manual procedure to add the Open with entry.
0
 
LVL 10

Author Comment

by:LRI41
ID: 13693596
sramesh2k,

At the outset, I want to thank you in advance for all the time you have spent
on this matter with me.

But I am a little confused and I may have also confused you as well

In your previous comment:
 
Comment from sramesh2k
Date: 03/30/2005 09:24PM PST
 Comment  


For No.1, try this:

Start Regedit.exe and navigate to:

[HKEY_CLASSES_ROOT\*\Shell\Open with\command]

Note down the value for (default) in the right-pane. It should read the following:

"rundll32.exe C:\\Windows\\system32\\shell32.dll,OpenAs_RunDLL %1"

When I Start Regedit.exe and navigate to  (HKEY_CLASSES_ROOT\Shell, I have no
"OPen With Folder to check .  This is what I am referring to as a Folder, the name of
Folder Icon within the Registry Hierarchy, Not any option or selection within the Open With
Menu.  Under the Registry Hierarchy , each Folder Icon has a name .

Under Shell I have no reference to Open With but two folder named  "Open"

Here is my complete Refistry Hierarchy under "Shell"  Please Note that immeidatey
after "Shell" Folder the first Sub-Folder is also called "Shell."

HKEY_CLASSES_ROOT\Shell

(Shell Folder) HKEY_CLASSES_ROOT\Shell      
                                                              Left Panel  Name          Type         Data
                                                               Icon ab(Default)          RG SZ     (Value Not Set)
                                                               IconabURL Protocol   RG SX


########################################################################

HKEY_CLASSES_ROOT\Shell\shell

(Sub-Folder)  Shell

HKEY_CLASSES_ROOT\Shell\shell      Left Panel  Name          Type         Data
                                                               Icon ab(Default)          RG SZ     (Value Not Set)


HKEY_CLASSES_ROOT\Shell\shell\explore

(Sub-Sub-Folder) expore                                            Left Panel  Name          Type         Data
                                                               Icon ab(Default)          RG SZ     (Value Not Set)


HKEY_CLASSES_ROOT\Shell\shell\explore\command

(Sub-Sub- Folder) Command
HKEY_CLASSES_ROOT\Shell\shell\explore\command
                  Left Panel  Name          Type         Data
                          Icon ab            (Default)     %SystemRoot%Explorer.exe/e/idlist,%I,%L  


HKEY_CLASSES_ROOT\Shell\shell\explore\ddeexec

(Sub-Sub-Sub Folder) ddeexec
HKEY_CLASSES_ROOT\Shell\shell\explore\ddeexec
Left Panel  Name          Type         Data
Icon ab                    (Default)   (ExploreFolder("%l", %I, %S)

Iconab  No Activate Handler     Reg S Z


HKEY_CLASSES_ROOT\Shell\shell\explore\ddeexec\application

(Sub-Sub-Sub-Sub-Folder) application

                                                                                                                         Left Panel                  
                                                                          Name          Type         Data

                                                               Icon ab(Default)          RG SZ     (Value Not Set)




HKEY_CLASSES_ROOT\Shell\shell\explore\ddeexec\ifexec


(Sub-Sub-Sub-Sub-Folder ifexec

                                                                               
                                                          Left Panel

                                                   Name          Type         Data                                                      
                                                                                                                                                                                 
                                           Icon ab(Default)          RG SZ     []


HKEY_CLASSES_ROOT\Shell\shell\explore\ddeexec\topic

(Sub-Sub-Sub-Sub-Folder)  topic

                                                             Left Panel

                                                   Name          Type         Data                                                      

                                Icon ab(Default)          RG SZ      AddProperties





THEN YOU GO BACK TO THE SECOND Sub-Sub Folder under Explore

(Sub-Sub –Folder) Open
HKEY_CLASSES_ROOT\Shell\shell\open

                                                                  Left Panel  Name          Type         Data

                                                               Icon ab(Default)          RG SZ     (Value Not Set)


AND IT HAS THE SAME TWO IDENTICAL Sub-Sub-Sub Folders entitled
“explore” and “ddeexec”  with the three identical Sub-Sub-Sub-Sub Folders
under “ddeexec” i.e. namely “ application “ “ifexecm” “ topic” with indentical
words and characters as above.

HKEY_CLASSES_ROOT\Shell\shell\open

HKEY_CLASSES_ROOT\Shell\shell\open\command

HKEY_CLASSES_ROOT\Shell\shell\open\ddeexec

HKEY_CLASSES_ROOT\Shell\shell\open\ddeexec\application

HKEY_CLASSES_ROOT\Shell\shell\open\ddeexec\ifexec

HKEY_CLASSES_ROOT\Shell\shell\open\ddeexec\topic

############################################################

No. 1.  It seem clear to me that by importing the Registry Tweak that you suggested that did in
fact get the second "Open Up With" option in both my Right-Click and File Menu after I have
selected any file.  The Second or bottem Open Up With has always been associated with
the Open Expert Program which I installed and it immediately open it up and runs fine.
It is the Top or first "Open Up" option that now  appears that appraently now appears
in the menu's since the importation but is not associated with the correct windows program, dll
or whatever.  Although If I waw supposed to see a "Open UP With" Folder Icon in the
Registry Hierarchy that is not there.

Notes about Open UP Registry

1. I assume the the “ddeexec Folder”  relates to the OpenExpert Program

2.  Note the second entry under this which specifies “No Activate Handler “
My guess is that is what is causing the error message of first Open Up With”
Selection in the Menu’s

Red Button
With White X+

            This file does not have a program associated with it for performing this
            action. Create an association in the Folder Options control panel.


                             (  OK   )

3.      Note the Characters  in both of the “ifexec” Folders , to wit:  []
That might be what is causing the error message?????

        The entire left panel of ifexec reads:    Icon ab(Default)          RG SZ    


If you don't think it is either of these that causes the problem , I could try the manual
proecure to try to add the Open With,

Where do I put it
and what does it say.
explain it to me in simple terms, I really need a "dumb country boy" explanation.  Please don't assume I can do any more without specific instructions. For what it's worth, I take instructions pretty good (at least according to my wife).Thanks in advance for your help
0
 
LVL 34

Expert Comment

by:sramesh2k
ID: 13694693
>> It is the Top or first "Open Up" option that now  appears that appraently now appears
in the menu's since the importation but is not associated with the correct windows program, dll
or whatever.

Let's make this further more clear. It's the "open-with" entry that mine adds (not "Open Up").

>> If you don't think it is either of these that causes the problem , I could try the manual
proecure to try to add the Open With

To add the open-with entry manually, try this:

Open Regedit.exe and navigate to:

[HKEY_CLASSES_ROOT\*\Shell]
Create a sub-key named "Open with"
Under "Open with", create a sub-key named "command"

Go here:
[HKEY_CLASSES_ROOT\*\Shell\Open with\command]
In the right-pane, double-click (default) value and type the following:

rundll32.exe C:\Windows\system32\shell32.dll,OpenAs_RunDLL %1

0
 
LVL 10

Author Comment

by:LRI41
ID: 13703937
sramesh2k ,

First I want again say I am sorry if I caused confustion, it was
always "Open With" , but for some reason I always want to
say "Open Up With"

Anyway, I creasted another Key called "Open with" and
a Sub Key called Command and inserted the suggestion.\,
and rebooted.

I still have the two "Open With" Options under both the Context
Menu and the File Menu, the top one still give the same error
message that I have posted above a couple of time and the
bottem one open up OPen Expert.  Right below the First
"Open With" under both Menus, I have an Option entitled
"Open" and if a file is selected it give me the Window

Windows cannot open this file

File  Nameand ext

to open this file, Windows needs to know wht program created it. Windows
can go online to look it up automaticially, or you can manually select from
a list of programs on your computer.

What do you want to do?

O Use the Web Service to find the appropriate program

0  Select the program from a list

##################################################

The top selection on the Menu depends somewhat on the file selected,
it ranges from "Preview, Play, and with and .exe file it is also called
"Open."

Now I guess I would really like to at least get rid of the First "Open With"
that is not associated with anything and see if there is some way to
add the word "With" to this one.
0
 
LVL 34

Expert Comment

by:sramesh2k
ID: 13704525
LRI41,

At this time, I can only think of uninstlaling the OpenExpert utility to isolate the problem. You can reinstall it back at a later stage.
0
 
LVL 10

Author Comment

by:LRI41
ID: 13712303
sramesh2K,

As suggested, I uninstalled Open Expert Utility, the only real change to the entire siutation is that the
"Second or bottem "Open With" option under both the Context Menu and the File Menu has disappeared and
the "Open" option under the First or what was the Top "Open With Option now immediately goes to the
Windows Open With List, rather than the option of going to it or to the Web.  The "Open With" Option still give
me the error message.  As Far as the Registry is concerned, nothing has changed in the "Shell" Hierarchy ,
except for the addition of the new "Open With Folder which has become the Third Sub Folder under the
Second Shell Folder, so it reads Shell, Shell then three Sub folders to that "explore". "open" and "open
with."  

1.  This lead me to conclude that the Open Expert Program registry entires went into some other
part of the registry and that these other entires under Explore and in the Open are trying to
connect to the Windows Operation that we got connected in the last one with the wrong name in
the option area.  

I am wondering if I shouldn't move the explore key up so it under the Firsh Shell Key and
the put the OPen With Key under that with the string and
Put a Second Sub Key under explore called "Open With and put that same string in there , and
get rid of the Second Shell Key and its sub keys.  Do you understand what I am saying?  or
it there an easer way.  I am really in an area that I am very uncomfortage in,
0
 
LVL 10

Author Comment

by:LRI41
ID: 13712320
I forgot to add here is the new open with Hierarchy

Additional  Third Sub Folder under the Second (which is also a Sub Shell Folder

“Open With”
HKEY_CLASSES_ROOT\Shell\shell\Open With

                                                 Left Pane

                                                Name        Type                 Data

                                      Icon ab(Default)          RG SZ     (Value Not Set)

 
Its Sub Folder “Command”
                         
                                               Left Pane

                                                Name        Type                

                            Icon ab(Default)          RG SZ  

         Data
 
  rundll32.exe C:\Windows\system32\shell32.dll,OpenAs_RunDLL %1                                                                            

Although as I keep saying it "Open" and Not Open With in both Menus.
0
 
LVL 34

Expert Comment

by:sramesh2k
ID: 13734739
>> "HKEY_CLASSES_ROOT\Shell\shell\Open With"

This does not exist by default in XP. Looks like an erroneous entry that you can backup and delete.
0
 
LVL 10

Author Comment

by:LRI41
ID: 13737167
Comment from sramesh2k
Date: 04/08/2005 03:44AM PDT
 Comment  


>> "HKEY_CLASSES_ROOT\Shell\shell\Open With"

This does not exist by default in XP. Looks like an erroneous entry that you can backup and delete.
 
####################################################

This is the one that you suggested that I put in manually:

#####################################################
Comment from sramesh2k
Date: 04/03/2005 08:28PM PDT
 Comment  


>> It is the Top or first "Open Up" option that now  appears that appraently now appears
in the menu's since the importation but is not associated with the correct windows program, dll
or whatever.

Let's make this further more clear. It's the "open-with" entry that mine adds (not "Open Up").

>> If you don't think it is either of these that causes the problem , I could try the manual
proecure to try to add the Open With

To add the open-with entry manually, try this:

Open Regedit.exe and navigate to:

[HKEY_CLASSES_ROOT\*\Shell]
Create a sub-key named "Open with"
Under "Open with", create a sub-key named "command"

Go here:
[HKEY_CLASSES_ROOT\*\Shell\Open with\command]
In the right-pane, double-click (default) value and type the following:

rundll32.exe C:\Windows\system32\shell32.dll,OpenAs_RunDLL %1

###############################################

Which I did and reported these results:

Comment from LRI41
Date: 04/04/2005 08:39PM P
Anyway, I creasted another Key called "Open with" and
a Sub Key called Command and inserted the suggestion.\,
and rebooted.

I still have the two "Open With" Options under both the Context
Menu and the File Menu, the top one still give the same error
message that I have posted above a couple of time and the
bottem one open up OPen Expert.  Right below the First
"Open With" under both Menus, I have an Option entitled
"Open" and if a file is selected it give me the Window Open With Program.

################################################

Now is I delete this Sub Key and Key, since I have also deleted the
Open Expert Program, that , of course, will delete the "Open"
selection from the Menu's which go to the Windows Open With
Program, and leave me with no "Open With" program at all, but
with two "Open With" options ( on on each menu, i..e.
"the right click and the "File Menu"that don't work.  Its ihe
the other keys with the "No Active Handlier" which I think are the
cause of the error message on the "Open With Option selections.

0
 
LVL 34

Expert Comment

by:sramesh2k
ID: 13738264
LRI41,

I suggested to add here:
[HKEY_CLASSES_ROOT\*\Shell\Open with]

Which is different from this:
HKEY_CLASSES_ROOT\Shell\shell\Open With

See if deleting the second "open with" after backing it up. If that does not help, this may be a tough call, and perhaps need a remote assistance session (LOL)
0
 
LVL 10

Author Comment

by:LRI41
ID: 13745250
sramesh2k , Ill try to give you a full report either later tonight, tommorrow or
MOnday, suffice to say, I now have just the "Shell" folder" and it has two
entires, and I think I may be this second one maya be the problem, I am sure
it has been there all along, but I didn't see it listed above but I just make a cursory
look.  the First line is the Default and the Reg SZ, but the second line
immiediately under it reads: "Icon ab URL Protocol      Reg_SZ"

the the next folder is the "Open With" Sub Folder "command" and the suggested line as posted.

Everything else than was in there including the Second Sub Shell Folder and all the other Sub folders have been
deleted.  But I still get Both the "Open With" Selection on both my Context Menue and the File Menu and when
I click on it, I still get the same error message, and immediately below that "Open With" Selection if
"Open" which when clicked on I get the  Windows  "Open With" Program.
0
 
LVL 10

Author Comment

by:LRI41
ID: 13745826
A Futher Update, I have not made any more changes to the Registry, but I
did run a couple of Registry Cleanors, and the Menu Selection "Open With"
which gave the error message is now gone in both the Context Menu and the
File Menu, but I still have the Open Selection that run the Windows Open 'With
Program, but the Selection is called "Open" Wish I knew how to change the name
of it on the Menus?

I going to check with my Oldest Son tommorrow or Monday and see what
his Registry says, as we have the identical Computers which arrived at
the same time , but of course, with different programs, but in this
part of the Registry, I wouldn't think that matters,  I want to see if
his reads with the same second line in the First Sheel Folder about
the URL etc.
0
 
LVL 34

Expert Comment

by:sramesh2k
ID: 13746073
Thanks for the feedback, LRI41. Context-menus load from different registry areas, and it's a pretty difficult area to troubleshoot (especially if one does not have a system in front of him). Good luck on the other issue, and keep us posted :-)
0
 
LVL 10

Author Comment

by:LRI41
ID: 13749169
sramesh2k ,Final Report.  Thanks for all you time, I have increased the point value
another 100 for a total of 300 (which probably is still not enough) and I will choose
one of you comments as the answer.  Anyway. the bottem line is that my eldest son
exported and sent me his "Shell" Key which by the way includes a second sub "Shell"
Key just like I had when I first started with all the same entries that I had, except
there was no such lanugare of such about "No actiave handler"  Anyway, I first
deleted the "Open With" entry that I had manually put in , rebooted, and then
merged his Reg Modication into my Registry and Re-booted,  I still have the
"Open" selection on both Menus that runs the "Windows Open With Program"
and as I previously said I have gotten rid of the bad "Open With" Selection that
use to be on both Menus, so I did accomplish something.  I think this Selection
called "Open" has been there for a long time and I never clicked on it, as I
alway thought that would be just like double-clicking on the file and either
open or run the file wheatever is needed to be done.  So I don't think
that came about by anything we have done in the past week or ten days
in this thread.  In Fact, I deleted the "OPen With"entry that I had manually
put in and re-booted, and before putting in the Reg Modication from my son,
I went to a folder and selected severral different files, and without anything
at all under the "Shell" folder this "Open' option running to Windows OPen "
With was still there.  So I can live with iit, the way it is. i.e. I will just run
the Windows Open With though this "Open" option which rreally should be
reading Open With, but for whatever reason will not so read.  I will also
re-install OPen Expert whick will give me an Open with Option that will
run with that program.  I'll just remember it just like bridge, sometimes
you have to pretend that 5 card Ace through 10 is a six card suit and re-bit it.
thanks again for all you time and help.
0
 
LVL 34

Expert Comment

by:sramesh2k
ID: 13750396
Thanks for the detailed feedback, LRI41. Sorry for not being of much help in this matter.
0
 
LVL 10

Author Comment

by:LRI41
ID: 13753534
"Sorry for not being of much help in this matter."
As the Questioner, I wouldn't ssay that.  True,
"Open" says Open not OPen with, but at leasst
you got me into places Ive always been afraid
to enter, and I did get rid of the bad "Open With"
Menu Selection, Anyway, both my eldest son and
I have identical Shell Keys and he gets "Open With
and I only get "Open" but with the same result and
as you said:
Context-menus load from different registry areas, and it's a pretty difficult area to troubleshoot (especially if one does not have a system in front of him . No need to reply I am Unsubscribing"
0

Featured Post

Simplifying Server Workload Migrations

This use case outlines the migration challenges that organizations face and how the Acronis AnyData Engine supports physical-to-physical (P2P), physical-to-virtual (P2V), virtual to physical (V2P), and cross-virtual (V2V) migration scenarios to address these challenges.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We have adopted the strategy to use Computers in Student Labs as the bulletin boards. The same target can be achieved by using a Login Notice feature in Group policy but it’s not as attractive as graphical wallpapers with message which grabs the att…
Issue: Unstable cursor in Windows XP and Windows runs extremely slow in that any click will bring up the Hour glass (sometimes for several seconds before giving you what you want) . Troubleshooting Process and the FINAL FIX: This issue see…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…
Suggested Courses
Course of the Month9 days, 12 hours left to enroll

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question