• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 220
  • Last Modified:

Processor time optimization questions

Alright, I'm somewhat new with Linux, so these questions might come off as very...."duh, the answer is so simple, it's this stupid"; but I have yet to find either in any resource I've been able to use, so here goes.
Oh, before going there, I'm running SuSE 9.2 with all of the latest updates.

First of all, I'm having a semi common issue (I'd say like maybe once a month) where my linux computer (which is something of a jack-of-all-trades - I use it for everything from my home router to a small webserver to an ssh/vnc terminal that I can learn on) will get so enthralled into some process that after 10 minutes of waiting for sshd to prompt me for my password that I'm just forced to give it a hard reboot.  I'm not asking for help remedying this, because I think I can figure it out for myself if I can get on the thing while it's doing it (and I kinda like figuring things out for myself); but is there some way for me to prioritize processes the way that I can on Windows such that sshd and other such apps are given the highest priority so even if something's trying to suck the life out of my processor I can still get in and figure out what's going on.

Secondly, and this is the question that makes me feel stupider of the two, how do I get it to not boot into a graphical login screen locally when I'm starting up?  The machine is all but headless, and is almost never used with a direct connection to the computer, so having it boot into the KDE login screen just seems like a waste of valuable resources.  How can I get it to boot to a bash login or whathaveyou?

Thanks for any and all help you all can provide.
0
daPyr0x
Asked:
daPyr0x
  • 4
1 Solution
 
wesly_chenCommented:
> sshd and other such apps are given the highest priority
Use command "nice" to prioritize the running process.
Do "man nice" for more details since you like to figure thing out for yourself.

> how do I get it to not boot into a graphical login screen locally when I'm starting up?
Edit /etc/inittab
id:5:defaults.....
change to
id:3:defaults......
change from run level 5 (graphic mode) to run level 3 (text mode).
0
 
wesly_chenCommented:
>after 10 minutes of waiting for sshd to prompt me for my password
The reverse DNS lookup issue on sshd.
Either add your hostname and IP address of Windows PC into /etc/hosts or
eidt /etc/ssh/sshd_config:
UseDNS no

and restart sshd.
/etc/init.d/sshd restart.

Wesly
0
 
daPyr0xAuthor Commented:
Much appreciation.

Question though; this reverse DNS bit - I only ever get that issue when the box is getting eaten alive like I was talking about before; when I can't log in locally much less over the ssh - is that still the same issue?  better yet - is it an issue when the linux box is the dhcp server assigning my windows box's ip?
0
 
wesly_chenCommented:
For security, sshd, by default, check the client machine's IP for valid DNS (hostname--IP) entry.
So if your DHCP server doesn't feed the DNS server the hostname--IP information of DHCP client (this
feature called DDNS, Dynamic DNS), then sshd will wait for reverse DNS lookup timeout and prompt for
password or wait for a long time to login. So turn off "UseDNS" in sshd configuration will bypass it.
0
 
wesly_chenCommented:
By the way, the option may be different from sshd version.
Please do
man sshd_config
for the right option
(In RH 7.2:-   ReverseMappingCheck   no
In RH 7.3 above:-   VerifyReverseMapping   no)
Or
echo 'OPTIONS="-u0"' >> /etc/sysconfig/sshd
for RedHat/Fedora
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now