Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1560
  • Last Modified:

Back to the GRUB GUI

I installed Fedora Core 3 with WinXP and using GRUB (in GUI mode) to select OS to boot. Everything's perfect, I can boot to both OS easily.
But lately, I don't know why my Grub always start in Command mode.
In this mode, I don't know how to boot to any OS.
I'm a newbie to Linux, so I really don't know how to get back to GRUB's GUI.
0
huy302
Asked:
huy302
  • 4
  • 4
1 Solution
 
wesly_chenCommented:
> why my Grub always start in Command mode.
You mean like
Grub >
?

   It seems your disk have some problem or the boot loader has wrong entry or corrupted.

   Boot from FC3 first CD and type
linux rescue
   to boot into rescue mode.

   Then do
df -h    # check the partition file system
fsck -y /dev/hda1   # run disk check on ext3 partition, do NOT fsck on Windows partition (NTFS)
fsck -y /dev/hda2
...
chroot /mnt/sysimage
/sbin/grub-install /dev/hda   (assume your hard disk is IDE primary master) to reinstall Grub on MBR
exit

Regards,

Wesly
0
 
huy302Author Commented:
after using the command "df -h", I think that the ext3 partition which I use to install Fedora is /dev/VolGroup00/LogVol00 (because it's capacity is 10GB)
then I use the command "fsck -y /dev/VolGroup00/LogVol00" , -> Yes
then "chroot /mnt/sysimage"
then "/sbin/grub-install /dev/hda"
after the installation of grub finished, it shows a table that was generated by Anaconda and ask to modify it if I want to (but I don't know how), so I just enter the command "exit" and restart my computer.
Then, I still don't see grub GUI, when I turn on my computer, it will automatically boot to Windows XP (like I never installed Fedora)
Did I do something wrong?
0
 
wesly_chenCommented:
> fsck -y /dev/VolGroup00/LogVol00
> /sbin/grub-install /dev/hda
It looks like your boot device is not /dev/hda.
Could you boot into rescue mode and do
cat /mnt/sysimage/boot/grub/devices.map
cat /mnt/sysimage/boot/grub/grub.conf
and post the output here?
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
huy302Author Commented:
I reinstalled Grub and then
cat /boot/grub/devices.map

# this device map was generated by anaconda
       (fd0) /dev/fd0
       (hd0) /dev/hda

cat /boot/grub/grub.conf

default = 1
timeout = 5
splashingimage (hd0,8)/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.6.9 - 1.667)
      root (hd0,8)
      kernel /vmlinuz - 2.6.9-1.667 ro root=dev/VolGroup00/LogVol00 rhgh quiet
title WinXP
      root noverify (hd0,0)
      chainloader +1

This time, I can boot to grub GUI, but when I select Fedora Core (2.6.9 - 1.667)

Booting 'Fedora Core (2.6.9 - 1.667)'
root (hd0,9)
      Filesystem type unknown, partition type 0x7
kernel /vmlinuz - 2.6.9-1.667 ro root=dev/VolGroup00/LogVol00 rhgh quiet
Error 17 : Cannot mount selected partition
Press any key to continue...

Does it mean that my Fedora partition was somehow damaged and I have to reinstall my Fedora?
In fact, I can easily reinstall Fedora because these is no important data stored in my Fedora, but I really want to look for a better solution.

I will accept your answer, wesly_chen. But can you give me some further advice with this problem ?
I will really appreciate that.
0
 
huy302Author Commented:
I want to add a detail that, it is not that I can boot to Grub GUI, but I realize that the Grub GUI was somehow become a black screen. It means that, when I boot up my computer, instead of the Grub blue screen, I receive a totally black screen.
Grub works, but the monitor shows nothing.
When I press up or down button on the keyboard, I can select the boot partition.
That's how I booted to the Fedora Core and receive the error above.

Does it mean that these are some problems with my graphic device?
I'm using Intel 865GAV mainboard with the Intel Graphics Extreme 2 intergrated on it, I don't think that Intel Graphics Extreme 2 is not compatible with Grub to cause the black screen. Everything worked perfect before I installed into my computer an unusable hdd (I just want to recover it).
0
 
wesly_chenCommented:
> /boot/grub/grub.conf
>      kernel /vmlinuz - 2.6.9-1.667 ro root=dev/VolGroup00/LogVol00 rhgh quiet
There is a typo or syntax error
It should be
... root=/dev/VolGroup00/LogVol00 ....
          ^^^

On Grub boot menu, press "e" twice, the
modify to
kernel /vmlinuz - 2.6.9-1.667 ro root=/dev/VolGroup00/LogVol00 rhgh quiet
Then "enter" and "b" to boot.

After successfully boot up, then correct it in /boot/grub/grub.conf.

Wesly
0
 
wesly_chenCommented:
> Grub works, but the monitor shows nothing.
Then take out "rhgh" in /boot/grub/grub.conf
kernel /vmlinuz - 2.6.9-1.667 ro root=dev/VolGroup00/LogVol00 quiet

Some graphic card doesn't support it.
0
 
huy302Author Commented:
>      kernel /vmlinuz - 2.6.9-1.667 ro root=/dev/VolGroup00/LogVol00 rhgh quiet
it just my typo error :)

I did take out "rhgh" in /boot/grub/grub.conf
kernel /vmlinuz - 2.6.9-1.667 ro root=dev/VolGroup00/LogVol00 quiet

but it still shows nothing :(

However, I did learn a lot from this issue.
Thanks a lot, wesly_chen

0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now