?
Solved

Error Installing PHP on IIS 6.0

Posted on 2005-03-30
7
Medium Priority
?
830 Views
Last Modified: 2008-01-09

I am installing PHP 4.3.9 on a Windows 2003 Standard Edition Server with IIS 6 using the ISAPI module. When the site tries to load the isapi filter, the load fails. Upon checking the Event Viewer, the following messages are present:

---------------------------
Event Source:      W3SVC-WP
Event ID:      2214
Description:
The HTTP Filter DLL C:\PHP\php4isapi.dll failed to load.  The data is the error.
---------------------------
Event Source:      W3SVC-WP
Event ID:      2268
Description:
Could not load all ISAPI filters for site/service.  Therefore startup aborted.
---------------------------

I am using manual installation of PHP performing the following actions:

- Extract PHP zip (downloaded from php.net) to a "PHP" folder and copy folder to C:\
- Rename php.ini-reccomended to "php.ini"
- Enter the extensions path in the php.ini file ("c:\PHP\extensions")
- Add C:\PHP to the PATH environment of Windows
- Add C:\PHP\sapi\php4isapi.dll to ISAPI filters in site of IIS
- Add .php ISAPI mapping to site in IIS
- Add index.php to default document list (although that should have no affect on any of the above)

Permissions on the C:\ PHP folder are as follows:

- Administrators: Full Control
- System: Full Control


I have used the above procedure on many servers without problems (2000 and 2003)... For some reason this one is giving me grief.

Any help would be greatly appreciated.
Thanks
- Ryan
0
Comment
Question by:guitar7man
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
  • +1
7 Comments
 
LVL 33

Expert Comment

by:humeniuk
ID: 13667048
You may want to post a pointer to this question in the PHP Installation area - www.experts-exchange.com/Web/Web_Languages/PHP/PHP_Installation/
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 13667050
Or have a Mod move it there if you don't get much response.
0
 
LVL 34

Accepted Solution

by:
Dave_Dietz earned 500 total points
ID: 13669763
Try adding IIS_WPG with at least read/execute permissions to the c:\php folder.

By default w3wp.exe runs as NETWORK_SERVICE and would not be included in either Administrators or SYSTEM.

Dave Dietz
0
Optimum High-Definition Video Viewing and Control

The ATEN VM0404HA 4x4 4K HDMI Matrix Switch supports 4K resolutions of UHD (3840 x 2160) and DCI (4096 x 2160) with refresh rates of 30 Hz (4:4:4) and 60 Hz (4:2:0). It is ideal for applications where the routing of 4K digital signals is required.

 
LVL 3

Author Comment

by:guitar7man
ID: 13671006
Your the man Dave!

That worked... But what I don't understand, is that I have seven other W2k3 servers that I installed without including the IIS_WPG user in the permissions scheme and they work...

If you don't mind, could you elaborate a little more on the purpose of the IIS_WPG user?

Thanks again for your help.
0
 
LVL 34

Expert Comment

by:Dave_Dietz
ID: 13680793
The IIS_WPG group is simply the list of accounts that are allowed to start an Application Pool (w3wp.exe) process.  The group is also given permissions to the locations that the w3wp.exe needs to access since the w3wp.exe processes will run as one of the accounts in this group.

By default is should include LOCAL_SYSTEM, LOCAL_SERVICE, NETWORK_SERVICE and IWAM_machinename.

If you configure an Application Pool to run under a custom identity the custom identity it will need to be added to the IIS_WPG group..

Dave Dietz
0
 

Expert Comment

by:mstefani
ID: 14794778
Hi,

I have a similar error but am not using any php, just standard win2k3 sbs w/sp1.

The HTTP Filter DLL D:\Program Files\Exchsrvr\ExchWeb\bin\auth\OwaAuth.dll failed to load.  The data is the error.

I get this everytime I try to access any web page on this server.

Anyone have an idea what to do?

Thanks,

Mike

0
 

Expert Comment

by:mstefani
ID: 14795124
I figured it out.  It seems to be a permissions error as others on this site have stated.  I looked at one of my other win2k3sbs servers and saw that the permissions for the particular file in the error

"D:\Program Files\Exchsrvr\ExchWeb\bin\auth\OwaAuth.dll"

were different on that server.  So I matched them,(I think it was the missing anonymous access account that did it), I did an iisreset and it worked.

I hope this helps others....

Mike
0

Featured Post

Moving data to the cloud? Find out if you’re ready

Before moving to the cloud, it is important to carefully define your db needs, plan for the migration & understand prod. environment. This wp explains how to define what you need from a cloud provider, plan for the migration & what putting a cloud solution into practice entails.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
What You Need to Know when Searching for a Webhost Provider
Visualize your data even better in Access queries. Given a date and a value, this lesson shows how to compare that value with the previous value, calculate the difference, and display a circle if the value is the same, an up triangle if it increased…
Have you created a query with information for a calendar? ... and then, abra-cadabra, the calendar is done?! I am going to show you how to make that happen. Visualize your data!  ... really see it To use the code to create a calendar from a q…
Suggested Courses
Course of the Month8 days, 14 hours left to enroll

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question