Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 453
  • Last Modified:

ACT! 2000 - wont do re-index function, "not enough disk space" error message, demanding mapped network drive

When I need to do routine database maintenance function "re-index", I get a warning message the prevents me from doing the task.    

The message reads:
" You may not have enough space to perform this operation.  If a network drive is not mapped ACT! cannot determine if you have enough disk space to complete this operation.  Your database could be damaged if you proceed without enough disk space.  "

There is plenty of space on the local drive(s).

0
james231
Asked:
james231
  • 4
  • 3
  • 2
  • +1
1 Solution
 
moorhouselondonCommented:
What drive is the ACT data stored on?  If it is stored on anything other than the C: drive then it sounds like you need to do one of the following:-

(1) Ascertain the overall size of all your data including the index files (basically how many bytes are used in the directory where your data is contained).  Check that there is say, at least ten times the amount of free space on the same drive available to perform the reindex operation.  If this is the case, then the risk the program is asking you to take is an acceptable one.

(2) Map a network drive instead of using UNC convention to access your ACT data.  You can do this from Windows Explorer, Tools, Map Network Drive.  You will need to configure ACT to use whatever drive letter you choose when you do the Mapping.

(3) If the data is on a pc with ACT fully installed on it, and it is pointing to the data directly, not via a network share, run the Reindex operation from there.

Out of these (3) is the recommended choice.  Note that everyone needs to be out of ACT as well when you perform this operation.
0
 
james231Author Commented:
Sorry for long delay on this.  Other pressing issues.

The data is very small - 20-30MB,  and there is 1gig free on drive.

Program on Drive D:    Data on Drive D: (in different folder).   On Win2003 server.

The message error does not give any choice to proceed, simply has "OK" button, no choice to continue ignoring message.

It does allow me to back up the data, but does not allow the reindex function.   It appears that it is running in number 3 above, though it is not on the c: drive, the data and program are on the same machine and on the same drive.

Any other thoughts ?
0
 
moorhouselondonCommented:
Backup all your data elsewhere on your pc, then try deleting all the indexes: that will force a re-index.  There is a utility called ACTDIAG within the Act directory which will enable you to do this.
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
james231Author Commented:
I can do that,  do you know the file extention(s) for the indexes -  so I know which ones to delete...
0
 
moorhouselondonCommented:
Um it's a while since I scratched below the surface of Act.  From memory Act I believe still uses XBase, so it could be any of the following NTX CDX NDX MDX.

I must emphasis again the need for a backup before attempting this.
0
 
james231Author Commented:
That did it !  

The  ".MDX" file was the one, I deleted that and when I reopend ACT, it informed me that the index was missing and proceeded to rebuild it.  issue resolved.  (I did back it up prior just in case).

Thanks !
0
 
PEOCENTRALCommented:
Is there anyway to reindex after the fact without going through this whole process?
0
 
moorhouselondonCommented:
Not sure what you mean, but reindexing is a fact of life for many applications.  You could construct a batch file that deletes all mdx's and put a short cut to it on the desktop.
0
 
PEOCENTRALCommented:
Yeah, that would work. I was asking because the reindexing is executed by the user's own accord, and he's not too fond of deleting the files manually whenever he needs to reindex. I didn't think of the batch file. Thank you!
0
 
OML_GuyCommented:
The problem with getting the message " You may not have enough space to perform this operation" may also mean that you are attempting to load/unpack/install to an invalid drive assignment.  My Documents was pointing to an invalid network location during an install.  That caused the problem message for me.
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 4
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now