?
Solved

Windows 2000 Simple Networking

Posted on 2005-03-30
20
Medium Priority
?
346 Views
Last Modified: 2008-01-09
I have two PCs.

Both Win2K Pro.

Both have NICs installed, proper drivers, functioning perfectly.

Both are connected via the LAN cable to a Linksys router/firewall.

Both are accessing the internet perfectly.

Both have the following components installed (checked) under the LAN properties -
1. client for microsoft network
2. file & printer sharing
3. netbeui protocol
4. tcp/ip  (obtain IP address automatically is checked)

Both have, under their main C: drives, a seperate folder called "shared" with sharing priviledges.

For the life of me, I can not get these folders to show up under My Network Places.

Can anyone suggest a place to start?

Thanks,
RNM





0
Comment
Question by:zchuss
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 5
  • 2
  • +3
20 Comments
 
LVL 13

Expert Comment

by:gpriceee
ID: 13667790
Get rid of netbeui
If you want to see the folders, install WINS
Ensure that on the router you only enable WINS on the LAN side, and include it in the DHCP options, unless you're using static addresses.

If you're using static, just enter the gateway address (the address of the router) as the WINS server.

On the workstations, if DHCP, at the cmd prompt, run the following command:
ipconfig /renew
0
 
LVL 13

Assisted Solution

by:gpriceee
gpriceee earned 80 total points
ID: 13667793
Install WINS on the workstations
ENABLE WINS on the router . . . just to be clear
0
 

Author Comment

by:zchuss
ID: 13667810
i appreciate your answer, but in all honesty, this is how i've always done it before with no problems.  ive always had netbeui in the past.  ive never had wins.  and its worked,  except for this time.  i've never had to fool with dhcp options in the router before.  im not using static addresses.

when i click on "computers near me" under "network places" i get the message

"workgroup is not accessible. the list of servers for this network is not currently available."

thanks again,
RNM
0
ATEN's HDBaseT Presentation at InfoComm 2017

Hear ATEN Product Manager YT Liang review HDBaseT technology, highlighting ATEN’s latest solutions as they relate to real-world applications during her presentation at the HDBaseT booth at InfoComm 2017.

 
LVL 13

Assisted Solution

by:2hype
2hype earned 80 total points
ID: 13667955
Make sure under the Tcp/ip settings, That you enable netbios over tcp/ip.

GO to control panel, Network connections, Right click your LAN and select Properties

Select tcp/ip and select properties, Click Advanced,  I think its under the wins tab, Select Enable Netbios over tcp/ip on both workstations.

Ensure that The Linksys Router is assiging the the DHCP Addresses and not the ISP.

Can you go \\IpAddress\Share, example \\192.168.0.10\Share <--- WHere the IP Address is one of the compters.  If you can do this IP Address should be setup right.

Are they part of the same Workgroup?
0
 

Author Comment

by:zchuss
ID: 13668032
again, i sincerely believe this is uneccessary from my experience.  i have never had to do this (ienable netbios over tcp/ip) in the past to get two win2k boxes to see each other over a lan with this router (linksys befsr41).  i have never had to make any setting adjustments to my router (dhcp or otherwise) to get two win2k machines to see each other.

thank you but the answer im looking for i think is simpler.  does anyone have a good tutorial they can direct me to?

thanks,
RNM

0
 
LVL 7

Assisted Solution

by:dttri
dttri earned 80 total points
ID: 13668626
 As in 2hype question:
Are they part of the same Workgroup?
  Do you have any firewall turned on on PCs?
0
 

Author Comment

by:zchuss
ID: 13668645
I believe they are part of the same workgroup -- what can I do to verify this.

When i click on "computers near me" under "network places" i get the message --

"workgroup is not accessible. the list of servers for this network is not currently available."

I have no software firewalls.  The only firewall is the router itself (hardware firewall).

Thanks,
RNM

0
 
LVL 23

Accepted Solution

by:
sciwriter earned 180 total points
ID: 13668660
It's amazing how people automatically say to get rid of Netbeui and IPX protocol -- yet both of these are easier for LOCAL networking than IP -- and were the underpinniings of ALL novell and windows netowrks originally.  Let me state here, there is NOTHING wrong with either NetBeui or IPX protocol -- they are very robust, although "chatty", and they are LIMITED TO LOCAL networking, so unlike TCP/IP, they cannot be hijacked from the internet or another network.  SO if you like them, LEAVE them, they are JUST FINE !!!

The reason you have never had to battle wins or dhcp is because you use local networking protocols.  It is possible that the stacks for these transport layers have become corrupted with time.  TCP/IP is easy to corrupt, and so are the others.  The solution is simple -- total removal of everything, then clean reinstall.

If you are comfortable that you can recreate your exact setup, then go for this -- go into the networking setup of BOTH computers, and simply blow it ALL away.  Whatever you see, wipe it out, until there is nothing left.  Make sure your login to both computers is the same name and password (on no password).

Turn both off, have a cup of tea, come back and boot one, and reinstall all the networking, as you want it.
Turn it off.  Turn on the second one, do the identical setup for it, differing ONLY by computer name, and then boot the other one.  Share drives on both systems again.  Now I bet you are up and runnning ?
0
 
LVL 4

Assisted Solution

by:Justin Malone
Justin Malone earned 80 total points
ID: 13668670
right click on my computer
click on the computer name tab

on this screen you can check what workgroup you are in

click on change to change it
0
 

Author Comment

by:zchuss
ID: 13668849
when i right click on my computer i get a menu

nothing in that menu says "computer name"

if i click "network identification" i can see i am in workgroup named "workgroup"

0
 
LVL 23

Expert Comment

by:sciwriter
ID: 13668931
right click my computer -- properties, then computer name tab, then the change button at bottom, and make sure both computers are part of the same workgroup.  I assumed you already knew/did this.
0
 

Author Comment

by:zchuss
ID: 13669014
in windows 2000 there is no 'change' button at the bottom of the name tab. in fact there is no name tab.  there is a network identification tab, which gives the computer name.

both computers are members of the same workgroup, names 'workgroup'

0
 
LVL 23

Expert Comment

by:sciwriter
ID: 13669075
I figured you had that one covered.  So go back to my original post, it is complete, and it will work.
0
 
LVL 23

Expert Comment

by:sciwriter
ID: 13669085
BTW -- windows 2000 is NOT simple networking.  It is all based on user login names, passwords and other "complex" networking that servers use.  There is no simple setup -- therefore, unless you go to XP, you will have to make sure that you use the same login name (in doc and settings) on all systems with the same passwords, or else go into users and groups on each system and assign a login on each computer for the other computers.  Otherwise, you will struggle with its complex networking.
0
 

Author Comment

by:zchuss
ID: 13670656
thanks for you info.

 i have made "simple" two computer networks for the last several years using windows 2000.

in each case it was simple was a 4-5 minute operation, and never involved making a new or seperate login on each computer.

RNM

0
 

Author Comment

by:zchuss
ID: 13672318
sciwriter --

you wrote "If you are comfortable that you can recreate your exact setup, then go for this -- go into the networking setup of BOTH computers, and simply blow it ALL away.  Whatever you see, wipe it out, until there is nothing left.  Make sure your login to both computers is the same name and password (on no password)."

.....

yes, i am comfortable with this.  it is very simple operation to delete and then add back
1. client for microsoft network
2. file & printer sharing
3. netbeui protocol
4. tcp/ip  (obtain IP address automatically is checked)

however what i do not understand, is your comment about loggin into both computer with the same name and pass.  that is strange to me.  

here's is what i have always done in the past.

1. install network components listed above
2. set up a single folder on each computer with share priviledges

the problem i am having is that when i do this, i am not seeing the other computer in the "my network places" window.  they cant find each other.

cables and connections are not the issue.  i think your idea is a good one, but before i proceed, can you say a word about the loging in with same name question.  its not something i was ever required to do in the past when setting up a 2-machine network this way.

thanks.

RNM
0
 

Author Comment

by:zchuss
ID: 13672560
I just deleted all the components on one machine, and then attempted to re-install them.

When attempting to save changes made to the LAN connection properties in Windows 2000, I get the following error: "You must enable one or more other components for the following component(s) to work properly: Client for Microsoft Networks, File and Printer Sharing for Microsoft Networks. Do you want to re-specify your selection? Click no to continue."
0
 

Author Comment

by:zchuss
ID: 13673137
ok -- i figured it out.  after i delted the components from one machine, i had trouble re-installing them.  to fix that problem, i tried re-installing them in a different order.  the order that worked, was to installed the protocols first then the F+P sharing and then the client for MS networks.

next, i was finally able to get these darned machines to 'see' each other by doing a simple "search for computer" on each machine.

dang! i hate when something as simple as this absorbs so much of my time.

thanks to all who offered help.

i'd like to distribute points to everyone.

2hype
dttri
squallkill99
gpriceee
sciwriter

 can i give to more than one?  how do i do that?


0
 
LVL 4

Expert Comment

by:Justin Malone
ID: 13673260
if you go down to the bottom of this screen. right above where you would type a new coment. click on split points.
0
 
LVL 23

Expert Comment

by:sciwriter
ID: 13686707
Glad that my directions fixed your problem.
0

Featured Post

Don't Cry: How Liquid Web is Ensuring Security

WannaCry is just the start. Read how Liquid Web is protecting itself and its customers against new threats.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Short answer to this question: there is no effective WiFi manager in iOS devices as seen in Windows WiFi or Macbook OSx WiFi management, but this article will try and provide some amicable solutions to better suite your needs.
For many of us, the  holiday season kindles the natural urge to give back to our friends, family members and communities. While it's easy for friends to notice the impact of such deeds, understanding the contributions of businesses and enterprises i…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…
Suggested Courses

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question