URGENT: SSH to server freezes after "Last login: Thu Mar 31 13:52:14 2005 from gateway.domain.com"

I have an urgent problem at work which I need help with.
For some unknown reason, I can no longer log in with ssh to one of my servers.

Regardless of whether I use Putty in win XP or ssh from a linux box I get the following coming up:

login as: root
Sent username "root"
root@192.168.0.71's password:
Last login: Thu Mar 31 13:52:14 2005 from gateway.domain.com

At that point it just hangs and I never get my bash prompt up.  Can anyone help me as I can't afford to reload the server at the moment and there must be a way to fix this without doing that.

The same thing happens when I ssh to the LAN or WAN IP.

Thanks in advance,

Paul.
phreak7t7Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

harbor235Commented:
Is there something wrong with your shell login scripts for root?
Do you have local access to this box? I would check to see which shell
root is using and take a look at root's logi scripts. Just a start


harbor235
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
wesly_chenCommented:
Hi,

   Could you post your /etc/ssh/sshd_config and /var/log/messages so people here can have more information to help you?
grep -v "^#" /etc/ssh/sshd_config
grep -i sshd /var/log/messages

   Also, does your login from an machines with DHCP client, which get dynamic IP address?
If yes, make sure your DHCP client have a DNS entry. You can test by
nslookup <DHCP client IP>
to see if you have a hostname entry in DNS server.

   Otherwise, you might need to disable reverse DNS lookup in /etc/sshd_config.

Regards,

Wesly
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.