Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Cisco Router Configuration

Posted on 2005-03-31
6
Medium Priority
?
403 Views
Last Modified: 2010-04-17
Hi, this is probably an easy question for you experts. I am upgrading a router from a 1600r with an external CSU/DSU to a 2651XM with a WIC-T1DSU-V2. The setup is pretty basic, we currenlty have one T1 going straight to the external CSU/DSU then to the router, a Cisco PIX sits between the LAN and router. All 24 channels on the T1 are being used. My goal is to move the T1 to the new router.
I replicated the router config from the old router to the new, moved the T1 cable to the WIC. Despite my confident approach, I was not able to get to the internet. The ISP was able to see the serial interface though. I have a feeling I am missing an important routing command or that my WIC is configured wrong as the communication between the ethernet and serial interfaces are not sucessful.
Any ideas? Here is the current config for the new router:

FYI: Eventually, I want to configure per-packet load balancing with an additional T1 from the same ISP. Hence, serial 0/1 is configured with an IP, my first step is to move from the old T1.

Current configuration : 985 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname
!
enable secret 5
enable password 7
!
ip subnet-zero
!
!
ip name-server z.z.z.132
ip name-server z.z.z.133
ip name-server z.z.z.134
!
no call rsvp-sync
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address x.x.x.1 255.255.255.224
 no ip mroute-cache
 speed auto
 full-duplex
!
interface Serial0/0
 ip address a.b.c.250 255.255.255.252
 no ip mroute-cache
 no fair-queue
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address d.e.f.10 255.255.255.252
 no ip mroute-cache
 no fair-queue
!
ip classless
ip route 0.0.0.0 0.0.0.0 x.x.x.249
no ip http server
!
!
dial-peer cor custom
!
!
!
!
line con 0
line aux 0
line vty 0 4
 password 7
 login
end

Thanks!!
0
Comment
Question by:mrbling
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 13674288
Can you post result of "show ip int brief"
and "show interface"
Can you ping your default gateway from the router console?
0
 

Author Comment

by:mrbling
ID: 13675220
Ahh, I cannot answer on the default gateway ping as I would have to take down the internet briefly from the 1600. I am assuming I cannot. I know the serial interface 0/1 shows as being up, this is my second T1 which physically is connected but not "turned up" by the ISP. They are waiting for me to get this new router online. The results of the "show" commands are:

FastEthernet0/0 is up, line protocol is down
  Hardware is AmdFE, address is 000b.be49.4140 (bia 000b.be49.4140)
  Internet address is x.x.x.1/27
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, Auto Speed, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 12:04:35, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     6039 packets input, 545037 bytes
     Received 2 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     6242 packets output, 384063 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     4375 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Serial0/0 is down, line protocol is down
  Hardware is PQUICC with Fractional T1 CSU/DSU
  Internet address is a.b.c.250/30
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 254/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  Last input 12:05:03, output 12:05:07, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     1074 packets input, 50732 bytes, 0 no buffer
     Received 55 broadcasts, 0 runts, 1 giants, 0 throttles
     1 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     67 packets output, 4857 bytes, 0 underruns
     0 output errors, 0 collisions, 1451 interface resets
     0 output buffer failures, 0 output buffers swapped out
     2 carrier transitions
     DCD=down  DSR=up  DTR=up  RTS=up  CTS=down

FastEthernet0/1 is administratively down, line protocol is down
  Hardware is AmdFE, address is 000b.be49.4141 (bia 000b.be49.4141)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Auto-duplex, Auto Speed, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Serial0/1 is up, line protocol is down
  Hardware is PQUICC with Fractional T1 CSU/DSU
  Internet address is d.e.f.10/30
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  Last input never, output 00:00:07, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     4592 packets output, 121746 bytes, 0 underruns
     0 output errors, 0 collisions, 1471 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up


Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            x.x.x.1     YES NVRAM  up                    down
Serial0/0                  a.b.c.250   YES NVRAM  down                  down
FastEthernet0/1            unassigned      YES NVRAM  administratively down down
Serial0/1                  d.e.f.10   YES NVRAM  up                    down
0
 
LVL 3

Assisted Solution

by:MaxQ
MaxQ earned 500 total points
ID: 13676679
You don't yet have the service-module configuration that handles the T1 signaling configured.  It's hard to know exactly what commands for you to use without knowing how your external CSU/DSU was configured, but I'd guess something like:

(in config mode)
interface Serial0/0                                       ! or whichever interface the T1 cable is coming into
service-module t1 framing esf                      
service-module t1 linecode b8zs
service-module t1 timeslots 1-24 speed 64

To verify the status of the T1 CSU/DSU do:

(in exec mode)
show service-module int Serial0/0               ! again, or whichever interface you're dealing with

More detailed instructions are on Cisco's site:
http://www.cisco.com/en/US/products/sw/iosswrel/ps5012/products_feature_guide09186a0080194a32.html#wp1025039

If you still can't get it working try posting the output from the 'show service-module' command, as that
might give us some clues.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 13676705
Max,
All of those commands are the default configuration and will not show up in "show config"

Since all of the interfaces are "down" we can't do any real troubleshooting until the new T1 is plugged in and the ISP turns it up..
0
 

Author Comment

by:mrbling
ID: 13681771
After scratching my head all day yesterday and planning an outage, it finally came down to the route table. Turns out even though I specifed the route "ip route 0.0.0.0 0.0.0.0 x.x.x.249" and even restarted the router, it did not show up in the route table when I did a "show ip route". I ended up removing the route and re-entering the command, wouldn't you know it came up beautifully! I configured CEF per-packet load balancing with my ISP succesfully this morning based on other posts you both replied to on this site. I am going to split the points for your quick replys if thats ok. Thanks!
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 13681889
Good work! Glad you're working...
- Cheers!
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question