Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1470
  • Last Modified:

vnc with SuSE and Red Hat

I have a linux cluster that was orgininally setup with Red Hat 7.3  I use VNC to log into the cluster from my Win2000 PC.  This has worked great.  I was able to start VNC sessions on two different computer, both hooked to external network, at the same time without any problems.  My /home/.vnc/xstartup files contains this.

~/.vnc> more xstartup
#!/bin/sh

[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
#twm &
/etc/X11/xdm/Xsession kde &

I have a common home directory that all computers see.

I recently changed one of the computers to SuSE 9.0 Professional because we have Opteron chips and are wanting to go to 64 bit.  Now when I try to use VNC on the SuSE 9.0 I get the kde interface to come up with a yellow active text window, but get errors and cannot execute any programs. I have jpg files of the errors that I can e-mail.  They basically say "The aplication Konqueror crashed and caused the signal 11 (SIGSEGV)  I have installed Real VNC vnc-4.0-1.i386.rpm which uninstalled the tightvnc from the SuSE install.  As I said before I have a common home directory that is using the above xstartup file.

What do I need to change so that I can run vnc on both Red Hat 7.3 and SuSE 9.0
0
psimms1
Asked:
psimms1
  • 2
  • 2
1 Solution
 
pdub79Commented:
Have you tried gnome desktop?

Change
/etc/X11/xdm/Xsession kde &
to
gnome-session &
0
 
wesly_chenCommented:
> /etc/X11/xdm/Xsession kde &
In xtartup, change to
startkde &  # for KDE, "gnome-session &" is for Gnome

Wesly
   
0
 
psimms1Author Commented:
I apollogize for not responding sooner.  I have been working on another project.

I tried both suggestions.  the gnome on the computer with SuSE 9.0 still had just the yellow terminal screen.  I switched back to kde and noticed that I get an error of

KDEInit could not lauch '/usr/bin/autorun'

This file does not exist on the SuSE 9.0 computer in this location but is on the RedHat 7.3 computer.  Can I just copy this file over?  Should had it been installed with the SuSE installation?
0
 
wesly_chenCommented:
> the gnome on the computer with SuSE 9.0 still had just the yellow terminal screen.
Make sure your can login in front of monitor with Gnome. Otherwise, you need to install Gnome on SuSE 9.0.

> KDEInit could not lauch '/usr/bin/autorun'
Your home directory have previous KDE setting for Redhat.
mv ~/.kde ~/.kde_rh
and relogin again.
Do not copy over the /usr/bin/autorun.
0
 
psimms1Author Commented:
I was able to get past the error about /usr/bin/autorun.  I still get errors abour The application Konqueror crashed and caused the signal 11 (SIGSEGV).

I tried to change the default interface to gnome through YAST, exited and logged in again.  It still came up in KDE.  

Is it a problem with running kde 3 on redhat 7 and kde 3.1 on the suse 9.0 with a common home directory on the redhat machine.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now