?
Solved

vnc with SuSE and Red Hat

Posted on 2005-03-31
5
Medium Priority
?
1,465 Views
Last Modified: 2013-12-15
I have a linux cluster that was orgininally setup with Red Hat 7.3  I use VNC to log into the cluster from my Win2000 PC.  This has worked great.  I was able to start VNC sessions on two different computer, both hooked to external network, at the same time without any problems.  My /home/.vnc/xstartup files contains this.

~/.vnc> more xstartup
#!/bin/sh

[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
#twm &
/etc/X11/xdm/Xsession kde &

I have a common home directory that all computers see.

I recently changed one of the computers to SuSE 9.0 Professional because we have Opteron chips and are wanting to go to 64 bit.  Now when I try to use VNC on the SuSE 9.0 I get the kde interface to come up with a yellow active text window, but get errors and cannot execute any programs. I have jpg files of the errors that I can e-mail.  They basically say "The aplication Konqueror crashed and caused the signal 11 (SIGSEGV)  I have installed Real VNC vnc-4.0-1.i386.rpm which uninstalled the tightvnc from the SuSE install.  As I said before I have a common home directory that is using the above xstartup file.

What do I need to change so that I can run vnc on both Red Hat 7.3 and SuSE 9.0
0
Comment
Question by:psimms1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 3

Expert Comment

by:pdub79
ID: 13678633
Have you tried gnome desktop?

Change
/etc/X11/xdm/Xsession kde &
to
gnome-session &
0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 13690884
> /etc/X11/xdm/Xsession kde &
In xtartup, change to
startkde &  # for KDE, "gnome-session &" is for Gnome

Wesly
   
0
 

Author Comment

by:psimms1
ID: 13765894
I apollogize for not responding sooner.  I have been working on another project.

I tried both suggestions.  the gnome on the computer with SuSE 9.0 still had just the yellow terminal screen.  I switched back to kde and noticed that I get an error of

KDEInit could not lauch '/usr/bin/autorun'

This file does not exist on the SuSE 9.0 computer in this location but is on the RedHat 7.3 computer.  Can I just copy this file over?  Should had it been installed with the SuSE installation?
0
 
LVL 38

Accepted Solution

by:
wesly_chen earned 750 total points
ID: 13765987
> the gnome on the computer with SuSE 9.0 still had just the yellow terminal screen.
Make sure your can login in front of monitor with Gnome. Otherwise, you need to install Gnome on SuSE 9.0.

> KDEInit could not lauch '/usr/bin/autorun'
Your home directory have previous KDE setting for Redhat.
mv ~/.kde ~/.kde_rh
and relogin again.
Do not copy over the /usr/bin/autorun.
0
 

Author Comment

by:psimms1
ID: 13775807
I was able to get past the error about /usr/bin/autorun.  I still get errors abour The application Konqueror crashed and caused the signal 11 (SIGSEGV).

I tried to change the default interface to gnome through YAST, exited and logged in again.  It still came up in KDE.  

Is it a problem with running kde 3 on redhat 7 and kde 3.1 on the suse 9.0 with a common home directory on the redhat machine.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How many times have you wanted to quickly do the same thing to a list but found yourself typing it again and again? I first figured out a small time saver with the up arrow to recall the last command but that can only get you so far if you have a bi…
It’s 2016. Password authentication should be dead — or at least close to dying. But, unfortunately, it has not traversed Quagga stage yet. Using password authentication is like laundering hotel guest linens with a washboard — it’s Passé.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses
Course of the Month14 days, 9 hours left to enroll

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question