?
Solved

XP Open With - Need to Add an Application to the Options

Posted on 2005-04-03
6
Medium Priority
?
184 Views
Last Modified: 2012-06-21
Windows XP Pro SP2

When I attempt to open a .php file by right clicking, there is an option to "Edit with Dreamweaver."  But when I select it, I am shown the "Open With" dialog box in which Dreamweaver (DW) is not present.  When I try to associate the .php file with DW using the Folder Options -> File Types, I am only allowed to open the one instance.  It does not set the permanent option, "Always open this type of file using this application."

Is there a registry tweak I can use for this?  Thanks.
0
Comment
Question by:WizeOwl
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
6 Comments
 
LVL 59

Expert Comment

by:LeeTutor
ID: 13697313
Sounds like perhaps your "Open with" registry settings may be corrupted.  This page has a table of registry files and Visual Basic Script programs that you can download and run by double-clicking:

http://www.kellys-korner-xp.com/xp_tweaks.htm

row 220, lefthand side:  Restore Open With on the Right Click
0
 

Author Comment

by:WizeOwl
ID: 13755047
Thank you Lee for the suggestion, however I checked my entries with those at Kelly's Korner and mine are the same.  Any other ideas what may need to be done?
0
 
LVL 59

Expert Comment

by:LeeTutor
ID: 13755141
Well, this free program may be of some use.  Go to the page, download it, and see if it will be helpful.  Read the entire page, it has a lot of info on using it:

http://www.nirsoft.net/utils/shexview.html
ShellExView v1.10 - Shell Extensions Manager
Copyright (c) 2003 - 2004 Nir Sofer  

Description
Shell Extensions are in-process COM objects which extends the abilities of Windows operating system. Most shell extensions are automatically installed by the operating system, but there are also many other applications that install additional shell extension components. For example: If you install WinZip on your computer, you'll see a special WinZip menu when you right-click on a Zip file. This menu is created by adding a shell extension to the system.
The ShellExView utility displays the details of shell extensions installed on your computer, and allows you to easily disable and enable each shell extension.

ShellExView can be used for solving context-menu problems in Explorer environment.
0
Back Up Your Microsoft Windows Server®

Back up all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 

Author Comment

by:WizeOwl
ID: 13808912
When I launch ShellExView, I do not see Dreamweaver or Macromedia in the list.   Are there any other Registry entries I may want to look at?


Just for the record, here are the registry entries suggested by Kelly's Korner

220.  Restore Open With on the Right Click
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shellex\ContextMenuHandlers\Open With]
@="{09799AFB-AD67-11d1-ABCD-00C04FC30936}"

[HKEY_CLASSES_ROOT\*\shellex\ContextMenuHandlers\Open With EncryptionMenu]
@="{A470F8CF-A1E8-4f65-8335-227475AA5C46}"
0
 
LVL 59

Accepted Solution

by:
LeeTutor earned 1200 total points
ID: 13811169
I just looked at a computer that had an old copy of Dreamweaver 4 on it.  There were no .php files I could test with.  But when I right clicked on an .htm file, I got the option to "Edit with Dreamweaver", so I took a look at the registry for the entry for this key:

HKEY_CLASSES_ROOT\htmlfile

and I saw that there was an entry like the following .reg file which I exported and then copied into Notepad:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\htmlfile\shell\Edit with Dreamweaver]

[HKEY_CLASSES_ROOT\htmlfile\shell\Edit with Dreamweaver\Command]
@="\"C:\\Program Files\\Macromedia\\Dreamweaver 4\\Dreamweaver.exe\" %1"

What I suggest you do is take a look at the registry on your computer for a type of file for which the "Edit with Dreamweaver" works, and then see if this item is somehow different from the entry for .php, and if so, then try adding similar subkeys.
0
 

Author Comment

by:WizeOwl
ID: 13907264
I re-installed on a new computer and the shell extension works fine.  I could probably have tried re-installing on the orig. computer to have solved the problem.  But your idea makes sense as far as debugging.  Didn't actually try it but the points are yours.  Thanks for the input.
0

Featured Post

U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Can I legally transfer my OEM version of Windows to another PC?  (AKA - Can I put a new systemboard in my OEM PC?) Few of us are both IT and legal experts but we all have our own views of Microsoft's licensing rules and how they apply.  There are…
If you have done a reformat of your hard drive and proceeded to do a successful Windows XP installation, you may notice that a choice between two operating systems when you start up the machine. Here is how to get rid of this: Click Start Clic…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
How to fix incompatible JVM issue while installing Eclipse While installing Eclipse in windows, got one error like above and unable to proceed with the installation. This video describes how to successfully install Eclipse. How to solve incompa…
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question