Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3674
  • Last Modified:

Can't support 200GB Harddisk in Windows 2000 server.

I buy a new 200GB Harddisk for my company Windows 2000 server. It only support maximum 128 GB partition. How can i enable this?
0
kennycpu
Asked:
kennycpu
1 Solution
 
davidis99Commented:
First, you need to find out whether the motherboard in your server supports hard drives of that size - if you're using an ATA hard drive (which would explain the 200GB capacity) your server probably has a IDE controller that only supports the ATA5 standard, which would limit you to the 128GB size you mentioned.  Adding a new controller card that supports ATA6 drives with 48-bit addressing (part of the ATA6 standard) would allow the hardware to recognize the full size of the drive.  To make sure Windows can read the drive once the hardware can recognize it, the server should be running Windows 2000 Service Pack 4.

http://support.microsoft.com/kb/305098/EN-US/
0
 
herbusCommented:
Another likely possibility,.. Windows 2000 can't format the entire drive due to limitations in the OS... If you format the drive with Windows XP then it allows for larger disk support and you can then use the drive in a 2000 machine with no problems,.. it's just the initial format you'll want XP to do
0
 
herbusCommented:
For the sake of being thorough, I posted the comment above because I bought a 200GB drive a while back and could only get 128 out of it when formatting with Win2000 SP4... sounds like the exact same problem
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
WatzmanCommented:

In order to use more than 137 gigs (that's "decimal" gigs -- it's 128 "binary" gigs), you need to have "48-bit lba".

This involves everything -- hardware, software, firmware, motherboard.

The first thing to do is to go to the web site of the system or motherboard mfgr. and find out if the hardware supports 48-bit LBA.  There are basically 3 possibilites:  Supported, not supported, or supported only after you update the BIOS.  In fact, in almost any case, I would update to the latest BIOS available if you have not already done so.

The next thing, for you, involves the operating system, Windows 2000.  In order to support 48-bit lba on Windows 2000, I beleive that you must have Service Pack 4 installed, and also that you need to make a registry entry manually.  You can find infromation on this at the Microsoft web site, do a search on "48-bit LBA".

If you pass all of these hurdles, then it should work.

Another option here is to use an external USB case for the drive, being sure that the case supports 48-bit LBA (almost all of the USB 2.0 cases do, and you need USB 2.0 for a hard drive, as USB 1.x is too slow).  The 137 gig limit is in the physical IDE interface and driver software, there is no general 137 gig drive limit in Windows (e.g. Widows supports dirves larger than 137 gigs if they are SCSI, Raid, USB .... almost any type of connection other than IDE.  Even IDE ports on a PCI add-in card are supported, because as far as Windows is concerned, drive on an add-in PCI card are treated as SCSI, not IDE).

[By the way, a PCI add-in card is another solution .... just be sure to get a recent card that supports 48-bit LBA itself.]

Herbus ... did you update the BIOS and make the manual registry entry when you tried to use the 200 gig drive with Win2K SP4?  Because Win2K SP4 can support 48-bit LBA, but it's not automatic, you still have to do all of the steps to meet all of the other requirements.
0
 
herbusCommented:
In my case the BIOS recognised it for what it was but Windows wouldn't... I didn't go looking for a fix to apply to Win2k because it was a good excuse to upgrade to XP at the time, so wasn't aware there was one, though if there's a registry fix then that'll be great for kennycpu here because he's hardly gonna put XP on his server... good work folks
0
 
kdkirmseCommented:
On windows 2000 there is a registry entry called EnableLargeLba that needs to be set to support large hard drives.

See the following knowledge base entry

http://support.microsoft.com/?kbid=305098
0
 
WatzmanCommented:

Actually, the registry fix is needed for XP SP1 as well.  It's a bit ambiguous to me as to whether or not the registry fix is needed for XP SP2.
0
 
crazijoeCommented:
The registry fix is not needed for XP SP2.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now