?
Solved

Odd relaying error 5.7.1 we do not relay

Posted on 2005-04-04
13
Medium Priority
?
930 Views
Last Modified: 2008-01-09
I have an odd relaying issue on SBS 2003 exchange server.  We get an intermittent error when sending mail.  Users will get an email back almost instantly from our server admin account saying this:

            You do not have permission to send to this recipient.  For assistance, contact your system administrator.
            <hoosiertradewinds.com #5.7.1 smtp;551 5.7.1 we do not relay>

If they double click the message and choose send again, it goes through just fine.  I have my exchange server setup to allow relaying for my domain and for authenticated users regardless of restrictions.

I do have 1 domain that I have been able to reproduce this error with.  For some reason, all emails to this particular domain are rejected with this error the first time.  I am unsure what the problem is.  

Thoughts?
0
Comment
Question by:benbecker
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 5
13 Comments
 
LVL 4

Expert Comment

by:o0JoeCool0o
ID: 13698929
Are you hosting your own DNS?
0
 
LVL 1

Author Comment

by:benbecker
ID: 13698977
Sort of, I do have a DNS record for my local domain, but other than that my MX records and what not are hosted at my registrar.  
0
 
LVL 4

Expert Comment

by:o0JoeCool0o
ID: 13699186
On exchange server under SMTP Virtual Server properties, click the Delivery tab then click advanced then click *Configure* is there anything set in there?
0
Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 
LVL 1

Author Comment

by:benbecker
ID: 13699212
No, there is nothing there for external DNS.
0
 
LVL 4

Accepted Solution

by:
o0JoeCool0o earned 2000 total points
ID: 13699238
You need to put your ISP's DNS servers in there, I had a wierd similar issue and adding the external DNS resolved more then one issue.
Also you MUST reboot for this change to take effect
0
 
LVL 1

Author Comment

by:benbecker
ID: 13699260
Will this cause any oddities with mail routing to the internal domain / local domain by doing this..e.g. will it try to use the external DNS to resolve things that should be resolved by the local DNS?
0
 
LVL 4

Expert Comment

by:o0JoeCool0o
ID: 13699489
No it will not, It is for External Name resolution, if it cant find the domain internally first it will try the external DNS
0
 
LVL 4

Expert Comment

by:o0JoeCool0o
ID: 13699755
your not also trying to use pop3 or anything that may interfere?

0
 
LVL 1

Author Comment

by:benbecker
ID: 13700315
I will try the external DNS suggestion tonight, can't reboot server till then.  I do have POP3 open for people to be able to access email that way, but I'm the only one that leverages that on my treo. I'm unsure how that would interferre though.  I used to use the POP3 connector, but do not anymore.
0
 
LVL 4

Expert Comment

by:o0JoeCool0o
ID: 13701044
I think this is where your problem is, you should set up 2 SMTP servers.
add a new Virtual SMTP server for Outgoing POP3 email. and disable open relay  also disable Anonymous access and use Integrated windows authenticatoin basic
On the main SMTP Virtual server you must ALLOW anonymous access so that your Exchange Box can deliver mail to other Mail servers.
but you do NOT want anonymous access on the POP3 server.
you ALSO have to change the port cause you cannot have 2 SMTP servers running on the same port 25, I used 25 for my mail delivery and 2525 for POP3 Virtual Server

0
 
LVL 4

Expert Comment

by:o0JoeCool0o
ID: 13701126
you should still put in your external DNS servers tho regardless if the 2 smtp servers fixes the issue.
0
 
LVL 1

Author Comment

by:benbecker
ID: 13701144
I'm a little fuzzy on the purpose behind the two SMTP servers.  
0
 
LVL 4

Expert Comment

by:o0JoeCool0o
ID: 13701337
The reason you want 2 is because one is for the  transport of mail from one server to another wich requires Anonymous authentication
The second mail server(POP3) is allowed to  Relay for authenticated users. NOT anonymous. You will see the relay check mark says "Allow relaying to authenticated users"  this will be disabled on the main SMTP server but enabled on the POP3 server, however it will still be secure because Anonymous Authentication is disabled on the pop3 server, so essentially you are only allowing relayed mail to go through the pop3 server.

if u still dont understand I will find some tutorials for u

0

Featured Post

Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Read this checklist to learn more about the 15 things you should never include in an email signature.
Unified and professional email signatures help maintain a consistent company brand image to the outside world. This article shows how to create an email signature in Exchange Server 2010 using a transport rule and how to overcome native limitations …
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
This video discusses moving either the default database or any database to a new volume.
Suggested Courses

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question