Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2741
  • Last Modified:

Cant connect to Remote Desktop

I am having trouble connecting to a Windows 2003 Server.
I have enabled remote admin on the server and added the necessary groups/users as remote operators.
I have set RRAS to automatic and started the service but still can't connection.
When I try to connect to the server I get

"Remote Desktop Disconnected
The client could not connect to the remote computer.
Remote connectioned might not be enabled or the computer might be too busy to accept new connections.
It is also possible that network connections are preventing your connection."

I have tried from another workstation and I get the same result. The network should be working OK as I can get a VNC connection to the server no problem.
0
Caltor
Asked:
Caltor
  • 7
  • 2
  • 2
  • +3
1 Solution
 
ScrptMastaCommented:
You probably need to open Port 3389 on your Firewall.
0
 
CaltorAuthor Commented:
No firewall between workstation and server. It is on local LAN subnet.
0
 
RimscorpCommented:
Do you have internet cut outs on that maching , It may be hardware related. But if it isnt

www.VNC.com offers a free very easy to use virtual networking too wich has realtime control of the client PC

really cool


                           -J-Rim
0
Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

 
ScrptMastaCommented:
When you right-click on My Computer - Properties - Remote Tab is the group you want to have access listed in the "Select Remote User" button?
0
 
TannerManCommented:
You do not need RRAS for this capability. In fact, if that is the only reason you have RRAS on there, it could even be causing your problem if this is a mutihoned machine (more than one network card). With RRAS service off can you connect given ScrptMAsta's question is answered as YES
0
 
CaltorAuthor Commented:
"Do you have internet cut outs on that maching , It may be hardware related. But if it isnt www.VNC.com offers a free very easy to use virtual networking"
No internet problems as far as I am aware. I am aware of VNC as I stated in my original post but I want to get RDP working as I need to perform some testing.

"When you right-click on My Computer - Properties - Remote Tab is the group you want to have access listed in the "Select Remote User" button?"
Yes.

"You do not need RRAS for this capability"
I was following one of the recommendations at
http://www.experts-exchange.com/Operating_Systems/Windows_Server_2003/Q_21104694.html
Even with RRAS set to manual and stopped I get the same problem.
Coming back to the firewall suggestion could it be the built-in firewall within 2003? I am used to ISA so I don't usually get involved on the built-in firewall. How can I configure the server to allow connections from port 3389. I was under the impression that RRAS had to be running for the firewall to work/be configured anyway.
0
 
CaltorAuthor Commented:
BTW The 2003 server has 2 NIC's for legacy reasons but the other one is not connected and is disabled.
0
 
CaltorAuthor Commented:
I don't think it is a firewall problem any longer. I have run netstat -a -n on the server and nothing appears to be listening on port 3389.
The system event log shows event id 1014 from TermService with the message
Cannot load illegal module c:\windows\system32\drivers\rdpwd.sys
0
 
CaltorAuthor Commented:
I went to follow the advice in http://support.microsoft.com/default.aspx?scid=kb;en-us;312030 as that is very close to my problem but I am completely missing the Cryptography key in HKEY_USERS\.DEFAULT\Software\Microsoft
0
 
vinilCommented:
"Cryptographic Services" services must be enabled and running.

HTH,
Vinil
0
 
vinilCommented:
i missed "Terminal Services" service in the prev. post
Rgds,
Vinil
0
 
CaltorAuthor Commented:
Cryptographic Services is started.
Terminal Services is started but options to start, stop or restart are all greyed out.
0
 
CaltorAuthor Commented:
I have now solved this problem myself.
The only cryptography key I found had the subkey Autoenrollment.
However I have replaced c:\windows\system32\drivers\rdpwd.sys with a copy from a working windows 2003 server. Reset the TCP-RDP session and it now works perfectly.
Many thanks for your input.
0
 
intermediagroupCommented:
FYI if issue still persists uninstall: KB2653956,

http://support.microsoft.com/kb/2653956
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 7
  • 2
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now