?
Solved

Cisco 801 ISDN configuration

Posted on 2005-04-04
7
Medium Priority
?
587 Views
Last Modified: 2008-02-01
Hello all,

I have a Cisco 801 router with this configuration.

version 12.3            
no service pad              
service timestamps debug datetime msec                                      
service timestamps log datetim                            
service password-encryption                          
!
hostname NETLINKR                
!
boot-start-marker                
boot-end-marker              
!
enable secret 5 $1$t9Y/$bw0oeL6nDrxX5dJnw6c6E.                                              
!
username NETLINKR password 7 0525233B0D65602229242421                                                    
no aaa new-model                
ip subnet-zero              
no ip source-route                  
!
isdn switch-type basic-net3                          
!
!
!
interface Ethernet0                  
 ip address 192.168.0.111 255.255.255.0                                      
 ip access-group 121 in                      
 no ip proxy-arp                
 ip nat inside              
!
interface BRI0              
 no ip address              
 encapsulation ppp                  
 dialer pool-member 1                    
 isdn switch-type basic-net3                            
 ppp authentication chap pap call                              
 ppp multilink              
!
interface Dialer1                
 description ISP                
 ip address negotiated                      
 ip access-group 121 in                      
 no ip proxy-arp                
 ip nat outside              
 encapsulation ppp                  
 no ip split-horizon                    
 dialer pool 1              
 dialer remote-name Cisco1                          
 dialer idle-timeout 300                        
 dialer string 8962548888                        
 dialer hold-queue 10                    
 dialer load-threshold 10 either                                
 dialer-group 1              
 ppp authentication chap pap callin                                  
 ppp chap hostname CKANELLAKIS.ATH.FORTHNET.GR                                              
 ppp chap password 7 124D5044405A4048                                    
 ppp pap sent-username CKANELLAKIS.ATH.FORTHNET.GR password 7 075                                                                
 ppp multilink              
!
ip nat inside source list 18 interface Dialer1 overload                                                      
ip classless            
ip route 0.0.0.0 0.0.0.0 Dialer1                                
ip http server              
!
!
map-class dialer DialClass                          
access-list 18 permit 192.168.1.0 0.0.0.255                                          
access-list 18 permit 192.168.0.0 0.0.0.255                                          
access-list 121 deny   udp any eq netbios-dgm any                                                
access-list 121 deny   udp any eq netbios-ns any                                                
access-list 121 deny   udp any eq netbios-ss any                                                
access-list 121 deny   tcp any eq 137 any                                        
access-list 121 deny   tcp any eq 138 any                                        
access-list 121 deny   tcp any eq 1                                  
access-list 121 permit ip any any time-range TIME                                                
dialer-list 1 protocol ip permit                                
!
line con 0          
 exec-timeout 120 0                  
 transport preferred all                        
 transport output all                    
 stopbits 1          
line vty 0 4            
 exec-timeout 0 0                
 login local            
 transport preferred all                        
 transport input all                    
 transport output all                    
!
no rcapi server              
!
!
time-range TIME              
 periodic daily 0:00 to 23:59                            
!
!
end  



well with this configuration I cann't connect to Internet...
Is it something missing, that I don't see it ?
0
Comment
Question by:vmaragos
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
7 Comments
 
LVL 19

Expert Comment

by:nodisco
ID: 13705242
This config looks like it was created from Configmaker with possibly some changes afterwards - are you sure of your isdn switch-type?
run the following troubleshooting commands and post the results:

sh int dialer1
sh int bri0

i posted you a link for a simple config file with necessary changes in the next thread you posted.


0
 

Author Comment

by:vmaragos
ID: 13737171
NETLINKR#sh int dialer1
Dialer1 is up (spoofing), line protocol is up (spoofing)
  Hardware is Unknown
  Description: ISP
  Internet address will be negotiated using IPCP
  MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, loopback not set
  DTR is pulsed for 1 seconds on reset
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 00:03:50
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 42 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes
     0 packets output, 0 bytes


NETLINKR#sh int bri0
BRI0 is up, line protocol is up (spoofing)
  Hardware is BRI with S/T interface
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, loopback not set
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 00:05:18
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 48 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions


These are the result from the test...
0
 
LVL 19

Expert Comment

by:nodisco
ID: 13737881
Is the router dialling out when you try to ping an outside address?

Go to the prompt and turn on debugging for negotiation and authentication

debug ppp negotiation
debug ppp authentication

ping X.X.X.X   ( ip address of internet server e.g. 159.134.237.6)

Post the output of this debug - it will help isolate where the problem is occurring.

0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 

Author Comment

by:vmaragos
ID: 13738128
How I will see if the router is dialing ?
0
 

Author Comment

by:vmaragos
ID: 13738904
Well these are the latest...

The router can connect to the net when I send from command line a ping to an external IP.

From this moment every external IP I check responses.

Here is what the console shows when making ping to 194.219.227.2
NETLINKR#ping 194.219.227.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 194.219.227.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/37/40 ms


The problem is that the IE cannot open pages and also the email and other programs as DC++ from example cannot find Internet.

Should I remove the access-list?  Is it a possible problem?
How can I remove it?
0
 
LVL 19

Expert Comment

by:nodisco
ID: 13751140
Don't take this the wrong way but I don't know your skillset so a couple of basics.  
Is your default gateway on your pc set to 192.168.0.111?  
Can you ping this address from the pc?
If you ping 194.219.227.2 from the PC, what happens?
What is listed in LAN setting in the internet options of Internet Explorer for your connection?
If you can ping the gateway, ping 194.219.227.2 but cannot browse websites then you have a DNS problem - what are your DNS server addresses?  Are you being assigned them?

If you are happy that all of the above is ok, try removing the line
ip nat inside source list 18 interface Dialer1 overload                                                      


You can also confirm your connection to the internet is up by using the command

show isdn status

This will tell you if you have established a link at layer 2 and if your call is active.

0
 
LVL 19

Accepted Solution

by:
nodisco earned 2000 total points
ID: 13789454
Have you had success with this or the previous config I posted to your other question?
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question