• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 487
  • Last Modified:

[warn] Apache php 5

Dear Experts,
I have this web server installed (copied from php.ini):
Apache/1.3.33 (Win32) PHP/5.0.3 mod_ssl/2.8.22 OpenSSL/0.9.7e
#Win32 is win-XP professional

When restarting the apache service I get this two warnings in the apache log:

[warn] Loaded DSO c:/php/php5apache.dll uses plain Apache 1.3 API, this module might crash under EAPI! (please recompile it with -DEAPI)
[warn] module mod_php5.c is already added, skipping

my httpd.conf file has these lines added to it:
-------------------------------------------------------------
LoadModule php5_module "c:/php/php5apache.dll"
AddModule mod_php5.c
AddType application/x-httpd-php .php
AddType application/x-httpd-php .wml
-------------------------------------------------------------
As far as I can see, my web site functions normally (wap included).
Should I worry about this?
How do I go on solving this?

Thank you.
0
eyal_barouk
Asked:
eyal_barouk
  • 4
  • 3
1 Solution
 
eyal_baroukAuthor Commented:
OK, I got rid of the second warning by removing:
AddModule mod_php5.c
from the httpd.conf file.

I am still concerned with the other warning.
0
 
kryptic0329Commented:
This is simply a problem of an old module. You just need to download a new verison of the php apache module. Make sure you get the one for apache2.
0
 
eyal_baroukAuthor Commented:
But I am using Apache 1.3.33
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
kryptic0329Commented:
I would suggest upgrading to Apache 2.0+. Its fully stable and supported now.
0
 
kryptic0329Commented:
Also eyal_barouk, if you wish to use Apache 1.3, you need to recompile it without EAPI. Just add the -DEAPI switch to your compile string.
0
 
eyal_baroukAuthor Commented:
I would upgrade to apache 2.0 but my problem is that I cannot install SSL on it as I did with 1.3.
With 1.3 I found an apache installation with SSL already configured on it. But as I understand, it doesn't exist for apache 2.0 for some legal reason.

I don't want to deal with compiling it for lack of tools and knowledge to do it.

I'm pretty confused by the subject right now and have to give it more thought.
Any more suggestions maybe? Does any site owner that want to have SSL installed on apache 2.0 have to compile it herself? Sounds pretty strange.
0
 
kryptic0329Commented:
Well most of the time any serious webmaster doesn't use apache on windows. :)

Linux compiles much easier and its quite easy to add it. I would purchasing a dedicated server from somewhere like 1and1.com for $5 a month if your site gets any traffic and needs SSL. They will give you a licensed SSL certification from a real certifying authority. Also you won't have to deal with any of this compiling and your site will be extremely fast. I've got a dedicated server there and I love it.
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now