?
Solved

Compiling BZIP2 in 64-bit mode

Posted on 2005-04-05
6
Medium Priority
?
479 Views
Last Modified: 2013-11-17

I've recently installed a P570 running AIX 5.3, installed the gcc compiler for AIX 5.2 from a link provided by gcc.gnu.org, and loaded the BZIP2 source from RedHat.

Try as I might, I can not get the BZIP2 object to run in 64-bit mode.  That is, fopen() calls the underlying 32-bit functions instead of the 64-bit ones.

Can anyone point me to generating a 64-bit object?

Thanks,
Kent
0
Comment
Question by:Kent Olsen
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 62

Expert Comment

by:gheist
ID: 13832707
try bullfreeware build if rpm from IBM's linux toolkit does not work
0
 
LVL 46

Author Comment

by:Kent Olsen
ID: 14368156

Hi Venabili,

I've got no problems with giving the points to gheist for a good suggestion.

The implemented solution was to simply install IBM's licensed C compiler.


Kent
0
 
LVL 20

Expert Comment

by:Venabili
ID: 14368445
KEnt,

IF the installation had helped you, then the recomemdnation should be a PAQ-refund

Just a note:  I was really surprised to see abandoned question from one of the top experts - and not just abandoned but with ignord suggestion... Please answer to the experts around - you are an expert, you know what is the feeling when you propose something and it seems like noone cares :)

Venabili
0
 
LVL 46

Author Comment

by:Kent Olsen
ID: 14369782

My apologies.  (They are certainly in order!)

When I first tried to build the 64-bit application I hadn't installed the IBM C compiler as there was a licensing issue.  So I downloaded gcc and tried with that, to no avail.

Shortly thereafter "management" decided that the entire server needed rebuilding.  I abandoned the then-current effort and let the installation overwrite my doctored-up efforts.  As part of the reinstall, the IBM compiler was loaded.

As far as this question is concerned, I let it devolved into "out of sight, out of mind".

Again, I apologize to the other experts.
Kent
0
 

Accepted Solution

by:
modulo earned 0 total points
ID: 14395419
PAQed with points refunded (200)

modulo
Community Support Moderator
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hello fellow BSD lovers, I've created a patch process for patching openjdk6 for BSD (FreeBSD specifically), although I tried to keep all BSD versions in mind when creating my patch. Welcome to OpenJDK6 on BSD First let me start with a little …
FreeBSD on EC2 FreeBSD (https://www.freebsd.org) is a robust Unix-like operating system that has been around for many years. FreeBSD is available on Amazon EC2 through Amazon Machine Images (AMIs) provided by FreeBSD developer and security office…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
In a previous video, we went over how to export a DynamoDB table into Amazon S3.  In this video, we show how to load the export from S3 into a DynamoDB table.
Suggested Courses
Course of the Month13 days, 16 hours left to enroll

800 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question