printing to a local HP Laserjet 5

Posted on 2005-04-05
Last Modified: 2013-12-09
I have a HP laser jet 5, non postscript.  Historically, it has worked well enough attached to a linux print server running samba.  Now  I have a long parallel printer cabel and I am attaching it directly to my main workstation, which is openbsd 3.6.  The printer can self-test and print its test page, the hardware test page.  I have it hooked up to the parallel port of the workstation.  I seem to have various places I can go to set up a printer.  There seems to be an option in kde, print management, and then there is the etc file printcap.  I have fussed with all this and cannot get the printer to respond.

I used to install ms window networks, with a proprietary application, and printing was always nasty.  A easy trick was to write a program to print directly to the lpt.  If that did not work, you had some problem other than configurating the operating system.  So I copied a txt file to /dev/lp and no luck.

Please advise.
Question by:astar666
    LVL 8

    Accepted Solution

    For HP Laserjet 5 non-postscript, you'll want to install the print/hpijs port as well as print/ghostscript.

    You can also install CUPS which makes it easy to setup your printer. Just install the PPD file from here in CUPS administrator:

    You might also want to read up on the various ways you can get printing to work on BSD (there's as usual more than one way) from these articles:


    Author Comment

    So installed apsfilter and ghostscript.  I did apfilter SETUP and got a test page to print.  I never discovered where CUPS was in the port tree.

    KDEprint tells me the printer is rejecting jobs.  From the command line, lpr some.txt tells me it cannot find connect, but is queuing.

    I might think this is permissions, but I tried lpr some.txt from root with the same result.

    Please advise.
    LVL 8

    Expert Comment

    What does your printcap entry look like?

    OpenBSD doesn't have CUPS in the ports tree. You'd have to install it from source.

    Try using foomatic from ports as well, foomatic/db-hpijs

    Have a look here for more info on foomatic.


    Author Comment


    Author Comment

    Hmm, from the foomatic doc, I was able to guess that it would be worthwhile trying to start lpd.  I did and the printqueue dumped to the printer.  This is promising.  

    Featured Post

    How to run any project with ease

    Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
    - Combine task lists, docs, spreadsheets, and chat in one
    - View and edit from mobile/offline
    - Cut down on emails

    Join & Write a Comment

    This tech tip describes how to install the Solaris Operating System from a tape backup that was created using the Solaris flash archive utility. I have used this procedure on the Solaris 8 and 9 OS, and it shoudl also work well on the Solaris 10 rel…
    Every server (virtual or physical) needs a console: and the console can be provided through hardware directly connected, software for remote connections, local connections, through a KVM, etc. This document explains the different types of consol…
    Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
    Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

    746 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    19 Experts available now in Live!

    Get 1:1 Help Now