?
Solved

Cisco 1721 Router works for only 10 Seconds

Posted on 2005-04-05
14
Medium Priority
?
293 Views
Last Modified: 2008-02-01
I have a Cisco 1721 Router with a T1 WIC. The router is connected to a Cisco PIX 515E. Previously, we were using the router provided by our ISP and everything was ok. Now we are swapping it out with the Cisco 1721 router. The router works for about ten seconds. The when I do a tracert command from a MS-DOS window I get "Destination host unreachable":

tracert 64.139.134.205

Tracing route to colo.traci.net [64.139.134.205]
over a maximum of 30 hops:

  1     *       <1 ms    <1 ms  65.23.7.193.nw.nuvox.net [65.23.7.193]
  2    36 ms    35 ms    35 ms  66.83.158.181.nw.nuvox.net [66.83.158.181]
  3    55 ms    56 ms    54 ms  so-0-2-0.ar2.mia1.gblx.net [64.215.248.205]
  4    55 ms   120 ms    65 ms  so-0-2-0.ar2.mia1.gblx.net [64.215.248.205]
  5     *     65.23.7.193.nw.nuvox.net [65.23.7.193]  reports: Destination host
unreachable.

When I try to ping I get:

Reply from 65.23.7.193: Destination host unreachable.
Reply from 65.23.7.193: Destination host unreachable.
Reply from 65.23.7.193: Destination host unreachable.
Reply from 65.23.7.193: Destination host unreachable.
Request timed out.

Here is my running config:
----------------------------------------------
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Cisco1721
!
no logging console
enable password 7 040813550C036D6D222C35
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
ip name-server 64.89.70.2
ip name-server 64.89.74.2
!
!
!
!
!
!
interface FastEthernet0
 description connected to EthernetLAN
 ip address 65.23.7.193 255.255.255.224
 speed auto
!
interface Serial0
 no ip address
 encapsulation frame-relay
 service-module t1 remote-alarm-enable
 frame-relay lmi-type ansi
!
interface Serial0.1 point-to-point
 description connected to Internet
 ip address 66.83.158.182 255.255.255.252
 frame-relay interface-dlci 16 IETF  
!
router rip
 version 2
 passive-interface Serial0.1
 network 65.0.0.0
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 66.83.158.181
ip http server

!
line con 0
 exec-timeout 0 0
 password 7 091F565A1A273631203934
 login
line aux 0
line vty 0 4
 password 7 091F565A1A273631203934
 login
!
no scheduler allocate
!
end
-------------------------------------------------------

What is wrong with the configuration? Thanks to all who reply.
0
Comment
Question by:sonnye2000
  • 8
  • 6
14 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 13713017
Can you post result of "show interface" on the 1721?

Did you have the same IP addresses before?

  2    36 ms    35 ms    35 ms  66.83.158.181.nw.nuvox.net [66.83.158.181] <== next hop should be you @.182
  3    55 ms    56 ms    54 ms  so-0-2-0.ar2.mia1.gblx.net [64.215.248.205] <== yet it bounces to Global crossing..

Looks like a ISP routing issue to me.. The ISP does not know to route 65.23.7.192 subnet to you at 66.83.158.182

Getting to your serial IP is no problem. I can traceroute to it, and I can also get to your LAN interface now:

 1  Addr:65.23.7.193, RTT: 123ms, TTL: 239
  2  Addr:65.23.7.193, RTT: 128ms, TTL: 239
  3  Addr:65.23.7.193, RTT: 126ms, TTL: 239
  4  Addr:65.23.7.193, RTT: 123ms, TTL: 239
  5  Addr:65.23.7.193, RTT: 140ms, TTL: 239

Looks to me like you should be working just fine..
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 13713032
Just noticed what you were doing a traceroute to. Still looks like it works

04/05/05 20:06:07 Fast traceroute 64.139.134.205
Trace 64.139.134.205 ...
 <edited for my security>

 6 157.130.72.225   23ms   22ms   18ms  TTL:  0  (500.POS3-1.GW3.ATL4.ALTER.NET ok)
 7 152.63.86.118    20ms   19ms   19ms  TTL:  0  (0.so-1-2-0.XL1.ATL4.ALTER.NET ok)
 8 152.63.85.185    21ms   21ms   20ms  TTL:  0  (0.so-2-0-0.XL1.ATL5.ALTER.NET ok)
 9 152.63.84.149    23ms   26ms   19ms  TTL:  0  (POS6-0.BR4.ATL5.ALTER.NET ok)
10 204.255.174.182  32ms   26ms   25ms  TTL:  0  (No rDNS)
11 144.232.12.149   23ms   26ms   27ms  TTL:  0  (sl-bb21-atl-15-0.sprintlink.net ok)
12 144.232.20.124   31ms   44ms   30ms  TTL:  0  (sl-bb20-orl-14-0.sprintlink.net ok)
13 144.232.2.226    33ms   33ms   35ms  TTL:  0  (sl-gw11-orl-0-0.sprintlink.net ok)
14 160.81.59.50     43ms   36ms   42ms  TTL:  0  (sl-ciberlynxinc-48-0-0.sprintlink.net ok)
15 216.242.114.23   43ms   52ms   37ms  TTL:  0  (No rDNS)
16 216.242.227.42   38ms   39ms   38ms  TTL:  0  (No rDNS)
17 64.139.134.205   41ms   53ms   40ms  TTL: 48  (colo.traci.net bogus rDNS: host not found [authoritative])
                                                     
                                                     
                                                     
                                                     
                                                     
                                                     
                                                     
                                                     
                                                     
                                                     
                                                     
                                                     

0
 

Author Comment

by:sonnye2000
ID: 13713309
lrmoore, I'm plugged back in to the router of the ISP which is probably the reason why you can reach 65.23.7.193. When doing tracert with the router of the ISP, the beginning hops are exactly the same that I get on the Cisco router before it says destination host unreachable.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 

Author Comment

by:sonnye2000
ID: 13722210
Here are the results of the show interface command

FastEthernet0 is up, line protocol is up
  Hardware is PQUICC_FEC, address is 000d.ed7b.7855 (bia 000d.ed7b.7855)
  Description: connected to EthernetLAN
  Internet address is 65.23.7.193/27
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:03, output 00:00:03, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     760 packets input, 81936 bytes
     Received 719 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     3141 packets output, 198328 bytes, 0 underruns
     2961 output errors, 0 collisions, 3 interface resets
     0 babbles, 0 late collision, 0 deferred
     2961 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Serial0 is up, line protocol is down
  Hardware is PQUICC with Fractional T1 CSU/DSU
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation FRAME-RELAY, loopback not set
  Keepalive set (10 sec)
  LMI enq sent  15, LMI stat recvd 0, LMI upd recvd 0, DTE LMI down
  LMI enq recvd 0, LMI stat sent  0, LMI upd sent  0
  LMI DLCI 0  LMI type is ANSI Annex D  frame relay DTE
  Broadcast queue 0/64, broadcasts sent/dropped 0/0, interface broadcasts 0
  Last input 00:01:55, output 00:00:02, output hang never
  Last clearing of "show interface" counters 08:30:35
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     420 packets input, 22544 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     1 input errors, 0 CRC, 1 frame, 0 overrun, 0 ignored, 0 abort
     386 packets output, 19789 bytes, 0 underruns
     0 output errors, 0 collisions, 3 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Serial0.1 is down, line protocol is down
  Hardware is PQUICC with Fractional T1 CSU/DSU
  Description: connected to Internet
  Internet address is 66.83.158.182/30
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation FRAME-RELAY
  Last clearing of "show interface" counters never
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 13722461
>Serial0.1 is down, line protocol is down
Is the T1 plugged in?

>FastEthernet0 is up, line protocol is up
Full-duplex, 100Mb/s, 100BaseTX/FX
==>   2961 lost carrier, 0 no carrier

Looks like physical connectivity issue between router port and switch port.
Is the switchport managed and manually set to 100/FUll, or is it 'auto' ?

0
 

Author Comment

by:sonnye2000
ID: 13723015
The T1 is plugged in. The ethernet interface of the router is plugged into our Cisco PIX. The Cisco PIX connects to a managed switch. I believe the switch is set to auto.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 13725628
If the T1 is plugged in and your interface is down, then you need to double check the DLCI assignment and the LMI type that your carrier specifies. Can you post result of "show frame-relay pvc"
Are you connecting with a crossover cable directly between the Ethenet port and the PIX?
Is the PIX interface set to 100/full or 'auto' ?
0
 

Author Comment

by:sonnye2000
ID: 13729487
I am connecting via crossover cable to the PIX. The interface is set to auto. I will plug in the router after business hours to do the show frame-relay pvc.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 13729520
Have you contacted your ISP to make sure they even have you "turned on" on the T1 ?
0
 

Author Comment

by:sonnye2000
ID: 13730511
I am not sure but aren't we turned on by the ISP already? Our ISP provided us with their own T1 router. It works. I take the same RJ48 T1 cable from their box and plug it into the WIC card of the Cisco router is what I've previously done. So isn't it safe to say our T1 is turned on by the ISP?
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 13730597
Yes, I confused myself there for a bit. The T1 should show as
   Serial0 is up, line protocol is down <== should be "up"

Typical causes of it being down:
 1. Telco has not enabled LMI -- should not be the case since it is currently working
 2. Incorrect LMI type in configuration. If telco specifies ANSI, then you are OK
 3. Wrong number of channels configured on fractional T1 service. Is it a full T1?
 4. Wrong DLCI identifier. Are you sure it is "16" ?
 5. Incorrect encapsulation type. You have IETF specified

Do you have access to the existing config of their router that is currently working?
Is it a Cisco box?

0
 
LVL 79

Accepted Solution

by:
lrmoore earned 2000 total points
ID: 13730607
After thinking about this a little more, the "works but only for 10 seconds" part may be a clue.

If you verify all the above, then try this:
  interface Serial 0/0
    no keepalive

0
 

Author Comment

by:sonnye2000
ID: 13732129
It worked. Why did

interface Serial 0/0
    no keepalive

make it work? Can you explain maybe?
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 13735173
Disabling keepalive disables LMI
It works for 10-15 seconds because it takes about 10-20 seconds to initialize the frame-relay circuit.
With keepalives enabled, the router is expecting LMI packets. Default keepalive is 10 seconds, but it waits until it misses 3 packets. It will work from the time it initializes, until it misses that 3rd packet. No LMI packets from the frame-relay switch, must be down, I'll shut down my interface.
There are some providers that don't use LMI at all. The problem is that if their switch goes down (your logical circuit), but your physical circuit stays up, there is no mechanism to tell the router. No interface event to trigger an SNMP alert to tell you that something is amiss for you to investigate. Very difficult to troubleshoot when your connection just stops working for no reason.
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

It happens many times that access list (ACL) have to be applied to outgoing router interface in order to limit some traffic.This article is about how to test ACL from the router which is not very intuitive for everyone. Below scenario shows simple s…
Problem Description:   Couple of months ago we upgraded the ADSL line at our branch office from Home to Business line. The purpose of transforming the service to have static public IP’s. We were in need for public IP’s to publish our web resour…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question