[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Mount Windows Ntfs to Linux

Posted on 2005-04-06
12
Medium Priority
?
865 Views
Last Modified: 2013-12-06
Hello,

I am trying to mount a Windows shared folder (NTFS) from a computer on my network to my linux station.

Somehow I am not able to perform this operation. I get all kinds of error message like Server does not exist, Ntfs not supported, etc...

Any help please?

0
Comment
Question by:markrhyman
  • 5
  • 4
  • 2
  • +1
12 Comments
 
LVL 14

Expert Comment

by:JohnK813
ID: 13716290
Red Hat and Fedora (and possibly others) don't come with native NTFS support for a variety of reasons.  You'll need this:

http://linux-ntfs.sourceforge.net/

If you need any help with it, don't be afraid to ask.
0
 

Author Comment

by:markrhyman
ID: 13716374
Yes I would appreciate some help.  I am fairly new to Linux.  Therefore I do not know the commands as I wished.

Mark
0
 
LVL 16

Expert Comment

by:manav_mathur
ID: 13716635
try mount -t ntfs /dev/hdax /mnt/some_directory

where /dev/hdax is your ntfs drive partition which you want to mount, and /mnt/some_directory is a preexisting (preferably empty) directory.

Manav
0
Veeam and MySQL: How to Perform Backup & Recovery

MySQL and the MariaDB variant are among the most used databases in Linux environments, and many critical applications support their data on them. Watch this recorded webinar to find out how Veeam Backup & Replication allows you to get consistent backups of MySQL databases.

 

Author Comment

by:markrhyman
ID: 13717135

I get

 mount: fs type ntfs not supported by kernel

JohnK813 was right.  I need to install NTFS Support but I am not sure of how to do this.  I see that I have to upgrade the kernel and recompile it.  I don't want to screw up and loose information on the linux machine.  I would like to be guided through the steps of this operation please.

Thanks
0
 
LVL 88

Accepted Solution

by:
rindi earned 800 total points
ID: 13717155
For what you want to do here you don't need to mount an ntfs filesystem, as the that is on another PC on your lan. What you will need to have installed on your linux machine, is a Samba client. So first make sure amba is installed. If you also have konqueror installed, you can use that to check if the sambe client works. Just start up konqueror and enter

smb://IpAddressOfWindowsPC

You should now be able to see the shares on your windows PC and also connect to them by using a username and password that exists on your windows PC.

If access to the Windows PC with the konqueror browser isn't enough, and you need it mounted, create a folder on the linux PC which you will use as mountpoint.

Now enter

mount -t cifs -o username=YourUserNameontheWindowsPC //IPAddressOfYourWindowsPC/ShareName /MountPointYouCreated

If that doesn't work try using -t smbfs instead of -t cifs

0
 

Author Comment

by:markrhyman
ID: 13717285
Rinji,

I tried:

smb://IpAddressOfWindowsPC
# smb://Web
bash: smb://Web: No such file or directory
# smb ://Web
bash: smb: command not found
# smb ://192.168.1.253
bash: smb: command not found
# smb://192.168.1.253
bash: smb://192.168.1.253: No such file or directory

Therefore I tried Smbd ://192.168.1.253 and I got back the #

Then I tried

mount -t cifs -o username=administrator //Web/Ipecac/Public /mnt/usrfiles

and I got cifs not supported

thus I did

mount -t smbfs -o username=administrator //Web/Ipecac/Public /mnt/usrfiles

Prompted me for the password.  Entered the windows password and got:

14463: session request to 192.168.1.253 failed (Called name not present)
14463: session request to 192 failed (Called name not present)
Password:
14463: tree connect failed: ERRDOS - ERRnosuchshare (You specified an invalid share name)
SMB connection failed
[root@localhost root]#


0
 
LVL 14

Expert Comment

by:JohnK813
ID: 13717317
rindi is right - you need Samba.  I didn't see at first that you wanted to connect to a shared folder.

Which Linux are you running, and which Desktop Manager?  I'm on Gnome in Fedora Core 3, and I can access Samba through the program menu - that may be a little easier for you.
0
 
LVL 88

Expert Comment

by:rindi
ID: 13717381
The first part you need konqueror, which runs under the Xwindows system (KDE, for instance). If you aren't using X you won't have konqueror installed.

The second part looks like a syntax error on your part. What is the name of the share on your server? Go to your windows PC (Which OS are you using there? XP? Windows 2000 Server? Windows 2003 Server?). right click the shared folder (You should see a small hand below the folder). Then select sharing and security and you should see the name under which the folder is shared.

the syntax would now be:

//IPAddress/Sharedname

your entry was:

//IPAddress/FolderName/PossibleSharedname
0
 

Author Comment

by:markrhyman
ID: 13717817
I am not running and X window on this machine.  Pure command line is what is being used.  Konqueror is not installed either.

The windows server is a windows 2000 Advanced server.

The shared folder I want to access from Linux is \\Web\Ipecac\Public\Backup where Web is the computer with ip 198.168.1.253

Rindi you are right for the Shared Folder that I was trying to access.  I managed to mount the folder on Linux.

Is there a way to have this mount always mounted on reboot?
0
 
LVL 88

Expert Comment

by:rindi
ID: 13717954
You need to edit your fstab file.

add the entry

//ip/sharename      /mountpoint      -t smbfs       -o username=xxxx,password=xxxx,          0  0

I'm not 100% sure about the username, password part, possibly the -o isn't necessary. The syntax could also be somewhat different, but you can see the general way to do it, I think.

The reason I asked about the windows server, for windows 2000 the smbfs always works, with windows 2003 you often need the cifs filesystem, which isn't installed on your linux box...

You would need ntfs mountable only if there was a disk in your PC which has a ntfs partition on it, by the way.
0
 

Author Comment

by:markrhyman
ID: 13717989
Thanks a lot you've been of great help.

Mark
0
 
LVL 88

Expert Comment

by:rindi
ID: 13718014
Thanks too, and no problem.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have written articles previously comparing SARDU and YUMI.  I also included a couple of lines about Easy2boot (easy2boot.com).  I have now been using, and enjoying easy2boot as my sole multiboot utility for some years and realize that it deserves …
This article will show you step-by-step instructions to build your own NTP CentOS server.  The network diagram shows the best practice to setup the NTP server farm for redundancy.  This article also serves as your NTP server documentation.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Suggested Courses
Course of the Month18 days, 20 hours left to enroll

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question