Brightstor ARCserve and Tape Libraries

I have ARCserve 9.0 (Build 2040) installed on my server. I also have a Compaq 35/70 DLT Library (Which appears to be a Compaq branded HP C5173-7000). I'm pretty certain the library works as intended. It passes all the self-diagnostics, and ARCServe will even back up to the drive. I went through the Device Configuration utililty in ARCServe and set up the library. I made 7 Device Groups within ARCServe. The Device Groups are set up basically for 2 slots for each day of the week, and the 15th slot has a cleaning tape. When I tried to initiate a backup, ARCserve started backing up to the 1st tape in the group....then after it got to 72% of the job, it asked me to insert another tape. I had been under the impression that ARCserve with the Tape Library Option installed (which I do have) should auto-span.

I searched through EE and found a PAQ that said I should go into Windows Device Manager and disable the library and the tape drive in the library, then go back through the ARCserve device configuration and set the library up again. I did this, and I do not get any change in what happens. At 72% of my back up job, a message appears on the console asking for another tape.

This is getting very frustrating, especially since my server is no longer getting good backups. I have a LOT of customer data on this system, and I really need to get a backup solution going that doesn't require a manual intervention every morning... I thought that was the point of libraries....

Thanks.
LVL 9
CCongdonAsked:
Who is Participating?
 
dovidmichelCommented:
Do a Quick Erase Plus on the second tape and then as a blank tape it should be used.

If it still does not work then the details of the jobs will be needed.

I don't keep track of build #s but here are the latest updates:
http://supportconnectw.ca.com/premium/storage/downloads/nt/v9/basb9-patchmenu.asp
QO65196 CAZ 68.0 MB 03/10/05 NT -BAB V9.01 - SERVICE PACK 1
QO66069 CAZ 7.7 MB 04/04/05 NT -BAB V9.01 DEVICE SUPPORT UPDATE 5  
0
 
patrick24Commented:
Yup, it should auto-span.

Make sure windows RSM is disabled.
There a meda option, check the global option for addtional media in brightstor.

:)
0
 
dovidmichelCommented:
Well with a library it is better to not use the option to Overwrite Any Tape.
Unless there is some tipe of Database or Tape Engine problem erasing the tape should take care of the problem.

Also this erase only has to be done the first time. Next week when the job runs again the tape will be fine as is.

Thing is this the tapes will be formated with the same name and ID only the serial and seq. # will be different. You can format two tapes with the same name but there is no way to give them the same random ID, so the seq. #2 tape has to be formated by ARCserve and not a user.  
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
CCongdonAuthor Commented:
Sigh, such a simple answer for what seemed like a huge problem. Thanks a lot! I was getting worried because I hadn't had any backups on this server in about a week, and this particular server has a LOT of data from several customers on it.
0
 
CCongdonAuthor Commented:
Yeah, I see where the ID on the tapes is now the same, and one says Sequence #1, and the other says Sequence #2. As for the serial numbers, it appears to have taken those directly from the barcodes I put on the tapes.

I officially have to say that Tape Libraries are cool. I picked this one up from a state surplus auction for $150. Glad to see it actually works. Also glad to see my tax dollars coming back to me in a way....the inventory sticker on the back still says 'Indiana Department of Revenue' heh.
0
 
dovidmichelCommented:
$150 !!! wow right place at the right time
0
 
CCongdonAuthor Commented:
I'd say so. Actually, it was a little more than that, since the auction had a 10% premium...then I had to buy a rail set for it, then tapes... But still, for a working DLT Library, it was a great deal. I've just bought a second library drive on eBay, so I'm hoping to load it into the empty slot. Hopefully the drive actually works... However, in the end, even if it has one drive, this thing is great, albeit huge. We like having small things in the rack, but this particular server with the library is HUGE (The server is a Compaq Proliant 7000). I think that's about what, almost half the rack? But, this box isn't going anywhere. 3 redunant power supplies, redundant NICs, redundant RAID controllers (all hot plug), and we've got it set up with two RAID drives, each running RAID5 w/hot spare. This setup gives us 100GB of storage for our customer data, and it takes a lot to drop this particular server....It would almost have to be someone running a crowbar into to nuke it.

Anyways, I thank you, my boss thanks you, and my customers thank you (althought I am NOT telling them I haven't been backign their data up for a week!!!) for helping solve this problem. I just wish CA's knowledge base and manuals were a little more straight forward since it seems that this problem had a simple solution. Oh well, that's what EE is for isn't it??

-Chris
0
 
dovidmichelCommented:
Thanks for the thanks, it is a very good idea in not informing the clients. Perhaps it would have been good to use a work around of breaking the job up into two until the problem was fixed just to make sure the data is backed up.

The ARCserve support site used to be a lot better, but it has been under going this major chance. It now seems to be in the midst of its second generation of change.
0
 
CCongdonAuthor Commented:
Well, the problem was that breaking the job up still required manual intervention. The other part of the problem is that we thought several times that we had 'fixed' the problem, only to find the next morning that it didn't work. Believe me, if I had known on day 1 I wasn't going to get a backup for a week, I would have done something different...

Part of what happened was that we were backing up to a solo DLT drive in the server, and last week, we crossed the threshold of being able to fit on one tape, so I thought finally setting up the library we purchased was a no-brainer.... And then the next day when it hadn't worked right, I made some changes, re-submitted the job and tried again...and that didn't work. Then elsewhere in EE I found an accepted answer to what looked to be the exact same problem, so I figured it was a good answer, so I made the critical error of making those changes and then not testing out the new job, instead I just waited for the job to run on its own....

So, I've been spinning my wheels....until last night. That's one more item off my list... now to fix that e-commerce site with the whacked out DB. Guy is using Access to power an online store that grossed about $750K last year... I've been telling him Access != Reliable in large environments. So now he finally calls me up complaining about his website crashing everytime his guy makes updates to the product lists... *Sigh*
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.