[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 496
  • Last Modified:

Using SMTP Connector with Virtual SMTP Server! 500 POINTS!

Hi,

I have a question with using a SMTP connector with a virtual SMTP server.  I am trying to separate emails with aol.com domain.  I setup a SMTP Connector for the aol.com domain and then I setup a AOL SMTP VIRTUAL SERVER.  The default SMTP Server is used to deliver all the non-aol emails but I want the AOL SMTP Server to send out just the aol emails.  The main reason I want to use a separate AOL SMTP Virtual Server is so that I can set different delivery time restrictions for the aol.com emails.

After I setup the AOL virtual SMTP server for aol and listed the IP address of the AOL virtual SMTP server in the "Forward area" of the SMTP Connector, I notice in EXchange System Manager > Queues area that the listed source for the SMTP connector is still Default SMTP Connector while I thought it should say the AOL SMTP VIRTUAL SERVER.

I am still noticing that the delivery time restrictions set in the AOL SMTP Virtual Server is not affecting the aol.com emails.  The aol.com emails are being affected by the delivery time restrictions set in the Default SMTP Virtual Server.

Can someone please help me with this?  

Thank You!
0
NAPSR
Asked:
NAPSR
  • 16
  • 13
1 Solution
 
kristinawCommented:
Naps,

you are a little mixed up about what you are trying to do, but are on the right track. first off, you don't need or want a second smtp virtual server. the only time you would have additional smtp virtual servers is if you have more than one ip on the server, or mail coming in on more than one port.

so first off, get rid of the additional virtual server.

next, the smtp connector. this is where you will specify how AOL emails are handled. Setup the new connector, call it whatever you want. in the address space tab you will want to make sure you have aol.com where it says address, with a cost of 1. the delivery options tab is where you will need to specify what time you want the connector to be able to connect. to get the new options to take effect you will need to restart the smtp service.

let me know if you have any questions.

Kris.
0
 
NAPSRAuthor Commented:
Thanks for your help.

Lets say I send about 20,000 aol.com emails from my desktop at midnight.  I want these emails to be sent until 7:00 am.  I don't want any emails being sent out during the day so to not to clog the bandwidth.  Then I want to be able to send them out again at night.  AOL usually allows about 15,000 to go through before 7:00am and then I usually notice about 5,000 just sitting in the queue waiting for aol servers to accept them.  Before when the server was trying to send these 5,000 emails, the bandwidth would always be slow so thats why I don't want to send any emails during the day.

Now for the regular non-aol emails, I want to be able to send them throughout the day during different intervals.  So I have delivery restrictions set up for the Default SMTP Server so that it times out after about 6 hours.  But I don't want these timout settings to affects aol emails.

Is this possible to do?  

Thanks

0
 
kristinawCommented:
20,000 emails?

sending out spam are we?
0
Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

 
kristinawCommented:
all items you reference above are controlled through the smtp connector settings, the key is to have a separate connector setup for each address space for which you want to control time settings or have a customized connection schedule. you can also set up connectors with different delivery times for very large messages, for example.
0
 
NAPSRAuthor Commented:
We have a job board with a large members database and we send out newsletters frequently.

On the SMTP connector now, I have it deliver from midnight to 7am and then again at night from 8 to 11 pm.  I noticed yesterday that about 5,000 aol emails had timed out.  This happened because I have the timeout restrictions set on the default virtual server at 6 hours.

I DO NOT WANT THE AOL EMAILS AFFECTED BY THE DEFAULT SMTP SERVER DELIVERY RESTRICTION SETTINGS.

How can I set it up so that the aol emails are not affected by the default virtual server timeout restrictions.

Thanks for your help.
0
 
kristinawCommented:
ok, let me try to explain again.

YOU DO NOT NEED TO MODIFY ANYTHING ON ANY OF THE SMTP VIRTUAL SERVERS.

setting up a separate smtp connector for aol addresses will not affect other emails that go through the default virtual servers. i promise.

"How can I set it up so that the aol emails are not affected by the default virtual server timeout restrictions."

if you are setting restrictions at the virtual server level, this could be what's causing the confusion. you don't want to do this. setup the connector (or connectors) as i suggested and put any time, size or schedule customizations in there.

Kris.
0
 
NAPSRAuthor Commented:
Thanks for the explanation.

"if you are setting restrictions at the virtual server level, this could be what's causing the confusion. you don't want to do this."

I have a lot of emails with bogus domain names that the server keeps trying to send.  I want the server to try to send non-aol emails for about 6 hours and then after the 6 hours is up, I want these non-aol emails to timeout.  So I setup the delivery time restriction on the Default SMTP Virtual Server to timeout after 6 hours.  

But this setting is also affecting the AOL emails.  I don't want the AOL emails to timeout after 6 hours.

Any way to prevent AOL emails from being affected by the Default SMTP Virtual Server timeout setting?

Thanks
0
 
kristinawCommented:
ok, that makes it a bit more clear. i'll think it over while i eat my chicken nuggets and see what i can come up with.

do you have a default smtp connector that all mail goes through? do you have any smtp connectors at all on your system?
0
 
NAPSRAuthor Commented:
Yesterday, I setup the AOL SMTP Connector for aol.com emails.  I do not have any other SMTP Connectors.

Someone yesterday had me setup the 2nd virtual server so that I can deliver the AOL emails through the SMTP Connector to the 2nd virtual server.  On the 2nd virtual server, I can specify any delivery time restrictions to only apply aol.com emails.  

But when I tried to send it out, the AOL SMTP Connector is delivering the emails to the Default SMTP Server and not the 2nd virtual server.

Thanks...I will be waiting for your reply.
0
 
kristinawCommented:
ok. here goes... in order to have more than one virtual server, you will need to give the server an additional ip address or give it a different port assignment (something other than 25). since i doubt you're going to want to do the latter, you'll want to do the former. what you will in effect be doing is emulating an additional mail server.

one comment on your last statement: But when I tried to send it out, the AOL SMTP Connector is delivering the emails to the Default SMTP Server and not the 2nd virtual server.

you  have this backwards. virtual servers send mail out through an smtp connector, if there is one, not the other way around. mail goes to the virtual server first, not the connector. it's considered a 'best practice' to have a default smtp connector with an address space of * to handle all mail, then add extra one as needed, such as the aol one in your case.

now, back to the virtual server, you will somehow have to tell the application that is sending your our your mail that it needs to use a different mail server (which is in effect what you are creating when you create an additional virtual server) when it sends mail to AOL mail addresses and direct your AOL mail there. that is the only way to get mail to go through another virtual server.

here's how to create an additional virtual server with a different IP address:
http://support.microsoft.com/kb/303707/EN-US/

this a better explanation?
0
 
NAPSRAuthor Commented:
Thanks.

I created another virtual server with a different IP and on port 26.  On the outbound connections, I left the port on 25.

So the emails go:

Desktop > smtp virtual server > smtp connector > (I have the smtp connector set so that it forwards it to the aol smtp server but its not happening!)

The way i have the smtp connector setup now is that i tell it to forward it to the IP address of the 2nd virtual server so why is it not being delivered by the aol smtp server?

So you are telling me that I have to split up the aol emails on my desktop and deliver it to the aol smtp server?  It will take a long time to split it up that way.

Any other suggestions?

Thanks for your help.
0
 
NAPSRAuthor Commented:
So let me get this straight now:

 - I send 20,000 emails from my desktop.
 - Default SMTP Virtual Server begins to deliver all non-aol emails and sends all aol.com
   mail to the SMTP Connector.
 - SMTP Connector receives 10,000 aol.com emails.
 - SMTP Connector delivery schedule is set so that emails are delivered from midnight to  
   7am and then again from 8pm to midnight.

DURING THE TIME WHEN DELIVERY IS NOT SCHEDULED, DO THE AOL.COM EMAILS JUST SIT IN THE SMTP CONNECTOR AND WAIT FOR THE NEXT OPEN DELIVERY TIME?

ARE THE AOL.COM EMAILS SITTING IN THE CONNECTOR AFFECTED BY THE DELIVERY RESTRICTION SETTINGS IN THE DEFAULT SMTP VIRTUAL SERVER?

So..

MY GOAL: To not let the server try to send out aol.com emails during the day so as to not clog the bandwidth.

SOLUTION: If I just set the delivery time restrictions on the Default SMTP Server for 2 days then IT WOULD NOT TIME OUT BEFORE ALL THE AOL EMAIL ARE SENT OUT and AOL.COM EMAILS WOULD NOT BE DELIVERED DURING THE WORK DAY.


PLEASE TELL ME IF ALL THE ABOVE IS CORRECT!

Thanks




 
0
 
kristinawCommented:
let me address the first set of comments first, then i'll read the second one.

first, your comment: Desktop > smtp virtual server > smtp connector > (I have the smtp connector set so that it forwards it to the aol smtp server but its not happening!)

as i said in my previous post, my flows FROM a virtual server TO an smtp connector, not the other way around. it is not possible to 'set' an smtp connector so that it will forward mail to a virtual server. that's why it isn't happening.


your comment: The way i have the smtp connector setup now is that i tell it to forward it to the IP address of the 2nd virtual server so why is it not being delivered by the aol smtp server?

again, read what i just wrote, smtp connectors do forward mail to virtual servers, they accept mail FROM a virtual server and forward it someplace else.

now i'll read the second post...
0
 
kristinawCommented:
woops, i meant again, read what i just wrote, smtp connectors do NOT forward mail to virtual servers, they accept mail FROM a virtual server and forward it someplace else.

now i'll read the second post...
0
 
kristinawCommented:
left out the critical NOT in the 2:23pm comment
0
 
kristinawCommented:
now for the second post...

DURING THE TIME WHEN DELIVERY IS NOT SCHEDULED, DO THE AOL.COM EMAILS JUST SIT IN THE SMTP CONNECTOR AND WAIT FOR THE NEXT OPEN DELIVERY TIME?

Yes

ARE THE AOL.COM EMAILS SITTING IN THE CONNECTOR AFFECTED BY THE DELIVERY RESTRICTION SETTINGS IN THE DEFAULT SMTP VIRTUAL SERVER?

Yes

what will happen if you have an smtp connector (with time restrictions) for aol is the following, as the default virtual server receives emails, if it gets one destined for aol during a time when the connector is not 'active', the default virtual server will queue messages up in a queue, or connection,  that is destined for that connector. the queue will have the same name as the connector. as soon as the connector starts to run, or becomes 'active' (at 8 pm, for example), the virtual server will realize the connector is active then will start pumping the aol mails through it.

SOLUTION: If I just set the delivery time restrictions on the Default SMTP Server for 2 days then IT WOULD NOT TIME OUT BEFORE ALL THE AOL EMAIL ARE SENT OUT and AOL.COM EMAILS WOULD NOT BE DELIVERED DURING THE WORK DAY.
Yes, provided you have the SMTP connector in place to tell the virtual server that AOL mails are to be handled differently than everyone else.

hth,
Kris.
0
 
NAPSRAuthor Commented:
Thanks..that helps a lot.


So I guess I can go ahead and delete the second smtp server?

Also, what should the setting be on the SMTP Connector:

Use DNS or Forward
If its forward, what should the IP address be?  The IP address of the server?


Thanks
0
 
kristinawCommented:
if you have no default smtp connector in place already and you do not have the 'smart host' setting enabled on your default virtual servers (which you shouldn't) then you will select use DNS.

you would use the 'Forward' option, if, for example in my domain i have a mail server that sits in a dmz, my internal mail servers 'Forward' all mail to the server in the dmz, and he uses DNS to send it along to its next hop.

Kris.
0
 
NAPSRAuthor Commented:
Allrighty...Thank you very much for clearing all that up.

I have done what you told me to do and I reset the Microsoft Excange Routing Engine and the SMTP Service.

I will send out the emails tonight and hopefully tomorrow morning, if all the emails did not go through during the night, I should find some in the AOL Connector Queue waiting for the next time period.

Also, on my desktop computer > outlook express, if i set the outgoing mailserver as my ISP's mailserver then the emails are not going to go through my server's SMTP right?  For example, if I want to email my friend john@aol.com and I use my ISP's mailserver then that mail will not be affected by the settings in my SMTP server right?
0
 
kristinawCommented:
you got it.
0
 
NAPSRAuthor Commented:
Hi kristinaw,

How are you?

I came back this morning and noticed that all the emails were delivered.  But its 9:15 A.M. now and I see that the AOL SMTP Connector says that its in "Retry" mode.  Its trying to resend about 3 emails but it should say "Scheduled".  I have it set to only deliver from midnight to 7:00am and then from 8pm to midnight.

I thought once it was 7am then the AOL SMTP Connector would not deliver anymore emails?

Thanks
0
 
kristinawCommented:
to be honest i've never set up a connector on a schedule, so this may be what its supposed to look like. maybe when the time limit is reached, if emails are in the queue when the cutoff time is hit, then it might just stay in retry mode until the 'on' button is hit again. at any rate it sounds like it's doing a much better job of what you want than before.

just watch it for a few days and you should be able to get a good idea of how it's supposed to look, etc.

hth,
Kris.
0
 
NAPSRAuthor Commented:
I just hit force connection, then froze, and then unfroze it and now it says "Scheduled".  I think you are right when you say that if there are emails in the queue even during non delivery times, it still keeps sending it.  

Thanks
0
 
kristinawCommented:
right, it might be that if they get queued up before the 'off' time they get stuck in a retry state. i wouldn't worry about it, they should just sit there until it clicks 'on' again, then go out.
0
 
NAPSRAuthor Commented:
Hi kristinaw,

The SMTP AOL Connector is not working correctly.  I checked it this morning and noticed that there were 4,000 emails stuck in queue.  Now I expected that but it is still trying to deliver it throughout the day.  Right now its about 2,500 emails in queue.  I don't want it to use up the bandwidth during the day.  The whole purpose of setting up the connector was to make sure that it would not deliver during the day.

I tried freezing it and then upfreezing it but it is still trying to deliver the emails.  

Do you have any other suggestions?

Thanks
0
 
kristinawCommented:
under the Delivery Options tab in the connector properties do you have the time schedule set in that area?
0
 
NAPSRAuthor Commented:
Yes...I have shaded the regions that I want the SMTP Connector to ONLY deliver.  If there is emails still in the queue even after the deliver window is closed, it still send out the remaining emails in queue.

I DO NOT WANT THIS TO HAPPEN.  I do not want the SMTP Connector to keep trying to send out the emails which would consume a lof of bandwidth.

Please help...
Thanks
0
 
kristinawCommented:
well, if i were you, what i would do after observing what is happening is this...

i would want to make sure new emails aren't getting sent to the connector after it's scheduled delivery window - you seem to think that is the case since the numbers go down after that point, not up

so, given the statement above, it sounds like emails that get queued up before the end of the scheduled delivery time get to keep trying to be delivered.

so, why don't you try decreasing time window during which the connector is allowed to accept messages.

Also, when you pull up the connector properties, do you aol.com in the address space with a cost of 1?
0
 
NAPSRAuthor Commented:
"so, why don't you try decreasing time window during which the connector is allowed to accept messages."

I usually send out the newsletters at midnight and it takes about 4-5 hours for my desktop to send all the emails to the server.

If I set the delivery time window on the SMTP Connector from midnight to 5am, does that mean:

The SMTP Connector will only accept emails from the desktop from midnight to 5am and deliver them during this time.  After 5am, it will just queue the emails until the next open delivery window?

I think that right now whats happening is that the SMTP Connector is ACCEPTING AND DELIVERING emails during its open delivery window and after the window is closed, the SMTP Connector ACCEPTS new emails but does not deliver them BUT WILL STILL TRY TO SEND OUT THE OLD EMAILS IT RECEIVED EVEN AFTER THE WINDOW IS CLOSED.

I DON'T WANT THIS TO HAPPEN!  Any suggestions?

Right now, the SMTP Connector has sent about 3,000 emails this morning and while doing so, clogged up the bandwidth WHICH I AM TRYING TO PREVENT.

"Also, when you pull up the connector properties, do you aol.com in the address space with a cost of 1?"

Yes


Thanks
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 16
  • 13
Tackle projects and never again get stuck behind a technical roadblock.
Join Now