[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4087
  • Last Modified:

vsync - on or off?

Should the 'vsync' option be kept on or turned off?
0
Oceanstar
Asked:
Oceanstar
  • 4
  • 3
  • 2
  • +2
1 Solution
 
Wojciech DudaCommented:
Depends. Do you have a powerful machine? And most importantly, what is the Refresh rate of your monitor?

Vsync forces games to draw exactly as many frames as the monitor can per second, i.e. if you have your monitor running at 85 Hz then it will be forced to draw 85 frames per second - but this will be hard for your machine because it must be able to run the game at 85 fps.

If your machine is not powerful enough then vsync will cause slowdowns (not choppiness, slowdons), as the game will redraw frames to reach 85 fps, recalculating each frame even without game progress.
You can prevent some display errors that way and also force some games to run at more than 60 Hz, and 60 Hz can strain your eyes after a while of playing.

Because I have a rather fast machine and I do not like slowdons in games I usually turn vsync off.
 
0
 
OceanstarAuthor Commented:
Monitor: 19' Philips 109-B6
Display settings: 1600 X 1200 @ 74Mhz
Motherboard: Asus A8N - SLI Deluxe
CPU: AMD Athlon 64bit 3200+
GFX: nVIDIA 6600GT
1 GB RAM

Though Half Life 2 should run perfectly with this config, the loading times seem too long and the game often stutters. I play at 1280X960. I was wondering if the vsync option was causing the problem. Also, my eyes strain a lot after/while playing HL2. So it seems like a refresh rate thing to me.

Any ideas?
0
 
Wojciech DudaCommented:
Isn't there an option in HL2 to set the refresh rate the game is using?
I would turn vsync off for such a fast machine and HL2, while making sure I run at quite a high refresh rate (check if you can set it ingame).

The stuttering could be caused by a lot of things (many possibilities for a bottleneck in a system, are other games smooth?). Your strained eyes could be because of a low refresh rate when playing it. Turning vsync off should help (or you can force the game to vsync at 100 Hz :-)
0
New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

 
OceanstarAuthor Commented:
There is no option in HL2 to set the refresh rate. My normal display settings are : 1600 X 1200 @ 74Hz. How can I force the game to run at 100 Hz?
0
 
Wojciech DudaCommented:
First, dunno if your monitor supports 1280x960@100Hz. I would turn vsync off and see if you notice a change.
0
 
Jerry_PangCommented:
>>There is no option in HL2 to set the refresh rate. My normal display settings are : 1600 X 1200 @ >>74Hz. How can I force the game to run at 100 Hz?

run directx
click "more help"
click overide
change the refresh rate in overide value.
0
 
Jerry_PangCommented:
With VSYNC enabled, frame rates will not exceed the monitor's current refresh rate for that particular resolution.

For example, if your monitor is using a refresh rate of 85Hz at 800x600, with VSYNC enabled, you will theoretically never exceed 85fps. So the refresh rate creates an artificial barrier that limits the frame rate.

Frame rates will appear higher with vsync off but the amount of information displayed is limited by your monitor in that instance. A monitor with an 85 Hz refresh rate will only display 85 frames per second even if the videocard is rendering 400 frames a second. The visual quality may decline as a result also because some frames could be skipped as a result of excess rendering resulting some visual anomalies, image tearing and flashing polygons.

turning it on with your PC and video card is a ok.


"loading times seem too long and the game often stutters. I play at 1280X960. I was wondering if the vsync option was causing the problem. Also, my eyes strain a lot after/while playing HL2. "

higher resolution will load longer. as for the stutters, other cause for this is
if you enable Anti-Aliansing. 2x-4x-8x will greatly reduce framerate. try setting it at "No AA"
0
 
Wojciech DudaCommented:
I can show and prove that VSYNC can make a game stutter. I have seen this a lot with GTA for example.
0
 
GonazCommented:
You can go ahead and keep it on buddy, and continue playing your retro games where it may be necessary. The fact is, the majority of people do have it off, because they have computers capable of dishing out a continuous frame count, why have a powerful video card if you are just going to sit there skipping along at 60 fps?
0
 
Jan LouwerensCommented:
When running benchmarks, I always turn vsync off. Otherwise, the results will be skewed by the refresh rate limiting specified above.

But when running games, I always turn vsync on. This makes the animation smoother by preventing a phenomenon known as shearing. (This is when the frame buffer is displayed on your screen while it's being written to. So on your display you get part of the current frame, and part of the previous frame, with a nice visible "shear" between the two.) I'm sure anyone who turns vsync off has seen this. The shearing is less noticable at higher frame rates, but to the human eye, there isn't much difference between 60fps and 100fps anyway, so I opt for the smoother animation at the cost of less noticable higher framerates.
0
 
Jerry_PangCommented:
>> I play at 1280X960.

your running HL2 at very high resolution..
From benchmarks,  http://www20.graphics.tomshardware.com/graphic/20050404/geforce_6600-33.html
p4 3.2ghz and 1gig ram at 1280x960 - trilinear and no AA
HL2 runs at 55fps only.

try running at 1024x768 resolution.. you'll get a higher fps.
0

Featured Post

Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

  • 4
  • 3
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now