OMA (Outlook Mobile Access) "Service Unavailable"

Posted on 2005-04-07
Last Modified: 2012-05-05

I tried nearly anything I found on the Internet regarding this problem - without any success.

We have an Exchange 2003 server running under Windows Server 2003. I'm trying to activate "Outlook Mobile Access" but can't get it to work. All I get is - with any browser - the message "Service Unavailable" (HTML code: <h1>Service Unavailable</h1>) when I try to access http://our-server/oma.

Of course I have activated OMA in the global settings (mobile services). The web server directories exist and seem to be active. There are NO messages regarding this problem in the system log.

I have tried some things I found on the Internet and here on EE: Checking the security settings of the /oma web application and adding the line <pages enableSessionState="true"/> to the Web.config file. I even restarted the server today after this change. Didn't help.

I also think this is another error as most people have with OMA. At least some get a more specific error messages. I tried activating ASP debugging messages, but the only thing i get is this "Service Unavailable" thing. If I try from a mobile device or with a WAP emulator, I get "503 Service Unavailable".

Because this is a produtive server I can't recreate all the Web directories as stated in a KB article by Microsoft. The risk to break OWA functionality is too high.

I hope someone of you might have a clue on what's going on here.

Thanks a lot.
Question by:wetzeladmin
    LVL 2

    Accepted Solution

    does ExchangeMobileBrowseApplicationPool exist under the application pools in IIS Admin?  Does OWA exist under your default web site, as part of that app pool?

    just a couple guesses.

    Author Comment

    Uhhh, thanks for the hint where to look at. *bashing head against wall*. The ExchangeMobileBrowseApplicationPool has been in state "Stopped".... argh.

    I started the thing and now I get the login window.

    But... now the next error: I get the message "System error while processing your request. Please contact your administrator." (not literally translated, I have the message in German).

    In the event log I have the following error (unfortunately German, too):

    Ereignistyp:      Fehler
    Ereignisquelle:      MSExchangeOMA
    Ereigniskategorie:      (1000)
    Ereigniskennung:      1507
    Datum:            07.04.2005
    Zeit:            15:09:08
    Benutzer:            Nicht zutreffend
    Computer:      WGW-EXS
    Unbekannter Fehler beim Verarbeiten der aktuellen Anforderung: Eine Ausnahme vom Typ Microsoft.Exchange.OMA.DataProviderInterface.ProviderException wurde ausgelöst.

       at Microsoft.Exchange.OMA.UserInterface.Global.Session_Start(Object sender, EventArgs e)
       at System.Web.SessionState.SessionStateModule.RaiseOnStart(EventArgs e)
       at System.Web.SessionState.SessionStateModule.CompleteAcquireState()
       at System.Web.SessionState.SessionStateModule.BeginAcquireState(Object source, EventArgs e, AsyncCallback cb, Object extraData)
       at System.Web.AsyncEventExecutionStep.System.Web.HttpApplication+IExecutionStep.Execute()
       at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

     Innerer Fehler: Ein Aufrufziel hat einen Ausnahmefehler verursacht.

       at System.Reflection.RuntimeConstructorInfo.InternalInvoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean isBinderDefault)
       at System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
       at System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
       at System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
       at Microsoft.Exchange.OMA.UserInterface.Global.Session_Start(Object sender, EventArgs e)

     Innerer Fehler: Der Remoteserver hat einen Fehler zurückgegeben: (403) Unzulässig.

       at Microsoft.Exchange.OMA.ExchangeDataProvider.OmaWebRequest.GetRequestStream()
       at Microsoft.Exchange.OMA.ExchangeDataProvider.ExchangeServices.GetSpecialFolders()
       at Microsoft.Exchange.OMA.ExchangeDataProvider.ExchangeServices..ctor(UserInfo user)

    Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter

    Some further guesses, maybe?

    LVL 2

    Expert Comment

    are you using instead of just username for OMA?

    maybe you should restart IIS Admin service just for kicks.

    Author Comment

    For Web Access we use syntax.

    The current configuration for Mobile Access accepts (basic) authentication only with normal network username and password.

    Author Comment

    Okay, solved the problem with a little more research.

    Problem was that we require SSL to connect to our Web Access. And SSL is not supported by OMA, resulting in these strange error messages (Hint to MS: Why not write something like "Error connecting to OMA: No SSL supported"?).

    This is the KB article:;en-us;817379
    It shows how you can create a new virtual /exchange directory without SSL requirement exclusively for Mobile Access.

    Now everything works great. There is only the message "Unsupported device" when connecting from some mobile phones. But with a click on "Ok" everything works. Maybe I need an update of some kind.

    Thanks for your help, though. I give you the points because you kicked me into the right direction.

    Featured Post

    Why spend so long doing email signature updates?

    Do you spend loads of your time carrying out email signature updates? Not very interesting are they? Don’t let signature updates get you down. Let Exclaimer Cloud - Signatures for Office 365 make managing email signatures a breeze.

    Join & Write a Comment

    Resolve Outlook connectivity issues after moving mailbox to new Exchange 2016 server
    Not sure what the best email signature size is? Are you worried about email signature image size? Follow this best practice guide.
    In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
    In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…

    728 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    20 Experts available now in Live!

    Get 1:1 Help Now