FTP server on Windowx/XP returns error 426

Posted on 2005-04-07
Last Modified: 2012-08-13
In order to get a SuSE Linux server updated from a local FTP server I (temporarely) installed the IIS FTP component on my Windows/XP Pro laptop and provided a ftp directoy with the SuSE Linux FTP distribution. I opened port 21 in the Windows firewall and tried to perform a Linux ftp network installation. After starting installtion from a boot cd my FTP server has been found and the installation started to download /suse/boot/root from However, the download failed with error 426!

Next I went to my Windows/XP Pro Desktop computer and tried to access the same ftp directory by entering into the address bar in Internet Explorer 6. The same here. It could not retrieve the directory even I made sure I used anonymous access.

Next, again from my Windows/XP Pro Desktop computer,  I started ftp in a command window and opened a connection to I entered "Anonymous" as the username and my email-address as password. I tried to list the suse directory, which worked fine, and finally downloaded /suse/boot/root to my desktop pc. No errors, no problems.

Why this different behaviour? How can I solve the problem on the server side?

Question by:pgloor
    LVL 5

    Author Comment

    If I uncheck "Tools -> Internet Options -> Advanced -> Use passive FTP" in Internet Explorer it works as well. So the problem ist that SuSE FTP Install does not use passive FTP while the Windows FTP server does not accept this.

    So my question has changed:
    - Can I change FTP server to accept non passive FTP requests?
    - If yes, how?
    LVL 18

    Accepted Solution

    You must open port 20 as well for iis ftp service in active mode. And read more here:;en-us;832017

    To open the high port you must have ALG service active. You'll find more info at Microsoft.

    For the suse installation, can't you stop windows firewall for some time? Only if the computer is not connected to Internet!
    LVL 18

    Expert Comment

    Why B grade? Thanks for points, anyway.
    LVL 5

    Author Comment

    Since all computers are inside a small LAN, stopping the firewall solves my problem for the Suse installation.

    I followed any other hints, started ALG, opened port 20 and 21 and restarted/rebooted the PC. Nothing helped.
    As soon I disabled the Windows Firewall it worked without further intervention.


    Featured Post

    What Security Threats Are You Missing?

    Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

    Join & Write a Comment

    Have you ever set up your wireless router at home or in the office to find that you little pop-up bubble in the bottom right-hand corner of Windows read "IP Conflict - One of more computers on the network have been assigned the following IP address"…
    We recently endured a series of broadcast storms that caused our ISP to shut us down for brief periods of time. After going through a multitude of tests, we determined that the issue was related to Intel NIC drivers on some new HP desktop computers …
    Here's a very brief overview of the methods PRTG Network Monitor ( offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
    Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

    754 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    23 Experts available now in Live!

    Get 1:1 Help Now