Oracle Reports 6i; Strange Errors

Posted on 2005-04-07
Last Modified: 2012-08-13
We are currently using Oracle Reports 6i for our reporting, and are experiencing errors when requests for generation of on-the-fly reports are made via our application. Reports which are not generated on-the-fly, and utilize the Oracle Queue, are being generated correctly.

I have searched the web for a resolution to this problem, to no avail. Suggestions usually revolved around restarting the Oracle Reports server, recompiling the reports, recompiling the PL/SQL, or refreshing the browser, etc. None of these resolutions worked.

The first error received in our browser was the following: "Error: The requested URL was not found, or cannot be served at this time. Oracle Reports Server CGI - The Reports Server Engine terminated abnormally." I went home last night when none of the suggestions which were implemented worked.

When I came in this morning, a more detailed error message was displayed: "Error: The requested URL was not found, or cannot be served at this time. Oracle Reports Server CGI - Report Job has terminated with error. Reports Server Replies: REP-0736: There exist uncompiled program unit(s). REP-1247: Report contains uncompiled PL/SQL."

Any assistance in solving this problem will be very much appreciated!

Thanks much.
Question by:Electrokardiogram

    Author Comment

    Elaboration of the term "on-the-fly" report: the report uses cgi60, not the Oracle Queue.
    LVL 3

    Expert Comment

    Can you compile the report?  Perhaps there's a little compilation error, like the name of a field changed or something like that, maybe.

    I'm assuming you know how to compile a report.

    Author Comment

    Thanks for your reply, "dnarramore". Please reread my original post - I already tried recompilation.

    It turns out that there appear to be some bugs in Oracle Reports 6i, and this is probably one of the reasons some of the other groups at work have upgraded to Oracle Reports 10g.

    One bug is the fact that Oracle Reports 6i will indicate a successful compile sometimes when the compile really was not successful. Essentially, the successful compile message will be displayed, but checking the Program Units section of a report to make sure no units have an asterisk by them will verify whether the compile was truly successful. A colleague of mine pointed this out - this is not a very intuitive feature of the product.

    Another bug is the fact that, when calling stored procedures that have optional parameters from a unit within Program Units, the optional parameters apparently need to be specified within the call - as soon as I supplied these parameters, which were coded as being optional in the associated packages, the report successfully compiled with no asterisks. This is also a very annoying feature of which I was not aware - Oracle Reports should adhere to PL/SQL rules when calling PL/SQL!

    This question is now closed.
    LVL 5

    Expert Comment


    check the following

    Open up a seeded reports and see the before report trigger. I remember SRW.INIT and something else that must exist.

    Check the way you transfer it.. Make sure it is binary transfer and also do you have any attached library plls

    You can also try converting your report by using the Report Compiler , this should be installed with the standard installation of Oracle Reports 6i

    try to gtant execute on the package to public and see


    Accepted Solution

    Question Closed, 500 points refunded.
    Community Support Moderator

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    PRTG Network Monitor: Intuitive Network Monitoring

    Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

    Truncate is a DDL Command where as Delete is a DML Command. Both will delete data from table, but what is the difference between these below statements truncate table <table_name> ?? delete from <table_name> ?? The first command cannot be …
    Note: this article covers simple compression. Oracle introduced in version 11g release 2 a new feature called Advanced Compression which is not covered here. General principle of Oracle compression Oracle compression is a way of reducing the d…
    This video shows how to Export data from an Oracle database using the Datapump Export Utility.  The corresponding Datapump Import utility is also discussed and demonstrated.
    This video shows how to configure and send email from and Oracle database using both UTL_SMTP and UTL_MAIL, as well as comparing UTL_SMTP to a manual SMTP conversation with a mail server.

    759 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    12 Experts available now in Live!

    Get 1:1 Help Now