?
Solved

Unable to add a computer to the domain

Posted on 2005-04-07
8
Medium Priority
?
347 Views
Last Modified: 2010-04-12
We are currently adding multiple computers to a domain and I have a couple of computers that I am unable to add to the domain
I can't even change the computer name
I am logging in as administrator and there are no group policies or local security settings in place
I receive the following error messages:
When joining the domain:
"The specified service does not exist as an installed service"
When we check Active Directory the computer name shows up
When I check the computer its still resides on a workgroup
When changing the computer name:
"A network error has occurred"

This computer is a Windows 2000 SP4 joining a 2003 domain
We have tried removing the computer from the domain and rejoining with no sucess

Does anyone know why this is happening?

Thanks
0
Comment
Question by:carrilloeo
7 Comments
 

Expert Comment

by:Cveselka
ID: 13729799
Do you have an error in the event log?
0
 

Author Comment

by:carrilloeo
ID: 13730916
There are no errors in the event log
0
 
LVL 7

Expert Comment

by:sweatbeast
ID: 13731710
reinstall sp4
0
Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

 
LVL 5

Expert Comment

by:sai2480
ID: 13732206
Error Message:
The specified service does not exist as an installed service.
User Action:
Check the spelling of the service name and then retype it. If you still get this message, contact your system administrator.

The above mention is the reason for the error.

Try removing SP4 and add to domain. Later you can upgrade SP4

0
 

Author Comment

by:carrilloeo
ID: 13737263
I tried reinstalling SP4 and still having the same problem

When SP4 was originally installed, the remove option "archive" was not installed
I reinstalled SP4 with the "archive" option inorder to uninstall it, but when I went to remove it from the add/remove programs, I was able to uninstall it but Windows remained at SP4

I am unable to uninstall SP4 or drop it down to a previous SP

I am noticing that after attempting to join the domain, it does add the domain suffix to the name and it does show in Active Directory if this helps

Does this have anything to do with SIDS?

Thanks
0
 

Author Comment

by:carrilloeo
ID: 13741515
I was finally able to change the computer name and join the domain
here is what had to be done

In safe mode I had to change the computer name (although it didnt appear to change)
rebooted into normal mode and had to change the name again (this time is appeared)
rebooted and uninstalled the following from the properties of the local area connection:

Client for Microsoft Networks
File and Print Sharing for Microsoft Networks
Internet Protocol (TCP/IP)

Rebooted

reinstalled the 3 stated above and rebooted again
then I was able to add the computer to the domain.

Thank you eveyone
0
 

Accepted Solution

by:
ee_ai_construct earned 0 total points
ID: 13774539
Question answered by asker or dialog deemed valuable.
Closed, 500 points refunded.
ee_ai_construct (replacement part #xm34)
Community Support Admin
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
Applications for our next round of the Experts Exchange Scholarship Contest are starting to roll in. It made us wonder what our past winners are up to these days. Here's a look at what four winners experienced with the contest and what they're doing…
Please read the paragraph below before following the instructions in the video — there are important caveats in the paragraph that I did not mention in the video. If your PaperPort 12 or PaperPort 14 is failing to start, or crashing, or hanging, …
Whether it be Exchange Server Crash Issues, Dirty Shutdown Errors or Failed to mount error, Stellar Phoenix Mailbox Exchange Recovery has always got your back. With the help of its easy to understand user interface and 3 simple steps recovery proced…
Suggested Courses

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question