Can't write Hello World ASP.NET program. Can't compile Cassini.

OK. I've just got Delphi 2005. Been a Delphi user for "decades". Know next to nothing about ASP and .net except basic concepts, being immersed in win32 device control software for a long while. Thought I'd just write a little ASP program to get started. Well, after several hours I am still nowhere.

Here's what I did ... Created a new "ASP.Net application - Delphi for .net" project. Accepted default project name and IIS server. Dropped a button and a label on the form. Wrote handler for button click which sets the label text. Pressed F9. It started IE with "http://localhost/WebApplication4/WebForm1.aspx" but showed  "The page cannot be displayed". After about 30 seconds, Delphi displayed the mssage "unable to start debugging on the web server. Unable to attach to ASP.NET worker process (typically aspnet_wp.exe or w3wp.exe)". Pressed Help and it said "No help found for context" which was not exactly helpful. Those exe files are not present on my system, which btw is XP Pro.

Based on the msg,I figure there is something wrong either with my .net environment or my IIS server. Pretty sure .net is OK, cause I ran some program from MS server which verified the setup.  

So I was going on the theory that there is some problem with IIS, of which I know little. I found the service “IIS Admin” running. Is that IIS? Sure sounds like. Tried starting, stopping, rebooting etc. No change to project errors. So I thought, since I did not want to learn all about IIS right now, that I might use the Cassini server instead which came with Delphi. It is touted as a much easier server to test with and administer. I tried to compile it with the build.bat file, but that died cause I don’t have csc.exe on my system which I presume is the C sharp compiler.

Please advise a course of action. Should I dig into IIS to see if it is really running etc? Do I really need to know much about IIS to program ASP apps? Should I compile and use Cassini instead? How to do that? Where do I get csc.exe?

Other comment – wow is this Delphi a pig or what? I’m running a 1.3ghz processor with 500mb of ram and it just crawls along under XP Pro and no other apps running. Where is the runfast option?

Thanks.

… Doug
LVL 1
doug_stephensAsked:
Who is Participating?
 
BlackTigerXConnect With a Mentor Commented:
the "IIS Admin Service" is the tool from where you can start your web services, ftp and SMTP (inetmgr.exe), notice that if you stop the IIS Admin Service, InetMgr will say that the connection to the machine has been lost
0
 
BlackTigerXCommented:
see my article about this issue:

http://www.delphi3000.com/articles/article_3876.asp

have you registered the .NET framework? try running this:
c:\windows\microsoft.net\framework\v1.1.4322\aspnet_regiis.exe -i

or

c:\winnt\microsoft.net\framework\v1.1.4322\aspnet_regiis.exe -i

by default .NET is installed, but not registered
0
 
doug_stephensAuthor Commented:
BlackTigerX,

I read your article. No improvements.

1. I don't have a proxy set up
2. My page does not run direct from browser either
3. Ran  your command to register .net. It sat at the DOS window for a minute then exited. I suppose that worked. But my project still gives same result, even after I exited and restarted Delphi.

Any other ideas?
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

 
calinutzCommented:
Check these out... maybe it helps
http://www.drbob42.com/examines/index.htm
0
 
doug_stephensAuthor Commented:
I solved this myself. I was looking at my IIS console and when I moused over the "Default Web Sites" it told me the web site was not running. So I started it from the context menu choice Start. I guess you have to start the site(s) as well as starting the service. Maybe I do need to read up on IIS.

Thanks.
0
 
BlackTigerXCommented:
so IIS was not started?...

yea... you better read a little bit about IIS...

the version that ships with XP is not very difficult though...
0
 
doug_stephensAuthor Commented:
When I looked at the Windows Services, it showed an entry for "IIS Admin" which was started. I opened it and saw my computer and a bunch of web apps I had tried to create. Based on that, I figured IIS was indeed started. However, later I looked there again and noticed that under IIS -> my computer -> Web Sites there was just one entry "Default Web Site" with a status of "Stopped". I started it, and that appeared to make my app work. Not sure why it was stopped or if I have to do this every time.

The Delphi docs do state that Cassini is much easier to debug. Any comments on that? And I still can't find a csc.exe to compile it with.
0
 
BlackTigerXCommented:
they say for Delphi is a lot better, I have not tried Cassini my self

as for the services, you can set the
"World Wide Web Publishing Service" to Automatic, and Start it and it will run by default when you start windows
0
 
doug_stephensAuthor Commented:
Thanks very much. I'm sure I'll be back now that I've made it to square one. Don't spend all the points in one place.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.